From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: X-Spam-Checker-Version: SpamAssassin 3.4.0 (2014-02-07) on aws-us-west-2-korg-lkml-1.web.codeaurora.org X-Spam-Level: X-Spam-Status: No, score=-3.8 required=3.0 tests=DKIM_INVALID,DKIM_SIGNED, HEADER_FROM_DIFFERENT_DOMAINS,MAILING_LIST_MULTI,SIGNED_OFF_BY,SPF_PASS autolearn=ham autolearn_force=no version=3.4.0 Received: from mail.kernel.org (mail.kernel.org [198.145.29.99]) by smtp.lore.kernel.org (Postfix) with ESMTP id 878A9C43381 for ; Mon, 4 Mar 2019 18:30:16 +0000 (UTC) Received: from vger.kernel.org (vger.kernel.org [209.132.180.67]) by mail.kernel.org (Postfix) with ESMTP id 55CE02070B for ; Mon, 4 Mar 2019 18:30:16 +0000 (UTC) Authentication-Results: mail.kernel.org; dkim=fail reason="signature verification failed" (1024-bit key) header.d=crapouillou.net header.i=@crapouillou.net header.b="OUggZ/k/" Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1727853AbfCDSaP (ORCPT ); Mon, 4 Mar 2019 13:30:15 -0500 Received: from outils.crapouillou.net ([89.234.176.41]:51912 "EHLO crapouillou.net" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1726162AbfCDSaO (ORCPT ); Mon, 4 Mar 2019 13:30:14 -0500 DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=crapouillou.net; s=mail; t=1551724211; h=from:from:sender:reply-to:subject:subject:date:date: message-id:message-id:to:to:cc:cc:mime-version:mime-version: content-type:content-type: content-transfer-encoding:content-transfer-encoding: in-reply-to:in-reply-to:references:references; bh=EsmaaCq8B4rgZWIMIgx7ZDtvqLzoJjOiO2PVEtrXTX8=; b=OUggZ/k/Wm5Ryfu5a4ItgJaiGppEE4L2XSvVdilrCJIC/jAzPdaVZVizFd2lGpGDo9VoUf ZcGfO/wcf/BC9sjXV4KxJ/qxcHwznGhMYiFDnAL6FUM+3sA+EdPKzwU5LxWoNGbl99i9GM DK5ysQUg/ZMgzACaZQky12O4d8SwPrY= Date: Mon, 04 Mar 2019 19:30:04 +0100 From: Paul Cercueil Subject: Re: [PATCH v4 8/9] mtd: rawnand: ingenic: Add support for the JZ4725B To: Miquel Raynal Cc: David Woodhouse , Brian Norris , Boris Brezillon , Marek Vasut , Richard Weinberger , Rob Herring , Mark Rutland , Harvey Hunt , linux-mtd@lists.infradead.org, devicetree@vger.kernel.org, linux-kernel@vger.kernel.org Message-Id: <1551724204.4932.6@crapouillou.net> In-Reply-To: <20190304113519.2e102b25@xps13> References: <20190209192305.4434-1-paul@crapouillou.net> <20190209192305.4434-8-paul@crapouillou.net> <20190304113519.2e102b25@xps13> MIME-Version: 1.0 Content-Type: text/plain; charset=iso-8859-1; format=flowed Content-Transfer-Encoding: quoted-printable Sender: linux-kernel-owner@vger.kernel.org Precedence: bulk List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Mon, Mar 4, 2019 at 11:35 AM, Miquel Raynal=20 wrote: > Hi Paul, >=20 > Paul Cercueil >=20 > wrote on Sat, 9 Feb 2019 16:23:04 > -0300: >=20 >> The boot ROM of the JZ4725B SoC expects a specific OOB layout on the >> NAND, so we use it unconditionally in the ingenic-nand driver. >>=20 >> Also add the jz4725b-bch driver to support the JZ4725B-specific BCH >> hardware. >>=20 >> Signed-off-by: Paul Cercueil > > >> --- >>=20 >> Changes: >>=20 >> v2: Instead of forcing the OOB layout, leave it to the board code or >> devicetree to decide if the jz4725b-specific layout should be=20 >> used >> or not. >>=20 >> v3: - Revert the change in v2, as the previous behaviour was=20 >> correct. >> - Also add support for the hardware BCH of the JZ4725B in this >> patch. >>=20 >> v4: - Add MODULE_* macros >> - Add tweaks suggested by upstream feedback >>=20 >> drivers/mtd/nand/raw/ingenic/Kconfig | 10 + >> drivers/mtd/nand/raw/ingenic/Makefile | 1 + >> drivers/mtd/nand/raw/ingenic/ingenic_nand.c | 48 ++++- >> drivers/mtd/nand/raw/ingenic/jz4725b_bch.c | 292=20 >> ++++++++++++++++++++++++++++ >> 4 files changed, 350 insertions(+), 1 deletion(-) >> create mode 100644 drivers/mtd/nand/raw/ingenic/jz4725b_bch.c >>=20 >=20 > [...] >=20 >> +static int jz4725b_calculate(struct ingenic_ecc *bch, >> + struct ingenic_ecc_params *params, >> + const u8 *buf, u8 *ecc_code) >> +{ >> + int ret; >> + >> + mutex_lock(&bch->lock); >> + ret =3D jz4725b_bch_init(bch, params, true); >=20 > I really don't like this bch_init name. A BCH initialization is what=20 > is > supposed to be done only once (probably at boot time), can you find a > better name or a better organization of the correct/calculate path? jz4725b_bch_setup() maybe? >> + if (ret) { >> + dev_err(bch->dev, "Unable to init BCH with given parameters\n"); >> + goto out_disable; >> + } >> + >> + jz4725b_bch_write_data(bch, buf, params->size); >> + >> + ret =3D jz4725b_bch_wait_complete(bch, BCH_BHINT_ENCF, NULL); >> + if (ret) { >> + dev_err(bch->dev, "timed out while calculating ECC\n"); >> + goto out_disable; >> + } >> + >> + jz4725b_bch_read_parity(bch, ecc_code, params->bytes); >> + >> +out_disable: >> + jz4725b_bch_disable(bch); >> + mutex_unlock(&bch->lock); >> + >> + return ret; >> +} >> + >=20 > [...] >=20 > Thanks, > Miqu=E8l =