From: Chunfeng Yun <chunfeng.yun@mediatek.com>
To: Rob Herring <robh+dt@kernel.org>,
Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
Heikki Krogerus <heikki.krogerus@linux.intel.com>
Cc: Mark Rutland <mark.rutland@arm.com>,
Chunfeng Yun <chunfeng.yun@mediatek.com>,
Matthias Brugger <matthias.bgg@gmail.com>,
Adam Thomson <Adam.Thomson.Opensource@diasemi.com>,
Li Jun <jun.li@nxp.com>,
Badhri Jagan Sridharan <badhri@google.com>,
Hans de Goede <hdegoede@redhat.com>,
Andy Shevchenko <andy.shevchenko@gmail.com>,
Min Guo <min.guo@mediatek.com>, <devicetree@vger.kernel.org>,
<linux-kernel@vger.kernel.org>, <linux-usb@vger.kernel.org>,
<linux-arm-kernel@lists.infradead.org>,
<linux-mediatek@lists.infradead.org>,
Biju Das <biju.das@bp.renesas.com>,
Linus Walleij <linus.walleij@linaro.org>
Subject: [v4 PATCH 0/6] add USB Type-B GPIO connector driver
Date: Fri, 26 Apr 2019 14:47:11 +0800 [thread overview]
Message-ID: <1556261237-13823-1-git-send-email-chunfeng.yun@mediatek.com> (raw)
Because the USB Connector is introduced and the requirement of
usb-connector.txt binding, the old way using extcon to support
USB Dual-Role switch is now deprecated, meanwhile there is no
available common driver when use Type-B connector, typically
using an input GPIO to detect USB ID pin.
This patch series introduce a Type-B GPIO connector driver and try
to replace the function provided by extcon-usb-gpio driver.
v4 changes:
1. use switch_fwnode_match() to find fwnode suggested by Heikki
2. assign fwnode member of usb_role_switch struct suggested by Heikki
3. make [4/6] depend on [2]
3. remove linux/gpio.h suggested by Linus
4. put node when error happens
[4/6] usb: roles: add API to get usb_role_switch by node
[2] [v6,08/13] usb: roles: Introduce stubs for the exiting functions in role.h
https://patchwork.kernel.org/patch/10909971/
v3 changes:
1. add GPIO direction, and use fixed-regulator for GPIO controlled
VBUS regulator suggested by Rob;
2. rebuild fwnode_usb_role_switch_get() suggested by Andy and Heikki
3. treat the type-B connector as a virtual device;
4. change file name of driver again
5. select USB_ROLE_SWITCH in mtu3/Kconfig suggested by Heikki
6. rename ssusb_mode_manual_switch() to ssusb_mode_switch()
v2 changes:
1. make binding clear, and add a extra compatible suggested by Hans
Chunfeng Yun (6):
dt-bindings: connector: add optional properties for Type-B
dt-bindings: usb: add binding for Type-B GPIO connector driver
dt-bindings: usb: mtu3: add properties about USB Role Switch
usb: roles: add API to get usb_role_switch by node
usb: roles: add USB Type-B GPIO connector driver
usb: mtu3: register a USB Role Switch for dual role mode
.../bindings/connector/usb-connector.txt | 14 +
.../devicetree/bindings/usb/mediatek,mtu3.txt | 10 +-
.../bindings/usb/typeb-conn-gpio.txt | 49 +++
drivers/usb/mtu3/Kconfig | 1 +
drivers/usb/mtu3/mtu3.h | 5 +
drivers/usb/mtu3/mtu3_debugfs.c | 4 +-
drivers/usb/mtu3/mtu3_dr.c | 48 ++-
drivers/usb/mtu3/mtu3_dr.h | 6 +-
drivers/usb/mtu3/mtu3_plat.c | 3 +-
drivers/usb/roles/Kconfig | 11 +
drivers/usb/roles/Makefile | 1 +
drivers/usb/roles/class.c | 25 ++
drivers/usb/roles/typeb-conn-gpio.c | 305 ++++++++++++++++++
include/linux/usb/role.h | 8 +
14 files changed, 481 insertions(+), 9 deletions(-)
create mode 100644 Documentation/devicetree/bindings/usb/typeb-conn-gpio.txt
create mode 100644 drivers/usb/roles/typeb-conn-gpio.c
--
2.21.0
next reply other threads:[~2019-04-26 6:48 UTC|newest]
Thread overview: 18+ messages / expand[flat|nested] mbox.gz Atom feed top
2019-04-26 6:47 Chunfeng Yun [this message]
2019-04-26 6:47 ` [PATCH v4 1/6] dt-bindings: connector: add optional properties for Type-B Chunfeng Yun
2019-04-26 13:19 ` Rob Herring
2019-04-26 6:47 ` [PATCH v4 2/6] dt-bindings: usb: add binding for Type-B GPIO connector driver Chunfeng Yun
2019-04-26 20:45 ` Rob Herring
2019-04-28 1:50 ` Chunfeng Yun
2019-04-26 6:47 ` [PATCH v4 3/6] dt-bindings: usb: mtu3: add properties about USB Role Switch Chunfeng Yun
2019-04-26 20:49 ` Rob Herring
2019-04-28 12:16 ` Chunfeng Yun
2019-04-29 16:25 ` Rob Herring
2019-04-30 6:57 ` Chunfeng Yun
2019-04-26 6:47 ` [PATCH v4 4/6] usb: roles: add API to get usb_role_switch by node Chunfeng Yun
2019-04-26 7:02 ` Biju Das
2019-04-26 7:16 ` Chunfeng Yun
2019-04-26 6:47 ` [PATCH v4 5/6] usb: roles: add USB Type-B GPIO connector driver Chunfeng Yun
2019-04-26 9:22 ` Biju Das
2019-04-28 9:26 ` Chunfeng Yun
2019-04-26 6:47 ` [PATCH v4 6/6] usb: mtu3: register a USB Role Switch for dual role mode Chunfeng Yun
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1556261237-13823-1-git-send-email-chunfeng.yun@mediatek.com \
--to=chunfeng.yun@mediatek.com \
--cc=Adam.Thomson.Opensource@diasemi.com \
--cc=andy.shevchenko@gmail.com \
--cc=badhri@google.com \
--cc=biju.das@bp.renesas.com \
--cc=devicetree@vger.kernel.org \
--cc=gregkh@linuxfoundation.org \
--cc=hdegoede@redhat.com \
--cc=heikki.krogerus@linux.intel.com \
--cc=jun.li@nxp.com \
--cc=linus.walleij@linaro.org \
--cc=linux-arm-kernel@lists.infradead.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-mediatek@lists.infradead.org \
--cc=linux-usb@vger.kernel.org \
--cc=mark.rutland@arm.com \
--cc=matthias.bgg@gmail.com \
--cc=min.guo@mediatek.com \
--cc=robh+dt@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®