From: Wang Qing <wangqing@vivo.com>
To: Ingo Molnar <mingo@redhat.com>,
Peter Zijlstra <peterz@infradead.org>,
Juri Lelli <juri.lelli@redhat.com>,
Vincent Guittot <vincent.guittot@linaro.org>,
Dietmar Eggemann <dietmar.eggemann@arm.com>,
Steven Rostedt <rostedt@goodmis.org>,
Ben Segall <bsegall@google.com>, Mel Gorman <mgorman@suse.de>,
linux-kernel@vger.kernel.org
Cc: opensource.kernel@vivo.com
Subject: Re: [PATCH 1/2] [V2 1/2]sched:add task_running_oncpu
Date: Tue, 14 Apr 2020 17:47:12 +0800 [thread overview]
Message-ID: <1586857633-2747-1-git-send-email-wangqing@vivo.com> (raw)
In-Reply-To: <1586779466-4439-2-git-send-email-wangqing@vivo.com>
>On Mon, 13 Apr 2020 at 14:04, Wang Qing <wangqing@vivo.com> wrote:
>>
>> We have no interface whether the task is running,
>> so we need to add an interface and distinguish CONFIG_SMP.
>>
>> Signed-off-by: Wang Qing <wangqing@vivo.com>
>> ---
>> include/linux/sched.h | 10 ++++++++++
>> 1 file changed, 10 insertions(+)
>>
>> diff --git a/include/linux/sched.h b/include/linux/sched.h
>> index 4418f5c..13cc8f5 100644
>> --- a/include/linux/sched.h
>> +++ b/include/linux/sched.h
>> @@ -1843,6 +1843,11 @@ static inline unsigned int task_cpu(const struct task_struct *p)
>>
>> extern void set_task_cpu(struct task_struct *p, unsigned int cpu);
>>
>> +static inline int task_running_oncpu(const struct task_struct *p)
>
>This function name is too close from task_running_on_cpu() and can be
>misleading as the difference is only "_"
>Also, how task_running_oncpu() is different from task_running() ?
I think task_running() should be renamed to task_running_on_rq(), this is what
it originally mean. And the task_running_oncpu I added should be called
task_running(). This solves the confusing naming problem that already exists.
Thanks,
Wang Qing.
>
>> +{
>> + return p->on_cpu;
>> +}
>> +
>> #else
>>
>> static inline unsigned int task_cpu(const struct task_struct *p)
>> @@ -1854,6 +1859,11 @@ static inline void set_task_cpu(struct task_struct *p, unsigned int cpu)
>> {
>> }
>>
>> +static inline int task_running_oncpu(const struct task_struct *p)
>> +{
>> + return p == current;
>> +}
>> +
>> #endif /* CONFIG_SMP */
>>
>> /*
>> --
>> 2.7.4
>>
next prev parent reply other threads:[~2020-04-14 9:58 UTC|newest]
Thread overview: 7+ messages / expand[flat|nested] mbox.gz Atom feed top
2020-04-13 12:04 [PATCH 0/2] fixed dump_backtrace() when task running on another cpu Wang Qing
2020-04-13 12:04 ` [PATCH 1/2] [V2 1/2]sched:add task_running_oncpu Wang Qing
2020-04-14 7:20 ` Vincent Guittot
2020-04-14 10:05 ` Peter Zijlstra
2020-04-14 9:47 ` Wang Qing [this message]
2020-04-15 8:34 ` Wang Qing
2020-04-13 12:04 ` [PATCH 2/2] [V2 2/2]ARM64:fixed dump_backtrace() when task running on another cpu Wang Qing
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1586857633-2747-1-git-send-email-wangqing@vivo.com \
--to=wangqing@vivo.com \
--cc=bsegall@google.com \
--cc=dietmar.eggemann@arm.com \
--cc=juri.lelli@redhat.com \
--cc=linux-kernel@vger.kernel.org \
--cc=mgorman@suse.de \
--cc=mingo@redhat.com \
--cc=opensource.kernel@vivo.com \
--cc=peterz@infradead.org \
--cc=rostedt@goodmis.org \
--cc=vincent.guittot@linaro.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®