From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1753437AbbIQJnt (ORCPT ); Thu, 17 Sep 2015 05:43:49 -0400 Received: from gloria.sntech.de ([95.129.55.99]:49820 "EHLO gloria.sntech.de" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1753295AbbIQJns (ORCPT ); Thu, 17 Sep 2015 05:43:48 -0400 From: Heiko =?ISO-8859-1?Q?St=FCbner?= To: Caesar Wang Cc: Daniel Lezcano , Catalin Marinas , Will Deacon , Caesar Wang , linux-rockchip@lists.infradead.org, Thomas Gleixner , linux-kernel@vger.kernel.org, linux-arm-kernel@lists.infradead.org Subject: Re: [PATCH 1/3] clocksource: rockchip: Make the driver more readability and compatible Date: Thu, 17 Sep 2015 11:43:44 +0200 Message-ID: <1595765.iIuZsGWCYG@diego> User-Agent: KMail/4.14.10 (Linux/4.1.0-2-amd64; KDE/4.14.10; x86_64; ; ) In-Reply-To: <55FA87AA.4040807@gmail.com> References: <1442476272-31723-1-git-send-email-wxt@rock-chips.com> <55FA83D5.9010504@linaro.org> <55FA87AA.4040807@gmail.com> MIME-Version: 1.0 Content-Transfer-Encoding: 7Bit Content-Type: text/plain; charset="us-ascii" Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org Hi, Am Donnerstag, 17. September 2015, 17:28:10 schrieb Caesar Wang: > >> The problem was different semantics of dsb on btw arm32 and arm64, > >> Here we can convert the dsb with insteading of dsb(sy). > > > > What happens to ARM32 then ? > > The dsb() is ok for ARM32, the ARM32/64 are OK if we can convert the > dsb() to dsb(sy). > I believe all drivers with 'dsb()' have same issue on ARM64 platform. correct ... I read this up in the ARM docs 2 days ago too for something. The "sy" param is the default, which you are allow to omit, so on arm32 dsb() and dsb(sy) are the same. Heiko