From: Luo Jiaxing <luojiaxing@huawei.com>
To: <akpm@linux-foundation.org>, <viro@zeniv.linux.org.uk>,
<andriy.shevchenko@linux.intel.com>
Cc: <linux-kernel@vger.kernel.org>, <martin.petersen@oracle.com>,
<john.garry@huawei.com>, <himanshu.madhani@cavium.com>,
<felipe.balbi@linux.intel.com>, <gregkh@linuxfoundation.org>,
<uma.shankar@intel.com>, <anshuman.gupta@intel.com>,
<animesh.manna@intel.com>, <linux-usb@vger.kernel.org>,
<linux-scsi@vger.kernel.org>, <linuxarm@huawei.com>
Subject: [PATCH v1 0/5] Introduce a new helper marco DEFINE_STORE_ATTRIBUTE at seq_file.c
Date: Thu, 22 Oct 2020 16:39:52 +0800 [thread overview]
Message-ID: <1603355997-32350-1-git-send-email-luojiaxing@huawei.com> (raw)
We already own DEFINE_SHOW_ATTRIBUTE() helper macro for defining attribute
for read-only file, but we found many of drivers also want a helper marco for
read-write file too.
So we try to add this macro to help decrease code duplication.
Luo Jiaxing (5):
seq_file: Introduce DEFINE_STORE_ATTRIBUTE() helper macro
scsi: hisi_sas: Introduce DEFINE_STORE_ATTRIBUTE for debugfs
scsi: qla2xxx: Introduce DEFINE_STORE_ATTRIBUTE for debugfs
usb: dwc3: debugfs: Introduce DEFINE_STORE_ATTRIBUTE
drm/i915/display: Introduce DEFINE_STORE_ATTRIBUTE for debugfs
.../gpu/drm/i915/display/intel_display_debugfs.c | 55 +--------
drivers/scsi/hisi_sas/hisi_sas_main.c | 135 +++------------------
drivers/scsi/qla2xxx/qla_dfs.c | 19 +--
drivers/usb/dwc3/debugfs.c | 52 +-------
include/linux/seq_file.h | 15 +++
5 files changed, 41 insertions(+), 235 deletions(-)
--
2.7.4
next reply other threads:[~2020-10-22 8:39 UTC|newest]
Thread overview: 11+ messages / expand[flat|nested] mbox.gz Atom feed top
2020-10-22 8:39 Luo Jiaxing [this message]
2020-10-22 8:39 ` [PATCH v1 1/5] seq_file: Introduce DEFINE_STORE_ATTRIBUTE() helper macro Luo Jiaxing
2020-10-22 14:22 ` Andy Shevchenko
2020-10-23 8:53 ` luojiaxing
2020-10-22 8:39 ` [PATCH v1 2/5] scsi: hisi_sas: Introduce DEFINE_STORE_ATTRIBUTE for debugfs Luo Jiaxing
2020-10-22 8:39 ` [PATCH v1 3/5] scsi: qla2xxx: " Luo Jiaxing
2020-10-22 8:39 ` [PATCH v1 4/5] usb: dwc3: debugfs: Introduce DEFINE_STORE_ATTRIBUTE Luo Jiaxing
2020-10-22 8:39 ` [PATCH v1 5/5] drm/i915/display: Introduce DEFINE_STORE_ATTRIBUTE for debugfs Luo Jiaxing
2020-10-22 11:14 ` kernel test robot
2020-10-22 12:28 ` [PATCH v1 0/5] Introduce a new helper marco DEFINE_STORE_ATTRIBUTE at seq_file.c Al Viro
2020-10-23 6:29 ` luojiaxing
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1603355997-32350-1-git-send-email-luojiaxing@huawei.com \
--to=luojiaxing@huawei.com \
--cc=akpm@linux-foundation.org \
--cc=andriy.shevchenko@linux.intel.com \
--cc=animesh.manna@intel.com \
--cc=anshuman.gupta@intel.com \
--cc=felipe.balbi@linux.intel.com \
--cc=gregkh@linuxfoundation.org \
--cc=himanshu.madhani@cavium.com \
--cc=john.garry@huawei.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-scsi@vger.kernel.org \
--cc=linux-usb@vger.kernel.org \
--cc=linuxarm@huawei.com \
--cc=martin.petersen@oracle.com \
--cc=uma.shankar@intel.com \
--cc=viro@zeniv.linux.org.uk \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®