mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: "Rafael J. Wysocki" <rjw@sisk.pl>
To: Nishanth Menon <nm@ti.com>
Cc: Randy Dunlap <rdunlap@infradead.org>,
	Viresh Kumar <viresh.kumar@linaro.org>,
	pavel@ucw.cz, linaro-kernel@lists.linaro.org, patches@linaro.org,
	linux-pm@vger.kernel.org, linux-kernel@vger.kernel.org
Subject: Re: OPP: rename functions? (was [PATCH] OPP: Export opp_add())
Date: Tue, 06 Aug 2013 16:15:17 +0200	[thread overview]
Message-ID: <1611420.5h2rr9N0mt@vostro.rjw.lan> (raw)
In-Reply-To: <20130806130820.GA6035@kahuna>

On Tuesday, August 06, 2013 08:08:20 AM Nishanth Menon wrote:
> change in subject to reflect new discussion.
> 
> On 05:53-20130806, Randy Dunlap wrote:
> > On 08/03/2013 02:25 AM, Viresh Kumar wrote:
> > >Export opp_add() so that modules can use it.
> > >
> > >Signed-off-by: Viresh Kumar <viresh.kumar@linaro.org>
> > >---
> > >  drivers/base/power/opp.c | 1 +
> > >  1 file changed, 1 insertion(+)
> > >
> > >diff --git a/drivers/base/power/opp.c b/drivers/base/power/opp.c
> > >index c8ec186..ef89897 100644
> > >--- a/drivers/base/power/opp.c
> > >+++ b/drivers/base/power/opp.c
> > >@@ -460,6 +460,7 @@ int opp_add(struct device *dev, unsigned long freq, unsigned long u_volt)
> > >  	srcu_notifier_call_chain(&dev_opp->head, OPP_EVENT_ADD, new_opp);
> > >  	return 0;
> > >  }
> > >+EXPORT_SYMBOL_GPL(opp_add);
> > 
> > Could it be renamed to pm_opp_add() or power_opp_add() ?
> > The name is a bit too unspecific IMO.
> Though this has nothing specific with this patch, an interesting point.
> 
> git grep -w opp . showed drivers/tty/n_tty.c,
> drivers/sbus/char/openprom.c and arch/powerpc/kvm/mpic.c using
> variables named opp to mean what ever they had in context. rest(around
> 40 odd files) seem to use opp as in Documentation/power/opp.txt..
> 
> We could go with a pm_ prefix or even dev_pm_opp_ prefix to be more
> specific, though I prefer just pm_. If Rafael and others are ok, I can
> post a series out.

Yup, that would be useful.  I'm for dev_pm_opp_ if that matters.

Thanks,
Rafael


  reply	other threads:[~2013-08-06 14:05 UTC|newest]

Thread overview: 10+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2013-08-03  9:25 [PATCH] OPP: Export opp_add() Viresh Kumar
2013-08-05 12:29 ` Nishanth Menon
2013-08-05 12:47   ` Rafael J. Wysocki
2013-08-06  4:48     ` Viresh Kumar
2013-08-06 12:53 ` Randy Dunlap
2013-08-06 13:08   ` OPP: rename functions? (was [PATCH] OPP: Export opp_add()) Nishanth Menon
2013-08-06 14:15     ` Rafael J. Wysocki [this message]
2013-08-07 15:48       ` Nishanth Menon
2013-08-07 22:53         ` Rafael J. Wysocki
2013-08-08 12:00           ` Nishanth Menon

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1611420.5h2rr9N0mt@vostro.rjw.lan \
    --to=rjw@sisk.pl \
    --cc=linaro-kernel@lists.linaro.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-pm@vger.kernel.org \
    --cc=nm@ti.com \
    --cc=patches@linaro.org \
    --cc=pavel@ucw.cz \
    --cc=rdunlap@infradead.org \
    --cc=viresh.kumar@linaro.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®