From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: X-Spam-Checker-Version: SpamAssassin 3.4.0 (2014-02-07) on aws-us-west-2-korg-lkml-1.web.codeaurora.org Received: from vger.kernel.org (vger.kernel.org [23.128.96.18]) by smtp.lore.kernel.org (Postfix) with ESMTP id 87CDDC4167B for ; Tue, 5 Dec 2023 11:43:29 +0000 (UTC) Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1345277AbjLELnU (ORCPT ); Tue, 5 Dec 2023 06:43:20 -0500 Received: from lindbergh.monkeyblade.net ([23.128.96.19]:41956 "EHLO lindbergh.monkeyblade.net" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1345204AbjLELnR (ORCPT ); Tue, 5 Dec 2023 06:43:17 -0500 Received: from madras.collabora.co.uk (madras.collabora.co.uk [46.235.227.172]) by lindbergh.monkeyblade.net (Postfix) with ESMTPS id 3A196CA for ; Tue, 5 Dec 2023 03:43:24 -0800 (PST) Received: from [10.3.2.161] (zone.collabora.co.uk [167.235.23.81]) (using TLSv1.3 with cipher TLS_AES_128_GCM_SHA256 (128/128 bits) key-exchange X25519 server-signature RSA-PSS (4096 bits) server-digest SHA256) (No client certificate requested) (Authenticated sender: dmitry.osipenko) by madras.collabora.co.uk (Postfix) with ESMTPSA id 0A9226607285; Tue, 5 Dec 2023 11:43:20 +0000 (GMT) DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/simple; d=collabora.com; s=mail; t=1701776602; bh=T5YH2R7k3v7oNwt6oxlEQ3qJ8fug5UIPB3Ee0qCYPyc=; h=Date:Subject:To:Cc:References:From:In-Reply-To:From; b=C3BtgxMoFe4jZE8nI2I63xvj8t3qn7XmQ+fMUv9x6aoKQQGHY4pYwGpA2bnd+GKtF 7of7PgxiKl3Y3djyYR1+HPNFnL+dRNpa/Q5NJCrkGvl9SYuqLFgSk0Zwbq6ibSkISg I5J+MjBw5ezTGAKEypX5Gv4BxTcc8pn6pS4cLSvy1koJpVCWAdUrx7piLT0kAfLJxl 0xDW6BUK7y9w6MTiD7d88ATIgI+JjfzOLU/4AkF4wHGfzjK7vSW+4PE9p+bhw6u7SE If49Q5yOi/LminYeRZRGCARxlepcIDPUf2WSQOutSSwiWIwKvHkkmJN/vodUrFjuzp BYJAncjgRQEvw== Message-ID: <161189c2-db65-2542-5d19-77a56b56cfac@collabora.com> Date: Tue, 5 Dec 2023 14:43:16 +0300 MIME-Version: 1.0 User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:102.0) Gecko/20100101 Thunderbird/102.15.1 Subject: Re: [PATCH v18 04/26] drm/shmem-helper: Refactor locked/unlocked functions Content-Language: en-US To: Maxime Ripard , Boris Brezillon Cc: David Airlie , Gerd Hoffmann , Gurchetan Singh , Chia-I Wu , Daniel Vetter , Maarten Lankhorst , Thomas Zimmermann , =?UTF-8?Q?Christian_K=c3=b6nig?= , Qiang Yu , Steven Price , Emma Anholt , Melissa Wen , dri-devel@lists.freedesktop.org, linux-kernel@vger.kernel.org, kernel@collabora.com, virtualization@lists.linux-foundation.org References: <20231124115911.79ab24af@collabora.com> <20231128133712.53a6f6cb@collabora.com> <37208c72-7908-0a78-fc89-2fa9b8d756a5@collabora.com> <20231129085330.7ccb35d3@collabora.com> <20231129144609.7544e773@collabora.com> <6da6mzwfzwbn5rhiebypo5e2v6rhtpn2fovwvfnoo333zjgobf@bgtuwhum3trp> <20231129164705.7461a294@collabora.com> From: Dmitry Osipenko In-Reply-To: Content-Type: text/plain; charset=UTF-8 Content-Transfer-Encoding: 7bit Precedence: bulk List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On 12/4/23 15:55, Maxime Ripard wrote: >> Okay, that means s/_locked/_nolock/ in drm_gem_shmem_helpers.{c,h}, I >> guess. DRM subsys and majority of kernel uses common _locked postfix. We should retain the old naming scheme by using _locked() in DRM. It's not worthwhile changing the name to a much less popular variant for a no good reason. Maxime, are you okay with keeping the _locked name? -- Best regards, Dmitry