From: Rik Faith <faith@redhat.com>
To: Chris Wright <chrisw@osdl.org>
Cc: linux-kernel@vger.kernel.org
Subject: Re: [PATCH][RFC] Light-weight Auditing Framework
Date: Wed, 3 Mar 2004 05:57:39 -0500 [thread overview]
Message-ID: <16453.47651.915651.491105@neuro.alephnull.com> (raw)
In-Reply-To: [Chris Wright <chrisw@osdl.org>] Tue 2 Mar 2004 16:49:51 -0800
On Tue 2 Mar 2004 16:49:51 -0800,
Chris Wright <chrisw@osdl.org> wrote:
> * Rik Faith (faith@redhat.com) wrote:
> > > Doesn't seem like CONFIG_AUDIT=n disables all the code.
> >
> > The bit tests in entry.S are still there, but those are the same tests
> > that are used for ptrace, and there is nothing that sets the bits. So,
> > aside from that test, all of the code should be disabled.
>
> I think, e.g. the code that calls audit_get/putname is still there.
When syscall auditing is disabled, the body of the if will become a nop
because of a #define, so the compiler will remove the whole if. I don't
want to move the if into a macro, since this would make it look like the
function was called all the time. I don't want the if in the function
because I'm trying not to call the function except when necessary.
I could put #ifdef CONFIG_AUDITSYSCALL around these statements, but I
find that often makes code harder to read. However, in this case, that
might avoid some confusion.
> > Except where noted below, I have either incorporated all your
> > suggestions or made notes in the code to do so later. The new patch is
> > at: http://people.redhat.com/faith/audit/audit-20040302.1632.patch
>
> Oops, I wasn't clear re: the static initialized data...
Yes, sorry, please see:
http://people.redhat.com/faith/audit/audit-20040303.0544.patch
prev parent reply other threads:[~2004-03-03 10:57 UTC|newest]
Thread overview: 12+ messages / expand[flat|nested] mbox.gz Atom feed top
2004-03-01 16:28 Rik Faith
2004-03-01 19:45 ` Christoph Hellwig
2004-03-01 20:28 ` Rik Faith
2004-03-02 9:44 ` Olaf Kirch
2004-03-02 11:09 ` Rik Faith
2004-03-02 15:02 ` Rik Faith
2004-03-03 8:55 ` Muli Ben-Yehuda
2004-03-03 11:21 ` Rik Faith
2004-03-01 20:26 ` Chris Wright
2004-03-02 21:49 ` Rik Faith
2004-03-03 0:49 ` Chris Wright
2004-03-03 10:57 ` Rik Faith [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=16453.47651.915651.491105@neuro.alephnull.com \
--to=faith@redhat.com \
--cc=chrisw@osdl.org \
--cc=linux-kernel@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®