mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Rob Herring <robh@kernel.org>
To: Colin Foster <colin.foster@in-advantage.com>
Cc: "Krzysztof Kozlowski" <krzysztof.kozlowski+dt@linaro.org>,
	"Marek Vasut" <marex@denx.de>,
	UNGLinuxDriver@microchip.com, "John Crispin" <john@phrozen.org>,
	linux-kernel@vger.kernel.org,
	"Alvin Šipraga" <alsi@bang-olufsen.dk>,
	"Landen Chao" <Landen.Chao@mediatek.com>,
	"Paolo Abeni" <pabeni@redhat.com>,
	linux-mediatek@lists.infradead.org,
	"Woojung Huh" <woojung.huh@microchip.com>,
	"David S. Miller" <davem@davemloft.net>,
	"nç ÜNAL" <arinc.unal@arinc9.com>,
	"Rob Herring" <robh+dt@kernel.org>,
	linux-renesas-soc@vger.kernel.org,
	"Sean Wang" <sean.wang@mediatek.com>,
	"Linus Walleij" <linus.walleij@linaro.org>,
	"Claudiu Manoil" <claudiu.manoil@nxp.com>,
	"Eric Dumazet" <edumazet@google.com>,
	devicetree@vger.kernel.org,
	"Kurt Kanzenbach" <kurt@linutronix.de>,
	linux-arm-kernel@lists.infradead.org,
	"Florian Fainelli" <f.fainelli@gmail.com>, ",
	DENG Qingfang" <dqfext@gmail.com>, "Andrew Lunn" <andrew@lunn.ch>,
	"George McCollister" <george.mccollister@gmail.com>,
	"Jakub Kicinski" <kuba@kernel.org>,
	"Vivien Didelot" <vivien.didelot@gmail.com>,
	"Matthias Brugger" <matthias.bgg@gmail.com>,
	netdev@vger.kernel.org, "Vladimir Oltean" <olteanv@gmail.com>,
	"Clément Léger" <clement.leger@bootlin.com>,
	"Alexandre Belloni" <alexandre.belloni@bootlin.com>
Subject: Re: [PATCH v4 net-next 3/9] dt-bindings: net: dsa: utilize base definitions for standard dsa switches
Date: Mon, 5 Dec 2022 15:42:10 -0600	[thread overview]
Message-ID: <167027652411.2674430.15313904791062984653.robh@kernel.org> (raw)
In-Reply-To: <20221202204559.162619-4-colin.foster@in-advantage.com>


On Fri, 02 Dec 2022 12:45:53 -0800, Colin Foster wrote:
> DSA switches can fall into one of two categories: switches where all ports
> follow standard '(ethernet-)?port' properties, and switches that have
> additional properties for the ports.
> 
> The scenario where DSA ports are all standardized can be handled by
> swtiches with a reference to the new 'dsa.yaml#/$defs/ethernet-ports'.
> 
> The scenario where DSA ports require additional properties can reference
> '$dsa.yaml#' directly. This will allow switches to reference these standard
> defitions of the DSA switch, but add additional properties under the port
> nodes.
> 
> Suggested-by: Rob Herring <robh@kernel.org>
> Signed-off-by: Colin Foster <colin.foster@in-advantage.com>
> Reviewed-by: Linus Walleij <linus.walleij@linaro.org>
> Reviewed-by: Florian Fainelli <f.fainelli@gmail.com>
> Acked-by: Alvin Šipraga <alsi@bang-olufsen.dk> # realtek
> ---
> 
> v3 -> v4
>   * Rename "$defs/base" to "$defs/ethernet-ports" to avoid implication of a
>     "base class" and fix commit message accordingly
>   * Add the following to the common etherent-ports node:
>       "additionalProperties: false"
>       "#address-cells" property
>       "#size-cells" property
>   * Fix "etherenet-ports@[0-9]+" to correctly be "ethernet-port@[0-9]+"
>   * Remove unnecessary newline
>   * Apply changes to mediatek,mt7530.yaml that were previously in a separate patch
>   * Add Reviewed and Acked tags
> 
> v3
>   * New patch
> 
> ---
>  .../bindings/net/dsa/arrow,xrs700x.yaml       |  2 +-
>  .../devicetree/bindings/net/dsa/brcm,b53.yaml |  2 +-
>  .../devicetree/bindings/net/dsa/dsa.yaml      | 25 ++++++++++++++++---
>  .../net/dsa/hirschmann,hellcreek.yaml         |  2 +-
>  .../bindings/net/dsa/mediatek,mt7530.yaml     | 16 +++---------
>  .../bindings/net/dsa/microchip,ksz.yaml       |  2 +-
>  .../bindings/net/dsa/microchip,lan937x.yaml   |  2 +-
>  .../bindings/net/dsa/mscc,ocelot.yaml         |  2 +-
>  .../bindings/net/dsa/nxp,sja1105.yaml         |  2 +-
>  .../devicetree/bindings/net/dsa/realtek.yaml  |  2 +-
>  .../bindings/net/dsa/renesas,rzn1-a5psw.yaml  |  2 +-
>  11 files changed, 35 insertions(+), 24 deletions(-)
> 

Reviewed-by: Rob Herring <robh@kernel.org>

  parent reply	other threads:[~2022-12-05 21:43 UTC|newest]

Thread overview: 27+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2022-12-02 20:45 [PATCH v4 net-next 0/9] dt-binding preparation for ocelot switches Colin Foster
2022-12-02 20:45 ` [PATCH v4 net-next 1/9] dt-bindings: net: dsa: sf2: fix brcm,use-bcm-hdr documentation Colin Foster
2022-12-02 20:45 ` [PATCH v4 net-next 2/9] dt-bindings: net: dsa: qca8k: remove address-cells and size-cells from switch node Colin Foster
2022-12-02 20:45 ` [PATCH v4 net-next 3/9] dt-bindings: net: dsa: utilize base definitions for standard dsa switches Colin Foster
2022-12-02 21:45   ` Arınç ÜNAL
2022-12-06  2:20     ` Colin Foster
2022-12-05 18:29       ` Arınç ÜNAL
2022-12-05 21:42   ` Rob Herring [this message]
2022-12-06 15:18   ` Vladimir Oltean
2022-12-07  2:24     ` Colin Foster
2022-12-06 15:37   ` Vladimir Oltean
2022-12-07  2:27     ` Colin Foster
2022-12-09  9:10   ` Krzysztof Kozlowski
2022-12-02 20:45 ` [PATCH v4 net-next 4/9] dt-bindings: net: dsa: allow additional ethernet-port properties Colin Foster
2022-12-02 20:45 ` [PATCH v4 net-next 5/9] dt-bindings: net: dsa: qca8k: utilize shared dsa.yaml Colin Foster
2022-12-05 21:42   ` Rob Herring
2022-12-02 20:45 ` [PATCH v4 net-next 6/9] dt-bindings: net: dsa: mediatek,mt7530: remove unnecessary dsa-port reference Colin Foster
2022-12-05 21:44   ` Rob Herring
2022-12-02 20:45 ` [PATCH v4 net-next 7/9] dt-bindings: net: add generic ethernet-switch Colin Foster
2022-12-05 21:47   ` Rob Herring
2022-12-02 20:45 ` [PATCH v4 net-next 8/9] dt-bindings: net: add generic ethernet-switch-port binding Colin Foster
2022-12-05 21:45   ` Rob Herring
2022-12-06 15:50   ` Vladimir Oltean
2022-12-07  2:49     ` Colin Foster
2022-12-02 20:45 ` [PATCH v4 net-next 9/9] dt-bindings: net: mscc,vsc7514-switch: utilize generic ethernet-switch.yaml Colin Foster
2022-12-06 16:04 ` [PATCH v4 net-next 0/9] dt-binding preparation for ocelot switches Vladimir Oltean
2022-12-07  3:07   ` Colin Foster

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=167027652411.2674430.15313904791062984653.robh@kernel.org \
    --to=robh@kernel.org \
    --cc=Landen.Chao@mediatek.com \
    --cc=UNGLinuxDriver@microchip.com \
    --cc=alexandre.belloni@bootlin.com \
    --cc=alsi@bang-olufsen.dk \
    --cc=andrew@lunn.ch \
    --cc=arinc.unal@arinc9.com \
    --cc=claudiu.manoil@nxp.com \
    --cc=clement.leger@bootlin.com \
    --cc=colin.foster@in-advantage.com \
    --cc=davem@davemloft.net \
    --cc=devicetree@vger.kernel.org \
    --cc=dqfext@gmail.com \
    --cc=edumazet@google.com \
    --cc=f.fainelli@gmail.com \
    --cc=george.mccollister@gmail.com \
    --cc=john@phrozen.org \
    --cc=krzysztof.kozlowski+dt@linaro.org \
    --cc=kuba@kernel.org \
    --cc=kurt@linutronix.de \
    --cc=linus.walleij@linaro.org \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mediatek@lists.infradead.org \
    --cc=linux-renesas-soc@vger.kernel.org \
    --cc=marex@denx.de \
    --cc=matthias.bgg@gmail.com \
    --cc=netdev@vger.kernel.org \
    --cc=olteanv@gmail.com \
    --cc=pabeni@redhat.com \
    --cc=robh+dt@kernel.org \
    --cc=sean.wang@mediatek.com \
    --cc=vivien.didelot@gmail.com \
    --cc=woojung.huh@microchip.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®