mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Joe Perches <joe@perches.com>
To: "Saleem, Shiraz" <shiraz.saleem@intel.com>,
	"Ismail, Mustafa" <mustafa.ismail@intel.com>
Cc: Doug Ledford <dledford@redhat.com>,
	Jason Gunthorpe <jgg@ziepe.ca>,
	"linux-rdma@vger.kernel.org" <linux-rdma@vger.kernel.org>,
	LKML <linux-kernel@vger.kernel.org>
Subject: Re: irdma: utils.c typos in irdma_cqp_gather_stats_gen1 ?
Date: Tue, 08 Jun 2021 09:25:34 -0700	[thread overview]
Message-ID: <16b30bff1b1403192f18f110ac83451d4f7d5bc1.camel@perches.com> (raw)
In-Reply-To: <38e0a7b9c19543c2aee679bdd346c5a9@intel.com>

On Tue, 2021-06-08 at 16:18 +0000, Saleem, Shiraz wrote:
> > > Looks reasonable to me. Wondering if irdma_update_stats should
> > > also use your IRDMA_STAT macro.
> > 
> > Probably, and it could really a macro or two of its own.
> > 
> > And it looks like that block has it's own copy/paste defects.
> > 
> > Maybe:
> > ---
[]
> > +#define irdma_update_stat(index, var, size)				\
> 
> Maybe var --> name. Other than that looks good.

Just a suggestion.  Do what you want with it.

And also the field name/MACRO mismatches are a bit odd at best.

I'd rename one or the other to match.

> +     irdma_update_stat(IP4TXFRAGS, ip4txfrag, 48);
[]
> +     irdma_update_stat(TCPTXSEG, tcptxsegs, 48);
[]
> +     irdma_update_stat(RDMAVBND, rdmavbn, 48);



      reply	other threads:[~2021-06-08 16:25 UTC|newest]

Thread overview: 7+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-06-06  1:10 Joe Perches
2021-06-07 14:54 ` Saleem, Shiraz
2021-06-07 15:07   ` Joe Perches
2021-06-07 22:40     ` Saleem, Shiraz
2021-06-07 23:37       ` Joe Perches
2021-06-08 16:18         ` Saleem, Shiraz
2021-06-08 16:25           ` Joe Perches [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=16b30bff1b1403192f18f110ac83451d4f7d5bc1.camel@perches.com \
    --to=joe@perches.com \
    --cc=dledford@redhat.com \
    --cc=jgg@ziepe.ca \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-rdma@vger.kernel.org \
    --cc=mustafa.ismail@intel.com \
    --cc=shiraz.saleem@intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®