From: "tip-bot2 for David Vernet" <tip-bot2@linutronix.de>
To: linux-tip-commits@vger.kernel.org
Cc: David Vernet <void@manifault.com>, Ingo Molnar <mingo@kernel.org>,
Vincent Guittot <vincent.guittot@linaro.org>,
Valentin Schneider <vschneid@redhat.com>,
x86@kernel.org, linux-kernel@vger.kernel.org
Subject: [tip: sched/core] sched/fair: Simplify the update_sd_pick_busiest() logic
Date: Wed, 28 Feb 2024 22:00:08 -0000 [thread overview]
Message-ID: <170915760842.398.18217674203199461024.tip-bot2@tip-bot2> (raw)
In-Reply-To: <20240206043921.850302-4-void@manifault.com>
The following commit has been merged into the sched/core branch of tip:
Commit-ID: 7e9f7d17fe6c23432fda9a3648a858b7589cb4aa
Gitweb: https://git.kernel.org/tip/7e9f7d17fe6c23432fda9a3648a858b7589cb4aa
Author: David Vernet <void@manifault.com>
AuthorDate: Mon, 05 Feb 2024 22:39:21 -06:00
Committer: Ingo Molnar <mingo@kernel.org>
CommitterDate: Wed, 28 Feb 2024 15:19:26 +01:00
sched/fair: Simplify the update_sd_pick_busiest() logic
When comparing the current struct sched_group with the yet-busiest
domain in update_sd_pick_busiest(), if the two groups have the same
group type, we're currently doing a bit of unnecessary work for any
group >= group_misfit_task. We're comparing the two groups, and then
returning only if false (the group in question is not the busiest).
Otherwise, we break out, do an extra unnecessary conditional check that's
vacuously false for any group type > group_fully_busy, and then always
return true.
Let's just return directly in the switch statement instead. This doesn't
change the size of vmlinux with llvm 17 (not surprising given that all
of this is inlined in load_balance()), but it does shrink load_balance()
by 88 bytes on x86. Given that it also improves readability, this seems
worth doing.
Signed-off-by: David Vernet <void@manifault.com>
Signed-off-by: Ingo Molnar <mingo@kernel.org>
Reviewed-by: Vincent Guittot <vincent.guittot@linaro.org>
Reviewed-by: Valentin Schneider <vschneid@redhat.com>
Link: https://lore.kernel.org/r/20240206043921.850302-4-void@manifault.com
---
kernel/sched/fair.c | 12 +++---------
1 file changed, 3 insertions(+), 9 deletions(-)
diff --git a/kernel/sched/fair.c b/kernel/sched/fair.c
index 448520f..51fe17f 100644
--- a/kernel/sched/fair.c
+++ b/kernel/sched/fair.c
@@ -10010,9 +10010,7 @@ static bool update_sd_pick_busiest(struct lb_env *env,
switch (sgs->group_type) {
case group_overloaded:
/* Select the overloaded group with highest avg_load. */
- if (sgs->avg_load <= busiest->avg_load)
- return false;
- break;
+ return sgs->avg_load > busiest->avg_load;
case group_imbalanced:
/*
@@ -10023,18 +10021,14 @@ static bool update_sd_pick_busiest(struct lb_env *env,
case group_asym_packing:
/* Prefer to move from lowest priority CPU's work */
- if (sched_asym_prefer(sg->asym_prefer_cpu, sds->busiest->asym_prefer_cpu))
- return false;
- break;
+ return sched_asym_prefer(sds->busiest->asym_prefer_cpu, sg->asym_prefer_cpu);
case group_misfit_task:
/*
* If we have more than one misfit sg go with the biggest
* misfit.
*/
- if (sgs->group_misfit_task_load <= busiest->group_misfit_task_load)
- return false;
- break;
+ return sgs->group_misfit_task_load > busiest->group_misfit_task_load;
case group_smt_balance:
/*
next prev parent reply other threads:[~2024-02-28 22:00 UTC|newest]
Thread overview: 10+ messages / expand[flat|nested] mbox.gz Atom feed top
2024-02-06 4:39 [PATCH v3 0/3] sched/fair: Simplify and optimize update_sd_pick_busiest() David Vernet
2024-02-06 4:39 ` [PATCH v3 1/3] sched/fair: Remove unnecessary goto in update_sd_lb_stats() David Vernet
2024-02-28 22:00 ` [tip: sched/core] " tip-bot2 for David Vernet
2024-02-06 4:39 ` [PATCH v3 2/3] sched/fair: Do strict inequality check for busiest misfit task group David Vernet
2024-02-06 13:17 ` Valentin Schneider
2024-02-28 22:00 ` [tip: sched/core] " tip-bot2 for David Vernet
2024-02-06 4:39 ` [PATCH v3 3/3] sched/fair: Simplify some logic in update_sd_pick_busiest() David Vernet
2024-02-28 22:00 ` tip-bot2 for David Vernet [this message]
2024-02-16 19:44 ` [PATCH v3 0/3] sched/fair: Simplify and optimize update_sd_pick_busiest() David Vernet
2024-02-26 17:50 ` David Vernet
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=170915760842.398.18217674203199461024.tip-bot2@tip-bot2 \
--to=tip-bot2@linutronix.de \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-tip-commits@vger.kernel.org \
--cc=mingo@kernel.org \
--cc=vincent.guittot@linaro.org \
--cc=void@manifault.com \
--cc=vschneid@redhat.com \
--cc=x86@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®