From: "tip-bot2 for Ahmed S. Darwish" <tip-bot2@linutronix.de>
To: linux-tip-commits@vger.kernel.org
Cc: "Ahmed S. Darwish" <darwi@linutronix.de>,
Ingo Molnar <mingo@kernel.org>, "H. Peter Anvin" <hpa@zytor.com>,
Andrew Cooper <andrew.cooper3@citrix.com>,
John Ogness <john.ogness@linutronix.de>,
x86-cpuid@lists.linux.dev, x86@kernel.org,
linux-kernel@vger.kernel.org
Subject: [tip: x86/core] x86/cacheinfo: Rename CPUID(0x2) descriptors iterator parameter
Date: Thu, 15 May 2025 17:17:15 -0000 [thread overview]
Message-ID: <174732943520.406.17897590489687675996.tip-bot2@tip-bot2> (raw)
In-Reply-To: <20250508150240.172915-7-darwi@linutronix.de>
The following commit has been merged into the x86/core branch of tip:
Commit-ID: 7f6b49644c6cadd9682075bc2dd6a1ba2afd55d8
Gitweb: https://git.kernel.org/tip/7f6b49644c6cadd9682075bc2dd6a1ba2afd55d8
Author: Ahmed S. Darwish <darwi@linutronix.de>
AuthorDate: Thu, 08 May 2025 17:02:35 +02:00
Committer: Ingo Molnar <mingo@kernel.org>
CommitterDate: Thu, 15 May 2025 18:48:10 +02:00
x86/cacheinfo: Rename CPUID(0x2) descriptors iterator parameter
The CPUID(0x2) descriptors iterator has been renamed from:
for_each_leaf_0x2_entry()
to:
for_each_cpuid_0x2_desc()
since it iterates over CPUID(0x2) cache and TLB "descriptors", not
"entries".
In the macro's x86/cacheinfo call-site, rename the parameter denoting the
parsed descriptor at each iteration from 'entry' to 'desc'.
Signed-off-by: Ahmed S. Darwish <darwi@linutronix.de>
Signed-off-by: Ingo Molnar <mingo@kernel.org>
Cc: H. Peter Anvin <hpa@zytor.com>
Cc: Andrew Cooper <andrew.cooper3@citrix.com>
Cc: John Ogness <john.ogness@linutronix.de>
Cc: x86-cpuid@lists.linux.dev
Link: https://lore.kernel.org/r/20250508150240.172915-7-darwi@linutronix.de
---
arch/x86/kernel/cpu/cacheinfo.c | 14 +++++++-------
1 file changed, 7 insertions(+), 7 deletions(-)
diff --git a/arch/x86/kernel/cpu/cacheinfo.c b/arch/x86/kernel/cpu/cacheinfo.c
index b6349c1..adfa7e8 100644
--- a/arch/x86/kernel/cpu/cacheinfo.c
+++ b/arch/x86/kernel/cpu/cacheinfo.c
@@ -381,7 +381,7 @@ static void intel_cacheinfo_done(struct cpuinfo_x86 *c, unsigned int l3,
static void intel_cacheinfo_0x2(struct cpuinfo_x86 *c)
{
unsigned int l1i = 0, l1d = 0, l2 = 0, l3 = 0;
- const struct leaf_0x2_table *entry;
+ const struct leaf_0x2_table *desc;
union leaf_0x2_regs regs;
u8 *ptr;
@@ -389,12 +389,12 @@ static void intel_cacheinfo_0x2(struct cpuinfo_x86 *c)
return;
cpuid_leaf_0x2(®s);
- for_each_cpuid_0x2_desc(regs, ptr, entry) {
- switch (entry->c_type) {
- case CACHE_L1_INST: l1i += entry->c_size; break;
- case CACHE_L1_DATA: l1d += entry->c_size; break;
- case CACHE_L2: l2 += entry->c_size; break;
- case CACHE_L3: l3 += entry->c_size; break;
+ for_each_cpuid_0x2_desc(regs, ptr, desc) {
+ switch (desc->c_type) {
+ case CACHE_L1_INST: l1i += desc->c_size; break;
+ case CACHE_L1_DATA: l1d += desc->c_size; break;
+ case CACHE_L2: l2 += desc->c_size; break;
+ case CACHE_L3: l3 += desc->c_size; break;
}
}
next prev parent reply other threads:[~2025-05-15 17:17 UTC|newest]
Thread overview: 29+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-05-08 15:02 [PATCH v1 0/9] x86/cpuid: Headers cleanup Ahmed S. Darwish
2025-05-08 15:02 ` [PATCH v1 1/9] x86/cpuid: Move CPUID(0x2) APIs into <cpuid/api.h> Ahmed S. Darwish
2025-05-15 17:17 ` [tip: x86/core] " tip-bot2 for Ahmed S. Darwish
2025-05-08 15:02 ` [PATCH v1 2/9] x86/cpuid: Set <asm/cpuid/api.h> as the main CPUID header Ahmed S. Darwish
2025-05-15 16:25 ` Ingo Molnar
2025-05-15 18:29 ` Ahmed S. Darwish
2025-05-15 17:17 ` [tip: x86/core] " tip-bot2 for Ahmed S. Darwish
2025-05-08 15:02 ` [PATCH v1 3/9] x86/cpuid: Rename have_cpuid_p() to cpuid_feature() Ahmed S. Darwish
2025-05-15 17:17 ` [tip: x86/core] " tip-bot2 for Ahmed S. Darwish
2025-05-08 15:02 ` [PATCH v1 4/9] x86/cpuid: Rename hypervisor_cpuid_base() to cpuid_hypervisor_base() Ahmed S. Darwish
2025-05-15 16:40 ` Ingo Molnar
2025-05-15 18:31 ` Ahmed S. Darwish
2025-05-08 15:02 ` [PATCH v1 5/9] x86/cpuid: Rename cpuid_get_leaf_0x2_regs() to cpuid_leaf_0x2() Ahmed S. Darwish
2025-05-15 17:17 ` [tip: x86/core] " tip-bot2 for Ahmed S. Darwish
2025-05-16 9:01 ` tip-bot2 for Ahmed S. Darwish
2025-05-08 15:02 ` [PATCH v1 6/9] x86/cacheinfo: Rename CPUID(0x2) descriptors iterator parameter Ahmed S. Darwish
2025-05-15 17:17 ` tip-bot2 for Ahmed S. Darwish [this message]
2025-05-16 9:00 ` [tip: x86/core] " tip-bot2 for Ahmed S. Darwish
2025-05-08 15:02 ` [PATCH v1 7/9] x86/cpu: " Ahmed S. Darwish
2025-05-15 17:17 ` [tip: x86/core] x86/cpu/intel: " tip-bot2 for Ahmed S. Darwish
2025-05-16 9:00 ` tip-bot2 for Ahmed S. Darwish
2025-05-08 15:02 ` [PATCH v1 8/9] x86/cpuid: Rename native_cpuid() to cpuid_native() Ahmed S. Darwish
2025-05-15 17:00 ` Ingo Molnar
2025-05-15 18:42 ` Ahmed S. Darwish
2025-05-08 15:02 ` [PATCH v1 9/9] x86/cpuid: Rename native_cpuid_REG() to cpuid_native_REG() Ahmed S. Darwish
2025-05-09 9:59 ` Ahmed S. Darwish (dev)
2025-05-08 18:49 ` [PATCH v1 0/9] x86/cpuid: Headers cleanup Ahmed S. Darwish
2025-05-15 16:51 ` Ingo Molnar
2025-05-15 18:50 ` Ahmed S. Darwish
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=174732943520.406.17897590489687675996.tip-bot2@tip-bot2 \
--to=tip-bot2@linutronix.de \
--cc=andrew.cooper3@citrix.com \
--cc=darwi@linutronix.de \
--cc=hpa@zytor.com \
--cc=john.ogness@linutronix.de \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-tip-commits@vger.kernel.org \
--cc=mingo@kernel.org \
--cc=x86-cpuid@lists.linux.dev \
--cc=x86@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®