From: Manivannan Sadhasivam <mani@kernel.org>
To: lpieralisi@kernel.org, bhelgaas@google.com,
kwilczynski@kernel.org, shawn.lin@rock-chips.com,
heiko@sntech.de, Hans Zhang <18255117159@163.com>
Cc: robh@kernel.org, linux-rockchip@lists.infradead.org,
linux-arm-kernel@lists.infradead.org, linux-pci@vger.kernel.org,
linux-kernel@vger.kernel.org
Subject: Re: (subset) [PATCH 0/2] PCI: Consolidate PCIe message routing definitions and remove driver-specific duplicates
Date: Thu, 19 Jun 2025 18:22:20 +0530 [thread overview]
Message-ID: <175033754020.15449.12159303573503323127.b4-ty@kernel.org> (raw)
In-Reply-To: <20250607154913.805027-1-18255117159@163.com>
On Sat, 07 Jun 2025 23:49:11 +0800, Hans Zhang wrote:
> This series consolidates PCIe message routing definitions into the common
> PCI core header, eliminating redundant enums in the Cadence and Rockchip
> drivers. By using standardized macros (PCIE_MSG_TYPE_R_* and
> PCIE_MSG_CODE_*) from drivers/pci/pci.h, we ensure alignment with the PCIe
> r6.0 specification, reduce code duplication, and improve maintainability
> across the PCI subsystem.
>
> [...]
Applied, thanks!
[1/2] PCI: cadence: Replace private message routing enums with PCI core definitions
commit: f28413fe0899591492d8ca3cdf5fd35558d9c05d
Best regards,
--
Manivannan Sadhasivam <mani@kernel.org>
next prev parent reply other threads:[~2025-06-19 12:52 UTC|newest]
Thread overview: 7+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-06-07 15:49 Hans Zhang
2025-06-07 15:49 ` [PATCH 1/2] PCI: cadence: Replace private message routing enums with PCI core definitions Hans Zhang
2025-06-07 15:49 ` [PATCH 2/2] PCI: rockchip: Remove redundant PCIe message routing definitions Hans Zhang
2025-06-20 15:42 ` Bjorn Helgaas
2025-06-20 15:58 ` Hans Zhang
2025-06-19 12:52 ` Manivannan Sadhasivam [this message]
2025-06-19 12:56 ` (subset) [PATCH 0/2] PCI: Consolidate PCIe message routing definitions and remove driver-specific duplicates Manivannan Sadhasivam
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=175033754020.15449.12159303573503323127.b4-ty@kernel.org \
--to=mani@kernel.org \
--cc=18255117159@163.com \
--cc=bhelgaas@google.com \
--cc=heiko@sntech.de \
--cc=kwilczynski@kernel.org \
--cc=linux-arm-kernel@lists.infradead.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-pci@vger.kernel.org \
--cc=linux-rockchip@lists.infradead.org \
--cc=lpieralisi@kernel.org \
--cc=robh@kernel.org \
--cc=shawn.lin@rock-chips.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®