From: Carlos Maiolino <cem@kernel.org>
To: "Darrick J. Wong" <djwong@kernel.org>,
Fedor Pchelkin <pchelkin@ispras.ru>
Cc: Christoph Hellwig <hch@lst.de>,
linux-xfs@vger.kernel.org, linux-kernel@vger.kernel.org,
lvc-project@linuxtesting.org
Subject: Re: [PATCH v2 0/6] xfs: cleanup key comparing routines
Date: Tue, 08 Jul 2025 14:00:23 +0200 [thread overview]
Message-ID: <175197602309.1155040.9466707632114261976.b4-ty@kernel.org> (raw)
In-Reply-To: <20250702093935.123798-1-pchelkin@ispras.ru>
On Wed, 02 Jul 2025 12:39:27 +0300, Fedor Pchelkin wrote:
> Key comparing routines are currently opencoded with extra casts and
> subtractions which is error prone and can be replaced with a neat
> cmp_int() helper which is now in a generic header file.
>
> Started from:
> https://lore.kernel.org/linux-xfs/20250426134232.128864-1-pchelkin@ispras.ru/T/#u
>
> [...]
Applied to for-next, thanks!
[1/6] xfs: rename diff_two_keys routines
commit: c4c6aee6ba87fdfbaeed1966f81298e3f3913f3c
[2/6] xfs: rename key_diff routines
commit: fb7eff8c9f1b7ac46b8e376f9da19d8996cd0262
[3/6] xfs: refactor cmp_two_keys routines to take advantage of cmp_int()
commit: ff48e83c9dcd8c4f6b92b7d695ebe599c0a0e57d
[4/6] xfs: refactor cmp_key_with_cur routines to take advantage of cmp_int()
commit: 786b3b2e16600a642ddf15bcaf94694cfc6b3250
[5/6] xfs: use a proper variable name and type for storing a comparison result
commit: a0b2b28e1cc1c3c95bd889eec455bf8e68def61d
[6/6] xfs: refactor xfs_btree_diff_two_ptrs() to take advantage of cmp_int()
commit: 10e4f0aebdadc94930e82ac13ef1e01abb0bda03
Best regards,
--
Carlos Maiolino <cem@kernel.org>
prev parent reply other threads:[~2025-07-08 12:00 UTC|newest]
Thread overview: 9+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-07-02 9:39 Fedor Pchelkin
2025-07-02 9:39 ` [PATCH v2 1/6] xfs: rename diff_two_keys routines Fedor Pchelkin
2025-07-02 9:39 ` [PATCH v2 2/6] xfs: rename key_diff routines Fedor Pchelkin
2025-07-02 9:39 ` [PATCH v2 3/6] xfs: refactor cmp_two_keys routines to take advantage of cmp_int() Fedor Pchelkin
2025-07-02 9:39 ` [PATCH v2 4/6] xfs: refactor cmp_key_with_cur " Fedor Pchelkin
2025-07-02 9:39 ` [PATCH v2 5/6] xfs: use a proper variable name and type for storing a comparison result Fedor Pchelkin
2025-07-02 9:39 ` [PATCH v2 6/6] xfs: refactor xfs_btree_diff_two_ptrs() to take advantage of cmp_int() Fedor Pchelkin
2025-07-02 14:43 ` Darrick J. Wong
2025-07-08 12:00 ` Carlos Maiolino [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=175197602309.1155040.9466707632114261976.b4-ty@kernel.org \
--to=cem@kernel.org \
--cc=djwong@kernel.org \
--cc=hch@lst.de \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-xfs@vger.kernel.org \
--cc=lvc-project@linuxtesting.org \
--cc=pchelkin@ispras.ru \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®