From: patchwork-bot+netdevbpf@kernel.org
To: Breno Leitao <leitao@debian.org>
Cc: davem@davemloft.net, edumazet@google.com, kuba@kernel.org,
pabeni@redhat.com, horms@kernel.org, andrew+netdev@lunn.ch,
netdev@vger.kernel.org, linux-kernel@vger.kernel.org,
kernel-team@meta.com
Subject: Re: [PATCH net-next v4 0/4] netconsole: reuse netpoll_parse_ip_addr in configfs helpers
Date: Wed, 13 Aug 2025 01:00:11 +0000 [thread overview]
Message-ID: <175504681100.2908717.15523966877694857156.git-patchwork-notify@kernel.org> (raw)
In-Reply-To: <20250811-netconsole_ref-v4-0-9c510d8713a2@debian.org>
Hello:
This series was applied to netdev/net-next.git (main)
by Jakub Kicinski <kuba@kernel.org>:
On Mon, 11 Aug 2025 11:13:24 -0700 you wrote:
> This patchset refactors the IP address parsing logic in the netconsole
> driver to eliminate code duplication and improve maintainability. The
> changes centralize IPv4 and IPv6 address parsing into a single function
> (netpoll_parse_ip_addr). For that, it needs to teach
> netpoll_parse_ip_addr() to handle strings with newlines, which is the
> type of string coming from configfs.
>
> [...]
Here is the summary with links:
- [net-next,v4,1/4] netconsole: move netpoll_parse_ip_addr() earlier for reuse
https://git.kernel.org/netdev/net-next/c/fa38524ca5a7
- [net-next,v4,2/4] netconsole: add support for strings with new line in netpoll_parse_ip_addr
https://git.kernel.org/netdev/net-next/c/364213b736e3
- [net-next,v4,3/4] netconsole: use netpoll_parse_ip_addr in local_ip_store
https://git.kernel.org/netdev/net-next/c/60cb69214148
- [net-next,v4,4/4] netconsole: use netpoll_parse_ip_addr in local_ip_store
https://git.kernel.org/netdev/net-next/c/4aeb452c237a
You are awesome, thank you!
--
Deet-doot-dot, I am a bot.
https://korg.docs.kernel.org/patchwork/pwbot.html
prev parent reply other threads:[~2025-08-13 0:59 UTC|newest]
Thread overview: 6+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-08-11 18:13 Breno Leitao
2025-08-11 18:13 ` [PATCH net-next v4 1/4] netconsole: move netpoll_parse_ip_addr() earlier for reuse Breno Leitao
2025-08-11 18:13 ` [PATCH net-next v4 2/4] netconsole: add support for strings with new line in netpoll_parse_ip_addr Breno Leitao
2025-08-11 18:13 ` [PATCH net-next v4 3/4] netconsole: use netpoll_parse_ip_addr in local_ip_store Breno Leitao
2025-08-11 18:13 ` [PATCH net-next v4 4/4] " Breno Leitao
2025-08-13 1:00 ` patchwork-bot+netdevbpf [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=175504681100.2908717.15523966877694857156.git-patchwork-notify@kernel.org \
--to=patchwork-bot+netdevbpf@kernel.org \
--cc=andrew+netdev@lunn.ch \
--cc=davem@davemloft.net \
--cc=edumazet@google.com \
--cc=horms@kernel.org \
--cc=kernel-team@meta.com \
--cc=kuba@kernel.org \
--cc=leitao@debian.org \
--cc=linux-kernel@vger.kernel.org \
--cc=netdev@vger.kernel.org \
--cc=pabeni@redhat.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®