mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: patchwork-bot+netdevbpf@kernel.org
To: Wang Liang <wangliang74@huawei.com>
Cc: sgarzare@redhat.com, davem@davemloft.net, edumazet@google.com,
	kuba@kernel.org, pabeni@redhat.com, horms@kernel.org,
	yuehaibing@huawei.com, zhangchangzhong@huawei.com,
	virtualization@lists.linux.dev, netdev@vger.kernel.org,
	linux-kernel@vger.kernel.org
Subject: Re: [PATCH net-next] vsock: use sizeof(struct sockaddr_storage) instead of magic value
Date: Thu, 14 Aug 2025 00:10:06 +0000	[thread overview]
Message-ID: <175513020601.3825277.1947080522866981155.git-patchwork-notify@kernel.org> (raw)
In-Reply-To: <20250812015929.1419896-1-wangliang74@huawei.com>

Hello:

This patch was applied to netdev/net-next.git (main)
by Jakub Kicinski <kuba@kernel.org>:

On Tue, 12 Aug 2025 09:59:29 +0800 you wrote:
> Previous commit 230b183921ec ("net: Use standard structures for generic
> socket address structures.") use 'struct sockaddr_storage address;'
> to replace 'char address[MAX_SOCK_ADDR];'.
> 
> The macro MAX_SOCK_ADDR is removed by commit 01893c82b4e6 ("net: Remove
> MAX_SOCK_ADDR constant").
> 
> [...]

Here is the summary with links:
  - [net-next] vsock: use sizeof(struct sockaddr_storage) instead of magic value
    https://git.kernel.org/netdev/net-next/c/4d18083d6b2c

You are awesome, thank you!
-- 
Deet-doot-dot, I am a bot.
https://korg.docs.kernel.org/patchwork/pwbot.html



      reply	other threads:[~2025-08-14  0:09 UTC|newest]

Thread overview: 2+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2025-08-12  1:59 Wang Liang
2025-08-14  0:10 ` patchwork-bot+netdevbpf [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=175513020601.3825277.1947080522866981155.git-patchwork-notify@kernel.org \
    --to=patchwork-bot+netdevbpf@kernel.org \
    --cc=davem@davemloft.net \
    --cc=edumazet@google.com \
    --cc=horms@kernel.org \
    --cc=kuba@kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=netdev@vger.kernel.org \
    --cc=pabeni@redhat.com \
    --cc=sgarzare@redhat.com \
    --cc=virtualization@lists.linux.dev \
    --cc=wangliang74@huawei.com \
    --cc=yuehaibing@huawei.com \
    --cc=zhangchangzhong@huawei.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®