From: "Rob Herring (Arm)" <robh@kernel.org>
To: Frank Li <Frank.Li@nxp.com>
Cc: Conor Dooley <conor+dt@kernel.org>,
Shawn Guo <shawnguo@kernel.org>,
devicetree@vger.kernel.org,
linux-arm-kernel@lists.infradead.org,
Krzysztof Kozlowski <krzk+dt@kernel.org>,
imx@lists.linux.dev, linux-kernel@vger.kernel.org
Subject: Re: [PATCH v2 0/7] ARM: dts: clean up most ls1021a CHECK_DTB warning
Date: Wed, 20 Aug 2025 13:57:03 -0500 [thread overview]
Message-ID: <175571287545.265879.1160274338030207211.robh@kernel.org> (raw)
In-Reply-To: <20250820-ls1021a_dts_warning-v2-0-2e39648a32b7@nxp.com>
On Wed, 20 Aug 2025 12:36:50 -0400, Frank Li wrote:
> clean up most ls1021a CHECK_DTB warning.
>
> Old uboot check esdhc@1560000. The new uboot already switch to check both
> esdhc@1560000 and mmc@1560000. So we can rename it now.
>
> Signed-off-by: Frank Li <Frank.Li@nxp.com>
> ---
> Changes in v2:
> - squash rename to flash patches
> - remove duplicate patches already post in
> https://lore.kernel.org/linux-devicetree/20250725061339.266125-1-alexander.stein@ew.tq-group.com/
> - Link to v1: https://lore.kernel.org/r/20250818-ls1021a_dts_warning-v1-0-7a79b6b4a0e2@nxp.com
>
> ---
> Frank Li (7):
> ARM: dts: ls1021a: Rename node name nor to flash
> ARM: dts: ls1021a: Rename 'mdio-mux-emi1' to 'mdio-mux@54'
> ARM: dts: ls1021a: Rename esdhc@1560000 to mmc@1560000
> ARM: dts: ls1021a: Rename node name power-controler to wakeup-controller
> ARM: dts: ls1021a: remove big-endian for mmc modes
> ARM: dts: ls1021a-tsn: Remove redundant #address-cells for ethernet-switch@1
> ARM: dts: ls1021a-tqmls1021a-mbls1021a-rgb-cdtech: Remove fallback compatible string edt,edt-ft5x06
>
> arch/arm/boot/dts/nxp/ls/ls1021a-qds.dts | 8 ++++----
> .../dts/nxp/ls/ls1021a-tqmls1021a-mbls1021a-rgb-cdtech-dc44.dtso | 2 +-
> .../dts/nxp/ls/ls1021a-tqmls1021a-mbls1021a-rgb-cdtech-fc21.dtso | 2 +-
> arch/arm/boot/dts/nxp/ls/ls1021a-tsn.dts | 2 --
> arch/arm/boot/dts/nxp/ls/ls1021a-twr.dts | 2 +-
> arch/arm/boot/dts/nxp/ls/ls1021a.dtsi | 6 ++----
> 6 files changed, 9 insertions(+), 13 deletions(-)
> ---
> base-commit: 3ede6e44fad31f1c80dd01188683f0caa0f19247
> change-id: 20250818-ls1021a_dts_warning-fff933bd83da
>
> Best regards,
> --
> Frank Li <Frank.Li@nxp.com>
>
>
>
My bot found new DTB warnings on the .dts files added or changed in this
series.
Some warnings may be from an existing SoC .dtsi. Or perhaps the warnings
are fixed by another series. Ultimately, it is up to the platform
maintainer whether these warnings are acceptable or not. No need to reply
unless the platform maintainer has comments.
If you already ran DT checks and didn't see these error(s), then
make sure dt-schema is up to date:
pip3 install dtschema --upgrade
This patch series was applied (using b4) to base:
Base: base-commit 3ede6e44fad31f1c80dd01188683f0caa0f19247 not known, ignoring
Base: attempting to guess base-commit...
Base: tags/next-20250820 (exact match)
If this is not the correct base, please add 'base-commit' tag
(or use b4 which does this automatically)
New warnings running 'make CHECK_DTBS=y for arch/arm/boot/dts/nxp/' for 20250820-ls1021a_dts_warning-v2-0-2e39648a32b7@nxp.com:
arch/arm/boot/dts/nxp/ls/ls1021a-qds.dtb: memory-controller@1530000 (fsl,ifc): board-control@3,0: Unevaluated properties are not allowed ('#address-cells', '#size-cells', 'bank-width', 'compatible', 'device-width', 'mdio-mux@54', 'ranges', 'reg' were unexpected)
from schema $id: http://devicetree.org/schemas/memory-controllers/fsl/fsl,ifc.yaml#
arch/arm/boot/dts/nxp/ls/ls1021a-qds.dtb: flash@0 (atmel,at45db021d): Unevaluated properties are not allowed ('spi-cpha', 'spi-cpol' were unexpected)
from schema $id: http://devicetree.org/schemas/mtd/atmel,dataflash.yaml#
next prev parent reply other threads:[~2025-08-20 18:57 UTC|newest]
Thread overview: 10+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-08-20 16:36 Frank Li
2025-08-20 16:36 ` [PATCH v2 1/7] ARM: dts: ls1021a: Rename node name nor to flash Frank Li
2025-08-20 16:36 ` [PATCH v2 2/7] ARM: dts: ls1021a: Rename 'mdio-mux-emi1' to 'mdio-mux@54' Frank Li
2025-08-20 16:36 ` [PATCH v2 3/7] ARM: dts: ls1021a: Rename esdhc@1560000 to mmc@1560000 Frank Li
2025-08-20 16:36 ` [PATCH v2 4/7] ARM: dts: ls1021a: Rename node name power-controler to wakeup-controller Frank Li
2025-08-20 16:36 ` [PATCH v2 5/7] ARM: dts: ls1021a: remove big-endian for mmc modes Frank Li
2025-08-20 16:36 ` [PATCH v2 6/7] ARM: dts: ls1021a-tsn: Remove redundant #address-cells for ethernet-switch@1 Frank Li
2025-08-20 16:36 ` [PATCH v2 7/7] ARM: dts: ls1021a-tqmls1021a-mbls1021a-rgb-cdtech: Remove fallback compatible string edt,edt-ft5x06 Frank Li
2025-08-20 18:57 ` Rob Herring (Arm) [this message]
2025-08-22 9:55 ` [PATCH v2 0/7] ARM: dts: clean up most ls1021a CHECK_DTB warning Shawn Guo
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=175571287545.265879.1160274338030207211.robh@kernel.org \
--to=robh@kernel.org \
--cc=Frank.Li@nxp.com \
--cc=conor+dt@kernel.org \
--cc=devicetree@vger.kernel.org \
--cc=imx@lists.linux.dev \
--cc=krzk+dt@kernel.org \
--cc=linux-arm-kernel@lists.infradead.org \
--cc=linux-kernel@vger.kernel.org \
--cc=shawnguo@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®