mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: "Rob Herring (Arm)" <robh@kernel.org>
To: Jihed Chaibi <jihed.chaibi.dev@gmail.com>
Cc: linux-kernel@vger.kernel.org, devicetree@vger.kernel.org,
	conor+dt@kernel.org, peter.ujfalusi@gmail.com,
	krzk+dt@kernel.org, lee@kernel.org, shuah@kernel.org
Subject: Re: [PATCH v5] mfd: dt-bindings: ti,twl6040: convert to DT schema
Date: Wed, 20 Aug 2025 16:58:43 -0500	[thread overview]
Message-ID: <175572712295.1429558.12540417914156224115.robh@kernel.org> (raw)
In-Reply-To: <20250817215234.50904-1-jihed.chaibi.dev@gmail.com>


On Sun, 17 Aug 2025 23:52:34 +0200, Jihed Chaibi wrote:
> Convert the legacy TXT binding for the TWL6040 MFD to the modern YAML
> DT schema format. This adds formal validation and improves documentation
> for the TWL6040/TWL6041 audio codec, which provides audio, vibra, and GPO
> functionality on OMAP4+ platforms.
> 
> Key changes:
> 
>  - Dropped usage of the 'twl6040,audpwron-gpio' property from the schema
>    as it is not used by the driver.
>  - Retained 'clocks' and 'clock-names' as flexible (1-2 items) to match
>    the original binding's "and/or" phrasing, which allows clk32k, mclk,
>    or both.
>  - Updated node name to 'audio-codec@4b' to follow generic naming
>    conventions per the Device Tree specification.
>  - Replaced raw interrupt values with standard defines for clarity.
> 
> Signed-off-by: Jihed Chaibi <jihed.chaibi.dev@gmail.com>
> 
> ---
> Changes in v5:
>  - Add missing changelogs
> 
> Changes in v4:
>  - Retained 'clocks' and 'clock-names' as flexible (1-2 items) to match
>    the original binding's "and/or" phrasing, which sould allow either
>    clk32k, mclk, or both.
>  - Updated node name to 'audio-codec@4b' to follow generic naming
>    conventions per the Device Tree specification.
>  - Replaced raw interrupt values with standard defines for clarity.
>  - Added clock properties to the example.
> 
> Changes in v3:
>  - Drop usage of The unused 'twl6040,audpwron-gpio' property from the
>    schema as it is not used by the driver.
>  - This patch was originally part of a larger series but has been
>    sent separately per maintainer feedback.
>    v2 (origial patch series) link:
>    https://lore.kernel.org/all/20250814132129.138943-3-jihed.chaibi.dev@gmail.com
> 
> Changes in v2:
>  - Renamed twl6040,audpwron-gpio to ti,audpwron-gpio for consistency
>    with TI naming, this fixes the dt_binding_check vendor name  error.
>  - Minor description clarifications for improved readability.
> 
> Changes in v1:
>  - Initial conversion of twl6040.txt to YAML format.
>  - v1 link :
>    https://lore.kernel.org/all/20250811224739.53869-3-jihed.chaibi.dev@gmail.com/
> ---
>  .../devicetree/bindings/mfd/ti,twl6040.yaml   | 154 ++++++++++++++++++
>  .../devicetree/bindings/mfd/twl6040.txt       |  67 --------
>  2 files changed, 154 insertions(+), 67 deletions(-)
>  create mode 100644 Documentation/devicetree/bindings/mfd/ti,twl6040.yaml
>  delete mode 100644 Documentation/devicetree/bindings/mfd/twl6040.txt
> 

Reviewed-by: Rob Herring (Arm) <robh@kernel.org>


      reply	other threads:[~2025-08-20 21:58 UTC|newest]

Thread overview: 2+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2025-08-17 21:52 Jihed Chaibi
2025-08-20 21:58 ` Rob Herring (Arm) [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=175572712295.1429558.12540417914156224115.robh@kernel.org \
    --to=robh@kernel.org \
    --cc=conor+dt@kernel.org \
    --cc=devicetree@vger.kernel.org \
    --cc=jihed.chaibi.dev@gmail.com \
    --cc=krzk+dt@kernel.org \
    --cc=lee@kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=peter.ujfalusi@gmail.com \
    --cc=shuah@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®