mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: patchwork-bot+netdevbpf@kernel.org
To: Vladimir Oltean <vladimir.oltean@nxp.com>
Cc: netdev@vger.kernel.org, andrew@lunn.ch, hkallweit1@gmail.com,
	linux@armlinux.org.uk, davem@davemloft.net, edumazet@google.com,
	kuba@kernel.org, pabeni@redhat.com, daniel@makrotopia.org,
	linux-kernel@vger.kernel.org, nikita.yoush@cogentembedded.com,
	bartosz.golaszewski@linaro.org, robimarko@gmail.com,
	frut3k7@gmail.com, sean.anderson@seco.com, jonathanh@nvidia.com
Subject: Re: [PATCH net-next 00/15] Aquantia PHY driver consolidation - part 1
Date: Mon, 25 Aug 2025 18:00:24 +0000	[thread overview]
Message-ID: <175614482452.3508254.15723019808056627426.git-patchwork-notify@kernel.org> (raw)
In-Reply-To: <20250821152022.1065237-1-vladimir.oltean@nxp.com>

Hello:

This series was applied to netdev/net-next.git (main)
by Jakub Kicinski <kuba@kernel.org>:

On Thu, 21 Aug 2025 18:20:07 +0300 you wrote:
> This started out as an effort to add some new features hinging on the
> VEND1_GLOBAL_CFG_* registers, but I quickly started to notice that the
> Aquantia PHY driver has a large code base, but individual PHYs only
> implement arbitrary subsets of it.
> 
> The table below lists the PHYs known to me to have the
> VEND1_GLOBAL_CFG_* registers.
> 
> [...]

Here is the summary with links:
  - [net-next,01/15] net: phy: aquantia: rename AQR412 to AQR412C and add real AQR412
    https://git.kernel.org/netdev/net-next/c/7cd3597b8f6f
  - [net-next,02/15] net: phy: aquantia: merge aqr113c_fill_interface_modes() into aqr107_fill_interface_modes()
    https://git.kernel.org/netdev/net-next/c/a31b1c1591e8
  - [net-next,03/15] net: phy: aquantia: reorder AQR113C PMD Global Transmit Disable bit clearing with supported_interfaces
    https://git.kernel.org/netdev/net-next/c/5433fbc3adcd
  - [net-next,04/15] net: phy: aquantia: rename some aqr107 functions according to generation
    https://git.kernel.org/netdev/net-next/c/9731bcf202e6
  - [net-next,05/15] net: phy: aquantia: fill supported_interfaces for all aqr_gen2_config_init() callers
    https://git.kernel.org/netdev/net-next/c/ab1dfcb5bce1
  - [net-next,06/15] net: phy: aquantia: save a local shadow of GLOBAL_CFG register values
    https://git.kernel.org/netdev/net-next/c/08048ba4285e
  - [net-next,07/15] net: phy: aquantia: remove handling for get_rate_matching(PHY_INTERFACE_MODE_NA)
    https://git.kernel.org/netdev/net-next/c/6fa022088b60
  - [net-next,08/15] net: phy: aquantia: use cached GLOBAL_CFG registers in aqr107_read_rate()
    https://git.kernel.org/netdev/net-next/c/832b63c70ef0
  - [net-next,09/15] net: phy: aquantia: merge and rename aqr105_read_status() and aqr107_read_status()
    https://git.kernel.org/netdev/net-next/c/c03c97e55f62
  - [net-next,10/15] net: phy: aquantia: call aqr_gen2_fill_interface_modes() for AQCS109
    https://git.kernel.org/netdev/net-next/c/02a7f5a92545
  - [net-next,11/15] net: phy: aquantia: call aqr_gen3_config_init() for AQR112 and AQR412(C)
    https://git.kernel.org/netdev/net-next/c/2d9503217520
  - [net-next,12/15] net: phy: aquantia: reimplement aqcs109_config_init() as aqr_gen2_config_init()
    https://git.kernel.org/netdev/net-next/c/ed1106f7f926
  - [net-next,13/15] net: phy: aquantia: rename aqr113c_config_init() to aqr_gen4_config_init()
    https://git.kernel.org/netdev/net-next/c/3c904dd67f50
  - [net-next,14/15] net: phy: aquantia: promote AQR813 and AQR114C to aqr_gen4_config_init()
    https://git.kernel.org/netdev/net-next/c/9dfe80a8157b
  - [net-next,15/15] net: phy: aquantia: add support for AQR115
    https://git.kernel.org/netdev/net-next/c/fb4b9f13718c

You are awesome, thank you!
-- 
Deet-doot-dot, I am a bot.
https://korg.docs.kernel.org/patchwork/pwbot.html



      parent reply	other threads:[~2025-08-25 18:00 UTC|newest]

Thread overview: 22+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2025-08-21 15:20 Vladimir Oltean
2025-08-21 15:20 ` [PATCH net-next 01/15] net: phy: aquantia: rename AQR412 to AQR412C and add real AQR412 Vladimir Oltean
2025-08-21 15:35   ` Andrew Lunn
2025-08-21 15:20 ` [PATCH net-next 02/15] net: phy: aquantia: merge aqr113c_fill_interface_modes() into aqr107_fill_interface_modes() Vladimir Oltean
2025-08-21 16:20   ` Andrew Lunn
2025-08-21 15:20 ` [PATCH net-next 03/15] net: phy: aquantia: reorder AQR113C PMD Global Transmit Disable bit clearing with supported_interfaces Vladimir Oltean
2025-08-21 16:21   ` Andrew Lunn
2025-08-21 15:20 ` [PATCH net-next 04/15] net: phy: aquantia: rename some aqr107 functions according to generation Vladimir Oltean
2025-08-21 15:20 ` [PATCH net-next 05/15] net: phy: aquantia: fill supported_interfaces for all aqr_gen2_config_init() callers Vladimir Oltean
2025-08-21 15:20 ` [PATCH net-next 06/15] net: phy: aquantia: save a local shadow of GLOBAL_CFG register values Vladimir Oltean
2025-08-21 15:20 ` [PATCH net-next 07/15] net: phy: aquantia: remove handling for get_rate_matching(PHY_INTERFACE_MODE_NA) Vladimir Oltean
2025-08-22  3:22   ` Andrew Lunn
2025-08-21 15:20 ` [PATCH net-next 08/15] net: phy: aquantia: use cached GLOBAL_CFG registers in aqr107_read_rate() Vladimir Oltean
2025-08-21 15:20 ` [PATCH net-next 09/15] net: phy: aquantia: merge and rename aqr105_read_status() and aqr107_read_status() Vladimir Oltean
2025-08-21 15:20 ` [PATCH net-next 10/15] net: phy: aquantia: call aqr_gen2_fill_interface_modes() for AQCS109 Vladimir Oltean
2025-08-21 15:20 ` [PATCH net-next 11/15] net: phy: aquantia: call aqr_gen3_config_init() for AQR112 and AQR412(C) Vladimir Oltean
2025-08-21 15:20 ` [PATCH net-next 12/15] net: phy: aquantia: reimplement aqcs109_config_init() as aqr_gen2_config_init() Vladimir Oltean
2025-08-21 15:20 ` [PATCH net-next 13/15] net: phy: aquantia: rename aqr113c_config_init() to aqr_gen4_config_init() Vladimir Oltean
2025-08-21 15:20 ` [PATCH net-next 14/15] net: phy: aquantia: promote AQR813 and AQR114C " Vladimir Oltean
2025-08-21 15:20 ` [PATCH net-next 15/15] net: phy: aquantia: add support for AQR115 Vladimir Oltean
2025-08-25 17:53 ` [PATCH net-next 00/15] Aquantia PHY driver consolidation - part 1 Jakub Kicinski
2025-08-25 18:00 ` patchwork-bot+netdevbpf [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=175614482452.3508254.15723019808056627426.git-patchwork-notify@kernel.org \
    --to=patchwork-bot+netdevbpf@kernel.org \
    --cc=andrew@lunn.ch \
    --cc=bartosz.golaszewski@linaro.org \
    --cc=daniel@makrotopia.org \
    --cc=davem@davemloft.net \
    --cc=edumazet@google.com \
    --cc=frut3k7@gmail.com \
    --cc=hkallweit1@gmail.com \
    --cc=jonathanh@nvidia.com \
    --cc=kuba@kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux@armlinux.org.uk \
    --cc=netdev@vger.kernel.org \
    --cc=nikita.yoush@cogentembedded.com \
    --cc=pabeni@redhat.com \
    --cc=robimarko@gmail.com \
    --cc=sean.anderson@seco.com \
    --cc=vladimir.oltean@nxp.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®