From: "Ilpo Järvinen" <ilpo.jarvinen@linux.intel.com>
To: Mark Pearson <mpearson-lenovo@squebb.ca>,
"Derek J. Clark" <derekjohn.clark@gmail.com>,
Armin Wolf <W_Armin@gmx.de>, Hans de Goede <hansg@kernel.org>,
Rong Zhang <i@rong.moe>
Cc: Guenter Roeck <linux@roeck-us.net>,
platform-driver-x86@vger.kernel.org,
linux-kernel@vger.kernel.org, linux-hwmon@vger.kernel.org
Subject: Re: [PATCH] platform/x86: lenovo-wmi-{capdata,other}: Fix HWMON channel visibility
Date: Tue, 10 Feb 2026 17:23:37 +0200 [thread overview]
Message-ID: <177073701772.1935.17832144626573387865.b4-ty@linux.intel.com> (raw)
In-Reply-To: <20260207172327.80111-1-i@rong.moe>
On Sun, 08 Feb 2026 01:23:27 +0800, Rong Zhang wrote:
> The LWMI_SUPP_MAY_{GET,SET} macros are fundamentally broken. When I
> introduced them, I meant to check LWMI_SUPP_VALID *and* the
> corresponding bits for get/set capabilities. However, `supported &
> LWMI_SUPP_MAY_{GET,SET}' means *or*, so it accidentally passes the check
> when LWMI_SUPP_VALID is set.
>
> Fix them by only including the corresponding get/set bit without
> LWMI_SUPP_VALID. Meanwhile, rename them to LWMI_SUPP_{GET,SET} to make
> them less confusing.
>
> [...]
Thank you for your contribution, it has been applied to my local
review-ilpo-next branch. Note it will show up in the public
platform-drivers-x86/review-ilpo-next branch only once I've pushed my
local branch there, which might take a while.
The list of commits applied:
[1/1] platform/x86: lenovo-wmi-{capdata,other}: Fix HWMON channel visibility
commit: 5a5203a45b063a594e89a2aeaf9e4923893a5b4c
--
i.
prev parent reply other threads:[~2026-02-10 15:23 UTC|newest]
Thread overview: 2+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-02-07 17:23 Rong Zhang
2026-02-10 15:23 ` Ilpo Järvinen [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=177073701772.1935.17832144626573387865.b4-ty@linux.intel.com \
--to=ilpo.jarvinen@linux.intel.com \
--cc=W_Armin@gmx.de \
--cc=derekjohn.clark@gmail.com \
--cc=hansg@kernel.org \
--cc=i@rong.moe \
--cc=linux-hwmon@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux@roeck-us.net \
--cc=mpearson-lenovo@squebb.ca \
--cc=platform-driver-x86@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®