From: patchwork-bot+netdevbpf@kernel.org
To: Ihor Solodrai <ihor.solodrai@linux.dev>
Cc: ast@kernel.org, andrii@kernel.org, eddyz87@gmail.com,
daniel@iogearbox.net, shung-hsi.yu@suse.com,
viro@zeniv.linux.org.uk, bpf@vger.kernel.org,
linux-kernel@vger.kernel.org
Subject: Re: [PATCH bpf v1] selftests/bpf: Rename do_filp_open() to do_file_open()
Date: Wed, 11 Feb 2026 02:20:05 +0000 [thread overview]
Message-ID: <177077640508.4160838.11857900603243131631.git-patchwork-notify@kernel.org> (raw)
In-Reply-To: <20260210235855.215679-1-ihor.solodrai@linux.dev>
Hello:
This patch was applied to bpf/bpf.git (master)
by Alexei Starovoitov <ast@kernel.org>:
On Tue, 10 Feb 2026 15:58:55 -0800 you wrote:
> do_filp_open() was renamed (fixing typo) in commit
> 541003b576c3 ("rename do_filp_open() to do_file_open()")
>
> This broke test_profiler, because it uses a kretprobe on that
> function. Fix it by renaming accordingly.
>
> Fixes: 541003b576c3 ("rename do_filp_open() to do_file_open()")
> Reported-by: Shung-Hsi Yu <shung-hsi.yu@suse.com>
> Closes: https://lore.kernel.org/bpf/djwjf2vfb7gro3rfag666bojod6ytcectahnb5z6hx2hawimtj@sx47ghzjg4lw/
> Signed-off-by: Ihor Solodrai <ihor.solodrai@linux.dev>
>
> [...]
Here is the summary with links:
- [bpf,v1] selftests/bpf: Rename do_filp_open() to do_file_open()
https://git.kernel.org/bpf/bpf/c/1a7eb7a3d740
You are awesome, thank you!
--
Deet-doot-dot, I am a bot.
https://korg.docs.kernel.org/patchwork/pwbot.html
prev parent reply other threads:[~2026-02-11 2:20 UTC|newest]
Thread overview: 2+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-02-10 23:58 Ihor Solodrai
2026-02-11 2:20 ` patchwork-bot+netdevbpf [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=177077640508.4160838.11857900603243131631.git-patchwork-notify@kernel.org \
--to=patchwork-bot+netdevbpf@kernel.org \
--cc=andrii@kernel.org \
--cc=ast@kernel.org \
--cc=bpf@vger.kernel.org \
--cc=daniel@iogearbox.net \
--cc=eddyz87@gmail.com \
--cc=ihor.solodrai@linux.dev \
--cc=linux-kernel@vger.kernel.org \
--cc=shung-hsi.yu@suse.com \
--cc=viro@zeniv.linux.org.uk \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®