From: John Hubbard <jhubbard@nvidia.com>
To: Alexandre Courbot <acourbot@nvidia.com>,
Miguel Ojeda <miguel.ojeda.sandonis@gmail.com>
Cc: "Alice Ryhl" <aliceryhl@google.com>,
"David Airlie" <airlied@gmail.com>,
"Simona Vetter" <simona@ffwll.ch>,
"Miguel Ojeda" <ojeda@kernel.org>,
"Alex Gaynor" <alex.gaynor@gmail.com>,
"Boqun Feng" <boqun.feng@gmail.com>,
"Gary Guo" <gary@garyguo.net>,
"Björn Roy Baron" <bjorn3_gh@protonmail.com>,
"Benno Lossin" <lossin@kernel.org>,
"Andreas Hindborg" <a.hindborg@kernel.org>,
"Trevor Gross" <tmgross@umich.edu>,
"Alistair Popple" <apopple@nvidia.com>,
"Joel Fernandes" <joelagnelf@nvidia.com>,
"Timur Tabi" <ttabi@nvidia.com>, "Edwin Peer" <epeer@nvidia.com>,
nouveau@lists.freedesktop.org, dri-devel@lists.freedesktop.org,
linux-kernel@vger.kernel.org, rust-for-linux@vger.kernel.org,
"Danilo Krummrich" <dakr@kernel.org>,
"Matthew Wilcox" <willy@infradead.org>,
Nouveau <nouveau-bounces@lists.freedesktop.org>
Subject: Re: [PATCH 5/7] gpu: nova-core: add extra conversion functions and traits
Date: Tue, 28 Oct 2025 10:18:21 -0700 [thread overview]
Message-ID: <1772ce29-c84c-42b3-8c77-e92355fbee53@nvidia.com> (raw)
In-Reply-To: <DDU1AQDW78QI.1CBHEW03926H0@nvidia.com>
On 10/28/25 7:44 AM, Alexandre Courbot wrote:
> On Tue Oct 28, 2025 at 3:46 AM JST, John Hubbard wrote:
>> On 10/26/25 9:44 AM, Miguel Ojeda wrote:
>>> On Sun, Oct 26, 2025 at 3:40 PM Alexandre Courbot <acourbot@nvidia.com> wrote:
>> ...
>>
>>> Regarding the `.into_as()` name, it makes sense, but it can be a bit
>>> surprising when reading out of context... The standalone functions are
>>> super clear, in comparison. But I am not sure what could be better.
>>> `into_in_this_arch()` or similar could emphasize that this will only
>>> work in certain architectures, i.e. it is "an `into()` for this arch"
>>> rather than the general one.
>>> That would go well with the idea that you didn't implement it for
>>> other obvious types, which I guess was to avoid developers using this
>>> instead of `into()` by mistake, right?
>>>
>>
>> Exactly: the into-as, from-as naming suffers from *appearing* to be
>> familiar and readable, but actually, the naming gives no hint as to
>> what it is really doing--nor how it is subtly different from the
>> basic from/as/into standard conversions.
>>
>> Instead, we need to add something (almost anything) to the name, to
>> make it clearly different from the from/as/into.
>>
>> into_for_arch() goes in that direction, for example.
>
> I'd like to get more input on that, for I am not sure how we can stay
> succint in the naming, while carrying the relevant information.
That's too many constraints: if you want an extremely short name
that carries information, *and* avoids (as requested here) confusion
with existing "as" methods, then...you can't.
But you are allowed to be less succinct here, because the more
specialized and rare a case is, the longer you can make the name.
And here, you are definitely allowed a few more characters.
> `into_arch` does not sound much more explanatory than `into_as` - the
> intent with the latter was to say "I would normally have done an `as`,
> but instead here is a method that attests that this operations is indeed
> lossless and safe".
>
> The best naming scheme I could think of is to have the methods carry the
> source or destination types: e.g. `from_usize` or `into_usize` (like the
> standalone functions), but that would require defining as many traits,
> and increase the number of imports - if we go that way, we might just as
> well drop the traits completely and use the standalone functions.
Accurate names are really desirable; maybe we shouldn't completely
close the door to the above approach.
thanks,
John Hubbard
>
> `into_native` also comes to mind, but like `arch`, it can mean many
> things depending on the context.
>
> ... I think I still believe that `into_as` is the clearest name, once
> one has read the documentation for the trait - which one should be
> expected to do anyway. :)
next prev parent reply other threads:[~2025-10-28 17:18 UTC|newest]
Thread overview: 24+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-10-26 14:39 [PATCH 0/7] gpu: nova-core: remove use of `as` for integer conversions Alexandre Courbot
2025-10-26 14:39 ` [PATCH 1/7] gpu: nova-core: replace `as` with `from` conversions where possible Alexandre Courbot
2025-10-26 14:39 ` [PATCH 2/7] gpu: nova-core: vbios: remove unneeded u8 conversions Alexandre Courbot
2025-10-26 14:39 ` [PATCH 3/7] gpu: nova-core: vbios: add conversion to u8 for BiosImageType Alexandre Courbot
2025-10-26 14:39 ` [PATCH 4/7] gpu: nova-core: use `try_from` instead of `as` for u32 conversions Alexandre Courbot
2025-10-26 14:39 ` [PATCH 5/7] gpu: nova-core: add extra conversion functions and traits Alexandre Courbot
2025-10-26 15:40 ` Danilo Krummrich
2025-10-27 12:08 ` Alexandre Courbot
2025-10-26 16:44 ` Miguel Ojeda
2025-10-27 12:20 ` Alexandre Courbot
2025-10-27 18:46 ` John Hubbard
2025-10-27 18:58 ` Joel Fernandes
2025-10-28 14:44 ` Alexandre Courbot
2025-10-28 15:12 ` Miguel Ojeda
2025-10-28 17:18 ` John Hubbard [this message]
2025-10-28 22:32 ` Alexandre Courbot
2025-10-28 22:40 ` John Hubbard
2025-10-26 14:39 ` [PATCH 6/7] gpu: nova-core: replace use of `as` with functions from `num` Alexandre Courbot
2025-10-26 14:39 ` [PATCH 7/7] gpu: nova-core: justify remaining uses of `as` Alexandre Courbot
2025-10-26 16:11 ` Miguel Ojeda
2025-10-27 12:07 ` Alexandre Courbot
2025-10-28 14:45 ` Miguel Ojeda
2025-10-26 15:35 ` [PATCH 0/7] gpu: nova-core: remove use of `as` for integer conversions Danilo Krummrich
2025-10-27 12:24 ` Alexandre Courbot
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1772ce29-c84c-42b3-8c77-e92355fbee53@nvidia.com \
--to=jhubbard@nvidia.com \
--cc=a.hindborg@kernel.org \
--cc=acourbot@nvidia.com \
--cc=airlied@gmail.com \
--cc=alex.gaynor@gmail.com \
--cc=aliceryhl@google.com \
--cc=apopple@nvidia.com \
--cc=bjorn3_gh@protonmail.com \
--cc=boqun.feng@gmail.com \
--cc=dakr@kernel.org \
--cc=dri-devel@lists.freedesktop.org \
--cc=epeer@nvidia.com \
--cc=gary@garyguo.net \
--cc=joelagnelf@nvidia.com \
--cc=linux-kernel@vger.kernel.org \
--cc=lossin@kernel.org \
--cc=miguel.ojeda.sandonis@gmail.com \
--cc=nouveau-bounces@lists.freedesktop.org \
--cc=nouveau@lists.freedesktop.org \
--cc=ojeda@kernel.org \
--cc=rust-for-linux@vger.kernel.org \
--cc=simona@ffwll.ch \
--cc=tmgross@umich.edu \
--cc=ttabi@nvidia.com \
--cc=willy@infradead.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®