From mboxrd@z Thu Jan 1 00:00:00 1970 Received: from smtp.kernel.org (aws-us-west-2-korg-mail-1.web.codeaurora.org [10.30.226.201]) (using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits)) (No client certificate requested) by smtp.subspace.kernel.org (Postfix) with ESMTPS id 8AA0C1BD9C9 for ; Sat, 4 Apr 2026 01:50:29 +0000 (UTC) Authentication-Results: smtp.subspace.kernel.org; arc=none smtp.client-ip=10.30.226.201 ARC-Seal:i=1; a=rsa-sha256; d=subspace.kernel.org; s=arc-20240116; t=1775267429; cv=none; b=iipu6+Zg4+9AREti8F6quMZxqSbVsjYuOskghJliE4dzQThrhIsQZ4K247EOwerfGypqUsLFBvPh2bsBO3YE4kDdqlvBMS756oD3Pn5hXI4+tMa/liSMulVvq0uierbXmHzmQeQMYVjXwI/y+TslXOsZRFU7YcTkCvpjIArv8J4= ARC-Message-Signature:i=1; a=rsa-sha256; d=subspace.kernel.org; s=arc-20240116; t=1775267429; c=relaxed/simple; bh=phx3qs8dMYY6rAwt1SmlW4YNc10KK+Pf0xVolC+iDwU=; h=Content-Type:MIME-Version:Subject:From:Message-Id:Date:References: In-Reply-To:To:Cc; b=rxu5jdQqyUeiENaIabEnBhmZdPDvlQZQZb5UkVwBGpyQjJVV6982iwabsUJSjMMCNCY3xbFY4/jr5+ti9ADO1SSmcVCggxfyHLLBAyYtpLzgf3rI8BbOk5YuScukwCMl3tjEk7bov3XYrPiPqPwo/LZ1NukAlCGhIiSgJS9Y9L0= ARC-Authentication-Results:i=1; smtp.subspace.kernel.org; dkim=pass (2048-bit key) header.d=kernel.org header.i=@kernel.org header.b=Fun/c63x; arc=none smtp.client-ip=10.30.226.201 Authentication-Results: smtp.subspace.kernel.org; dkim=pass (2048-bit key) header.d=kernel.org header.i=@kernel.org header.b="Fun/c63x" Received: by smtp.kernel.org (Postfix) with ESMTPSA id 21104C4CEF7; Sat, 4 Apr 2026 01:50:29 +0000 (UTC) DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/simple; d=kernel.org; s=k20201202; t=1775267429; bh=phx3qs8dMYY6rAwt1SmlW4YNc10KK+Pf0xVolC+iDwU=; h=Subject:From:Date:References:In-Reply-To:To:Cc:From; b=Fun/c63xB4fDCsPjuLzX+xurZNy9azUsOWa3UXB9MstCl2m+ZwdNc9HLELTvgsLrs vIf8JFNNC9uFBL1OePH1SMLaYROkTOiY2BYgrxfzXCQ053zhHxiR6T6SUCHUzN5VDx c4Gg+50Ul7FLDjsoZfAUYT5bufgpd8RkA2qMOmLn/7Z6lKnSrKtE6XmtBIN+FRYyFX iGP75PZBaHfCkRrGSozXxEhcC0CBzf9aszQNMxPowamGllSMVZTIwCA6zMdMah12vG oe943vk1KvyBgdwYNuGrMTiCxmtkLuw1Ss4x1xAORbKuyewPhbwP3xvSXIWoO0Xef/ maSdauAyu6wGw== Received: from [10.30.226.235] (localhost [IPv6:::1]) by aws-us-west-2-korg-oddjob-rhel9-1.codeaurora.org (Postfix) with ESMTP id B9E643809A18; Sat, 4 Apr 2026 01:50:11 +0000 (UTC) Content-Type: text/plain; charset="utf-8" Precedence: bulk X-Mailing-List: linux-kernel@vger.kernel.org List-Id: List-Subscribe: List-Unsubscribe: MIME-Version: 1.0 Content-Transfer-Encoding: 8bit Subject: Re: [PATCH 0/6] Restructure per-task CFI prctl() and ptrace interfaces From: patchwork-bot+linux-riscv@kernel.org Message-Id: <177526741054.1520684.8289044721186928310.git-patchwork-notify@kernel.org> Date: Sat, 04 Apr 2026 01:50:10 +0000 References: <177526680875.878386.16551569883089050686.stgit@seppa> In-Reply-To: <177526680875.878386.16551569883089050686.stgit@seppa> To: Paul Walmsley Cc: linux-riscv@lists.infradead.org, linux-kernel@vger.kernel.org, torvalds@linux-foundation.org, tglx@linutronix.de, peterz@infradead.org, broonie@kernel.org Hello: This series was applied to riscv/linux.git (for-next) by Paul Walmsley : On Fri, 3 Apr 2026 19:40:56 -0600 you wrote: > Restructure the per-task CFI indirect branch landing pad prctl() > interface, as suggested by Linus [1]. In place of the current > approach, which follows the style of shadow stack control prctl()s > (PR_{GET,SET,LOCK}_SHADOW_STACK_STATUS), adopt the style of the > speculation control prctl() constants (PR_{GET,SET}_SPECULATION_CTRL). > > Then, to improve readability, expand "indir_br_lp", "lpad", and > related abbreviations in the interfaces, also as requested by Linus. > While here, expand "ss" in the shadow stack ptrace macros to "shadow > stack". > > [...] Here is the summary with links: - [1/6] riscv: ptrace: cfi: fix "PRACE" typo in uapi header (no matching commit) - [2/6] riscv: cfi: clear CFI lock status in start_thread() (no matching commit) - [3/6] riscv: ptrace: expand "LP" references to "branch landing pads" in uapi headers (no matching commit) - [4/6] prctl: rename branch landing pad implementation functions to be more explicit https://git.kernel.org/riscv/c/987bd38dee75 - [5/6] riscv: ptrace: cfi: expand "SS" references to "shadow stack" in uapi headers https://git.kernel.org/riscv/c/c8acc707f48c - [6/6] prctl: cfi: change the branch landing pad prctl()s to be more descriptive https://git.kernel.org/riscv/c/e0d96d3c63f5 You are awesome, thank you! -- Deet-doot-dot, I am a bot. https://korg.docs.kernel.org/patchwork/pwbot.html