From mboxrd@z Thu Jan 1 00:00:00 1970 Received: from smtp.kernel.org (aws-us-west-2-korg-mail-1.web.codeaurora.org [10.30.226.201]) (using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits)) (No client certificate requested) by smtp.subspace.kernel.org (Postfix) with ESMTPS id E80C37081E for ; Sun, 5 Apr 2026 00:50:28 +0000 (UTC) Authentication-Results: smtp.subspace.kernel.org; arc=none smtp.client-ip=10.30.226.201 ARC-Seal:i=1; a=rsa-sha256; d=subspace.kernel.org; s=arc-20240116; t=1775350229; cv=none; b=TCE0szairSk17AALqv0ZLa/TsF7mNbxJ/I89P9EROLSPrqiOroliC0lQNeeipXjLQNMzFiCZktNYwm0cXslK9+IjpREjd7ioA0QwEgxpZKeDEGcgn3uC4k1Jsd9lth6IipTB2PHt2IZSu5N561OKjhqfPmKNOL9gnlIFQ4AP9n0= ARC-Message-Signature:i=1; a=rsa-sha256; d=subspace.kernel.org; s=arc-20240116; t=1775350229; c=relaxed/simple; bh=Y1CXJ7f+au3Zjz4W6Dd5ph3A520Nxdxgjuk367KbPuM=; h=Content-Type:MIME-Version:Subject:From:Message-Id:Date:References: In-Reply-To:To:Cc; b=I68UZR11nfuNkeYmaJH8zCff/GgNVXbj/S5X75oR15Hcfxi+b4WLYjqmgxfmJHWFTakADYjrYkAQEYYXJNB0PIbUnvl2i9J2o8PSe/RI6T2CtHShgmxNPKI+qmXvIwQFjnDma3CExSIKkd/jN6DTK7nBQXOsyLn/X5K1gdgGy90= ARC-Authentication-Results:i=1; smtp.subspace.kernel.org; dkim=pass (2048-bit key) header.d=kernel.org header.i=@kernel.org header.b=lDBL2BrL; arc=none smtp.client-ip=10.30.226.201 Authentication-Results: smtp.subspace.kernel.org; dkim=pass (2048-bit key) header.d=kernel.org header.i=@kernel.org header.b="lDBL2BrL" Received: by smtp.kernel.org (Postfix) with ESMTPSA id 8B7CEC19421; Sun, 5 Apr 2026 00:50:28 +0000 (UTC) DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/simple; d=kernel.org; s=k20201202; t=1775350228; bh=Y1CXJ7f+au3Zjz4W6Dd5ph3A520Nxdxgjuk367KbPuM=; h=Subject:From:Date:References:In-Reply-To:To:Cc:From; b=lDBL2BrL7NURr671xgWhfeipvESZ0a7hjZDB9clKkuXbn6pS3+YHLmH70LZbdWcvq Ugl2fnIckFkBMKPQTmY9L1CkQHuh2kRWxJ/86JGM4BvRNtw829MSiv022iPEhyHigy xBRSu7NaUXqzKXWbQrfW6PB861vR4EeXbf8z1rBdw5YpqQI1rc9qTdxaw/GrjXHr35 oCvkLswhev2xeoJVcR0g7290zZ6q9ZaY5ntnKjy+hC9VTA+JB99fWqVQxNtcfIFDam O42Yrfu/ZuJD0EYzn65O7AuKmQao6d39saayrLKJsooDtUxII/EiNpyHpDhpBsL0dX sjTAJunIDN+Fg== Received: from [10.30.226.235] (localhost [IPv6:::1]) by aws-us-west-2-korg-oddjob-rhel9-1.codeaurora.org (Postfix) with ESMTP id 3FC6E3809A1B; Sun, 5 Apr 2026 00:50:10 +0000 (UTC) Content-Type: text/plain; charset="utf-8" Precedence: bulk X-Mailing-List: linux-kernel@vger.kernel.org List-Id: List-Subscribe: List-Unsubscribe: MIME-Version: 1.0 Content-Transfer-Encoding: 8bit Subject: Re: [PATCH 0/6] Restructure per-task CFI prctl() and ptrace interfaces From: patchwork-bot+linux-riscv@kernel.org Message-Id: <177535020904.1815399.7322753771351511383.git-patchwork-notify@kernel.org> Date: Sun, 05 Apr 2026 00:50:09 +0000 References: <177526680875.878386.16551569883089050686.stgit@seppa> In-Reply-To: <177526680875.878386.16551569883089050686.stgit@seppa> To: Paul Walmsley Cc: linux-riscv@lists.infradead.org, linux-kernel@vger.kernel.org, torvalds@linux-foundation.org, tglx@linutronix.de, peterz@infradead.org, broonie@kernel.org Hello: This series was applied to riscv/linux.git (fixes) by Paul Walmsley : On Fri, 3 Apr 2026 19:40:56 -0600 you wrote: > Restructure the per-task CFI indirect branch landing pad prctl() > interface, as suggested by Linus [1]. In place of the current > approach, which follows the style of shadow stack control prctl()s > (PR_{GET,SET,LOCK}_SHADOW_STACK_STATUS), adopt the style of the > speculation control prctl() constants (PR_{GET,SET}_SPECULATION_CTRL). > > Then, to improve readability, expand "indir_br_lp", "lpad", and > related abbreviations in the interfaces, also as requested by Linus. > While here, expand "ss" in the shadow stack ptrace macros to "shadow > stack". > > [...] Here is the summary with links: - [1/6] riscv: ptrace: cfi: fix "PRACE" typo in uapi header https://git.kernel.org/riscv/c/a621d9cdc8d0 - [2/6] riscv: cfi: clear CFI lock status in start_thread() https://git.kernel.org/riscv/c/a6ede084c4b7 - [3/6] riscv: ptrace: expand "LP" references to "branch landing pads" in uapi headers https://git.kernel.org/riscv/c/ac4e61c730d7 - [4/6] prctl: rename branch landing pad implementation functions to be more explicit (no matching commit) - [5/6] riscv: ptrace: cfi: expand "SS" references to "shadow stack" in uapi headers (no matching commit) - [6/6] prctl: cfi: change the branch landing pad prctl()s to be more descriptive (no matching commit) You are awesome, thank you! -- Deet-doot-dot, I am a bot. https://korg.docs.kernel.org/patchwork/pwbot.html