From: patchwork-bot+netdevbpf@kernel.org
To: Jiangshan Yi <yijiangshan@kylinos.cn>
Cc: sgoutham@marvell.com, rkannoth@marvell.com, gakula@marvell.com,
sbhatta@marvell.com, andrew+netdev@lunn.ch, davem@davemloft.net,
edumazet@google.com, kuba@kernel.org, pabeni@redhat.com,
netdev@vger.kernel.org, linux-kernel@vger.kernel.org,
13667453960@163.com
Subject: Re: [PATCH net-next v2] octeontx2-af: consolidate RVU AFVF device id definitions
Date: Tue, 15 Sep 2026 02:30:10 +0000 [thread overview]
Message-ID: <178943941013.1322157.7401389527831061083.git-patchwork-notify@kernel.org> (raw)
In-Reply-To: <20260910104102.590989-1-yijiangshan@kylinos.cn>
Hello:
This patch was applied to netdev/net-next.git (main)
by Jakub Kicinski <kuba@kernel.org>:
On Thu, 10 Sep 2026 18:41:02 +0800 you wrote:
> commit f695390ea639 ("octeontx2-af: Fix limiting SRIOV VF count logic")
> added a local PCI_DEVID_OCTEONTX2_RVU_AFVF define in rvu.c, although
> the same value was already defined twice elsewhere: as RVU_LBK_VF_DEVID
> in af/rvu.h and as PCI_DEVID_OCTEONTX2_RVU_AFVF in nic/otx2_common.h.
>
> Move the definition into the "PCI device IDs" block in af/rvu.h, rename
> RVU_LBK_VF_DEVID to match the PCI_DEVID_* naming convention of its
> peers, and drop the redundant copies in rvu.c and nic/otx2_common.h,
> the latter already including <rvu.h> through the af include path.
>
> [...]
Here is the summary with links:
- [net-next,v2] octeontx2-af: consolidate RVU AFVF device id definitions
https://git.kernel.org/netdev/net-next/c/ce71c433395e
You are awesome, thank you!
--
Deet-doot-dot, I am a bot.
https://korg.docs.kernel.org/patchwork/pwbot.html
prev parent reply other threads:[~2026-09-15 2:31 UTC|newest]
Thread overview: 3+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-09-10 10:41 Jiangshan Yi
2026-09-11 10:53 ` Simon Horman
2026-09-15 2:30 ` patchwork-bot+netdevbpf [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=178943941013.1322157.7401389527831061083.git-patchwork-notify@kernel.org \
--to=patchwork-bot+netdevbpf@kernel.org \
--cc=13667453960@163.com \
--cc=andrew+netdev@lunn.ch \
--cc=davem@davemloft.net \
--cc=edumazet@google.com \
--cc=gakula@marvell.com \
--cc=kuba@kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=netdev@vger.kernel.org \
--cc=pabeni@redhat.com \
--cc=rkannoth@marvell.com \
--cc=sbhatta@marvell.com \
--cc=sgoutham@marvell.com \
--cc=yijiangshan@kylinos.cn \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®