From: "Rafael J. Wysocki" <rjw@rjwysocki.net>
To: Yangtao Li <tiny.windzz@gmail.com>
Cc: len.brown@intel.com, pavel@ucw.cz, gregkh@linuxfoundation.org,
linux-pm@vger.kernel.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH 1/4] PM / core: Introduce dpm_async_fn() helper
Date: Wed, 10 Apr 2019 10:15:17 +0200 [thread overview]
Message-ID: <1823590.m8T6rWHPoh@aspire.rjw.lan> (raw)
In-Reply-To: <20190316045928.31934-2-tiny.windzz@gmail.com>
On Saturday, March 16, 2019 5:59:25 AM CEST Yangtao Li wrote:
> When we want to execute device pm functions asynchronously, we'll
> do the following for the device:
>
> 1) reinit_completion(&dev->power.completion);
> 2) Check if the device enables asynchronous suspend.
> 3) If necessary, execute the corresponding function asynchronously.
>
> There are a lot of such repeated operations here, in fact we can avoid
> this. So introduce dpm_async_fn() to have better code readability and
> reuse.
>
> And use this function to do some cleanup.
>
> Signed-off-by: Yangtao Li <tiny.windzz@gmail.com>
I'm queuing up this one, but the [2-4/4] are not convincing.
Thanks!
next prev parent reply other threads:[~2019-04-10 8:17 UTC|newest]
Thread overview: 7+ messages / expand[flat|nested] mbox.gz Atom feed top
2019-03-16 4:59 [PATCH 0/4] PM / core: Introduce some helper for better Code reuse Yangtao Li
2019-03-16 4:59 ` [PATCH 1/4] PM / core: Introduce dpm_async_fn() helper Yangtao Li
2019-04-10 8:15 ` Rafael J. Wysocki [this message]
2019-03-16 4:59 ` [PATCH 2/4] PM / core: Introduce DEVICE_SUSPEND_FUNC() helper macro Yangtao Li
2019-03-16 4:59 ` [PATCH 3/4] PM / core: Introduce ASYNC_RESUME_FUNC() " Yangtao Li
2019-03-16 4:59 ` [PATCH 4/4] PM / core: Introduce ASYNC_SUSPEND_FUNC() " Yangtao Li
2019-03-18 12:20 ` [PATCH 0/4] PM / core: Introduce some helper for better Code reuse Pavel Machek
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1823590.m8T6rWHPoh@aspire.rjw.lan \
--to=rjw@rjwysocki.net \
--cc=gregkh@linuxfoundation.org \
--cc=len.brown@intel.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-pm@vger.kernel.org \
--cc=pavel@ucw.cz \
--cc=tiny.windzz@gmail.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®