From mboxrd@z Thu Jan 1 00:00:00 1970 Received: from foss.arm.com (foss.arm.com [217.140.110.172]) by smtp.subspace.kernel.org (Postfix) with ESMTP id CA08A1EC01D; Mon, 3 Mar 2025 10:18:44 +0000 (UTC) Authentication-Results: smtp.subspace.kernel.org; arc=none smtp.client-ip=217.140.110.172 ARC-Seal:i=1; a=rsa-sha256; d=subspace.kernel.org; s=arc-20240116; t=1740997126; cv=none; b=hHTTxBNcXmuyPfRtgYnDOLaAYMxI/23Er/XL+wUD4Mpxk2FMuAtIM2N0QjybwbvgAti/Dp86a2ArZbGyMczJVfIUg7/TSJPtZEfPJ9uNq2fJ0zGLLHc2CgCPM4VeqNWG0DddKZVzq2LmLkdVUm+OLLdJg5VnC6xTVu7QCSCeFvo= ARC-Message-Signature:i=1; a=rsa-sha256; d=subspace.kernel.org; s=arc-20240116; t=1740997126; c=relaxed/simple; bh=4WWNAHQh+XvY80gXEnh5L9romOWeq5HbCjAs1NzKAIs=; h=Message-ID:Date:MIME-Version:Subject:To:Cc:References:From: In-Reply-To:Content-Type; b=A2CnxNgQ+5XKcTdiwlTkxuYvLyDrHa2sg7m+xo9lI0gj8XcbvM5qB70K0PrPM4hhnbMGMu242/iSXZ0PwCl+bwrX0dzHwSmpA4PcHWihjiVWxQ1bFAMAelML96IGuszkdkCTydmit/Gc4jsqm54XzlkH0SV4Dg7/gsCKoDfwO8g= ARC-Authentication-Results:i=1; smtp.subspace.kernel.org; dmarc=pass (p=none dis=none) header.from=arm.com; spf=pass smtp.mailfrom=arm.com; arc=none smtp.client-ip=217.140.110.172 Authentication-Results: smtp.subspace.kernel.org; dmarc=pass (p=none dis=none) header.from=arm.com Authentication-Results: smtp.subspace.kernel.org; spf=pass smtp.mailfrom=arm.com Received: from usa-sjc-imap-foss1.foss.arm.com (unknown [10.121.207.14]) by usa-sjc-mx-foss1.foss.arm.com (Postfix) with ESMTP id 4F2E812FC; Mon, 3 Mar 2025 02:18:58 -0800 (PST) Received: from [10.163.38.109] (unknown [10.163.38.109]) by usa-sjc-imap-foss1.foss.arm.com (Postfix) with ESMTPSA id C17CC3F66E; Mon, 3 Mar 2025 02:18:41 -0800 (PST) Message-ID: <18ea9794-3901-4802-875c-b0327984a9d6@arm.com> Date: Mon, 3 Mar 2025 15:48:38 +0530 Precedence: bulk X-Mailing-List: linux-kernel@vger.kernel.org List-Id: List-Subscribe: List-Unsubscribe: MIME-Version: 1.0 User-Agent: Mozilla Thunderbird Subject: Re: [PATCH v3 04/10] selftests/mm/uffd: Rename nr_cpus -> nr_threads To: Brendan Jackman Cc: Lorenzo Stoakes , Andrew Morton , Shuah Khan , linux-mm@kvack.org, linux-kselftest@vger.kernel.org, linux-kernel@vger.kernel.org References: <20250228-mm-selftests-v3-0-958e3b6f0203@google.com> <20250228-mm-selftests-v3-4-958e3b6f0203@google.com> Content-Language: en-US From: Dev Jain In-Reply-To: Content-Type: text/plain; charset=UTF-8; format=flowed Content-Transfer-Encoding: 7bit On 03/03/25 3:17 pm, Brendan Jackman wrote: > On Fri, Feb 28, 2025 at 11:06:35PM +0530, Dev Jain wrote: >> Taking a cursory look at the test, it creates three threads for each cpu. >> The bounding of the variable is fine but that being the reason to rename the >> variable is not making sense to me. > > Hmm yeah the name needs to be more abstract. Do you think nr_workers > would be confusing? Or even just "parallelism" or nr_parallel? Or any > other ideas? > > FWIW I briefly looked at just cleaning this up to remove the global > variable but that's a bigger time investment than I can afford here I > think. (The local variable in stress() would still need a better name > anyway). > > Thanks for the review BTW! Your welcome. I personally prefer leaving it as is; unless someone comes up and completely cleans up the structure, let us save our collective brain cycles for more meaningful battles than renaming variables :)