mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: "Rafael J. Wysocki" <rjw@rjwysocki.net>
To: Jiang Liu <jiang.liu@linux.intel.com>
Cc: "Rafael J . Wysocki" <rafael.j.wysocki@intel.com>,
	Bjorn Helgaas <bhelgaas@google.com>,
	Lv Zheng <lv.zheng@intel.com>, Len Brown <lenb@kernel.org>,
	Tony Luck <tony.luck@intel.com>,
	Leonidas Da Silva Barbosa <leosilva@linux.vnet.ibm.com>,
	Ashley Lai <ashley@ashleylai.com>,
	Peter Huewe <peterhuewe@gmx.de>, Rajiv Andrade <mail@srajiv.net>,
	Marcel Selhorst <tpmdd@selhorst.net>,
	Sirrix AG <tpmdd@sirrix.com>,
	Daniel Vetter <daniel.vetter@ffwll.ch>,
	David Airlie <airlied@linux.ie>, Jiri Kosina <jkosina@suse.cz>,
	linux-acpi@vger.kernel.org, linux-kernel@vger.kernel.org
Subject: Re: [Patch v2 00/13] Introduce ACPI _DSM helper functions to simplify code
Date: Sun, 05 Jan 2014 22:58:59 +0100	[thread overview]
Message-ID: <1922556.NGT5hD6mbC@vostro.rjw.lan> (raw)
In-Reply-To: <1387456702-4709-1-git-send-email-jiang.liu@linux.intel.com>

On Thursday, December 19, 2013 08:38:09 PM Jiang Liu wrote:
> There are several drivers making use of ACPI _DSM method to detect
> and invoke device specific methods. Currently every driver has
> implemented its private version to support ACPI _DSM method.
> So this patch introduces three helper functions to support ACPI _DSM
> method, which will be used to replace open-coded versions.  It helps
> to simplify code and improve code readability.
> 
> It also includes some bugfixes for TPM/nouveau drivers.
> 
> It applies to the mainstream kernel on top of
> b0031f2 Merge tag 's2mps11-build' of git://git.kernel.org/pub/scm/linux/kernel/git/broonie/regulator
> 
> Due to lacking of hardware platform, I have only tested the ACPI _DSM
> helper functions and TPM related changes, but haven't tested changes to
> other drivers yet. So appreciate help to review and test these patches.
> 
> V1->V2
> 1) fix an issue in initializing acpi_object structure
> 
> Jiang Liu (13):
>   ACPI: introduce helper interfaces to support ACPI _DSM method
>   ACPI, extlog: replace open-coded _DSM specific code with helper
>     functions
>   PCI, pci-label: release allocated ACPI object on error recovery path
>   ACPI, PCI: replace open-coded _DSM specific code with helper
>     functions
>   PCI, pci-label: treat PCI label with index 0 as valid label
>   ACPI, TPM: fix memory leak when walking ACPI namespace
>   ACPI, TPM: matching node name instead of full path when searching for
>     TPM device
>   ACPI, TPM: replace open-coded _DSM specific code with helper
>     functions
>   ACPI, TPM: detecting PPI features by checking availability of _DSM
>     functions
>   ACPI, i2c-hid: replace open-coded _DSM specific code with helper
>     functions
>   ACPI, i915: replace open-coded _DSM specific code with helper
>     functions
>   nouveau: fix memory leak in ACPI _DSM related code
>   ACPI, nouveau: replace open-coded _DSM specific code with helper
>     functions
> 
>  drivers/acpi/acpi_extlog.c                     |   61 +---
>  drivers/acpi/utils.c                           |   98 ++++++
>  drivers/char/tpm/tpm_ppi.c                     |  406 +++++++++---------------
>  drivers/gpu/drm/i915/intel_acpi.c              |  144 ++-------
>  drivers/gpu/drm/nouveau/core/subdev/mxm/base.c |   48 +--
>  drivers/gpu/drm/nouveau/nouveau_acpi.c         |  134 +++-----
>  drivers/hid/i2c-hid/i2c-hid.c                  |   26 +-
>  drivers/pci/pci-label.c                        |  129 +++-----
>  include/acpi/acpi_bus.h                        |   26 ++
>  9 files changed, 406 insertions(+), 666 deletions(-)

I've queued up the entire series for 3.14, thanks a lot!

-- 
I speak only for myself.
Rafael J. Wysocki, Intel Open Source Technology Center.

  parent reply	other threads:[~2014-01-05 21:45 UTC|newest]

Thread overview: 17+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2013-12-19 12:38 Jiang Liu
2013-12-19 12:38 ` [Patch v2 01/13] ACPI: introduce helper interfaces to support ACPI _DSM method Jiang Liu
2013-12-19 12:38 ` [Patch v2 03/13] PCI, pci-label: release allocated ACPI object on error recovery path Jiang Liu
2013-12-19 18:22   ` Bjorn Helgaas
2013-12-20  2:01     ` Rafael J. Wysocki
2013-12-19 12:38 ` [Patch v2 04/13] ACPI, PCI: replace open-coded _DSM specific code with helper functions Jiang Liu
2013-12-19 12:38 ` [Patch v2 05/13] PCI, pci-label: treat PCI label with index 0 as valid label Jiang Liu
2013-12-19 12:38 ` [Patch v2 06/13] ACPI, TPM: fix memory leak when walking ACPI namespace Jiang Liu
2013-12-19 12:38 ` [Patch v2 07/13] ACPI, TPM: matching node name instead of full path when searching for TPM device Jiang Liu
2013-12-19 12:38 ` [Patch v2 08/13] ACPI, TPM: replace open-coded _DSM specific code with helper functions Jiang Liu
2013-12-19 12:38 ` [Patch v2 09/13] ACPI, TPM: detecting PPI features by checking availability of _DSM functions Jiang Liu
2013-12-19 12:38 ` [Patch v2 10/13] ACPI, i2c-hid: replace open-coded _DSM specific code with helper functions Jiang Liu
2013-12-19 12:38 ` [Patch v2 11/13] ACPI, i915: " Jiang Liu
2013-12-19 12:38 ` [Patch v2 12/13] nouveau: fix memory leak in ACPI _DSM related code Jiang Liu
2013-12-19 12:38 ` [Patch v2 13/13] ACPI, nouveau: replace open-coded _DSM specific code with helper functions Jiang Liu
2014-01-05 21:58 ` Rafael J. Wysocki [this message]
2014-01-06  6:18   ` [Patch v2 00/13] Introduce ACPI _DSM helper functions to simplify code Jiang Liu

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1922556.NGT5hD6mbC@vostro.rjw.lan \
    --to=rjw@rjwysocki.net \
    --cc=airlied@linux.ie \
    --cc=ashley@ashleylai.com \
    --cc=bhelgaas@google.com \
    --cc=daniel.vetter@ffwll.ch \
    --cc=jiang.liu@linux.intel.com \
    --cc=jkosina@suse.cz \
    --cc=lenb@kernel.org \
    --cc=leosilva@linux.vnet.ibm.com \
    --cc=linux-acpi@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=lv.zheng@intel.com \
    --cc=mail@srajiv.net \
    --cc=peterhuewe@gmx.de \
    --cc=rafael.j.wysocki@intel.com \
    --cc=tony.luck@intel.com \
    --cc=tpmdd@selhorst.net \
    --cc=tpmdd@sirrix.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®