From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1752516AbdKEIas (ORCPT ); Sun, 5 Nov 2017 03:30:48 -0500 Received: from mout.web.de ([212.227.15.3]:51901 "EHLO mout.web.de" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1751823AbdKEIaq (ORCPT ); Sun, 5 Nov 2017 03:30:46 -0500 Subject: Re: [PATCH] USB: core: Improve unlocking of a mutex in two functions To: Geert Uytterhoeven , linux-usb@vger.kernel.org, kernel-janitors@vger.kernel.org Cc: Alan Stern , Eugene Korenevsky , Greg Kroah-Hartman , =?UTF-8?B?R8O8bnRlciBSw7Zjaw==?= , Jaejoong Kim , Johan Hovold , Jonathan Corbet , Mathias Nyman , Mauro Carvalho Chehab , LKML References: <0ff5f74e-ae23-5c97-8998-0e598ceae96b@users.sourceforge.net> From: SF Markus Elfring Message-ID: <1923596b-ce14-7b80-6148-f67143b4a367@users.sourceforge.net> Date: Sun, 5 Nov 2017 09:29:22 +0100 User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Thunderbird/52.4.0 MIME-Version: 1.0 In-Reply-To: Content-Type: text/plain; charset=utf-8 Content-Language: en-GB Content-Transfer-Encoding: 7bit X-Provags-ID: V03:K0:dvMHlto/VgVvc9RwrisJxa1rB3dZdWl8nqolL57PeWqO0dY6YdU GBsShZbnWt6MtOd1T5jTcgu1qt+dLBQUaP5li53hrZKGbNbFRYD/XX4Az9klUizkIRzNw5r jGCQmPo1WY3d7PlrOimcYMX+FJKi3F5eNdEyBxayi5SD8pEXK9znkdFvIqMf7pUlXZbyYs2 GCwtMyOEcb8Ig/rvArUwQ== X-UI-Out-Filterresults: notjunk:1;V01:K0:+JUYuCkdqiI=:nmzCK2fOYjYpR1EQI7bmVt HvIhg++sqhsaE8h6Oo3hrhgj5v1DwL1NIFzqa9p1IRAeE2DLtvAwiWNOPU+FYwJqgP1VhPgp7 ID9ibY/fBt3EqTlKf8GIYcsjUHIMsmKJP10zaBae1NxC2RsecZXxc3F2uXOewo0Qw7A90gy+I 2I2ps6lZCv8ICQmU0Mv9hUSCKj7HqeB5KpNM4h/+3noRz4gCtAOhjQNRaYi9gftBSAieqUGxP HTlr+xO8zM7JQEJMBUzPfhh/j3CQxT/rfT3YDujwMh1jDfgGsAvMOM+LmLNeNls5SEySQKWJu Ivy/3RSz4doH5mhBfUA761O/ERalcxK2h17eTe8NL7HE0vSRcxfFxMntWEQaOFsFUkPoCHq/7 BgbijugmXCYhPdkpCq2o+oPwFX8OIDDI3TNHpC58cuhdhjbIhdhK4u5lPKyt3W+PXJXNxZjdl wTXXlV34kI3AcSAlEAPzEcZv7pwmCgGNLWI/HtYEi45XFUjGa9CeaNlSOiqnfQgJCdjrriTM6 Dpxh8MW8wKGYQvuDciIbmZn2PQURXmiHQumN7NuOtJvfYEUtenzXnkTap/R87uks4M+ON3lhu 7jHG9u4ECcuu3PacW3IthCe6du2ad0wzdu2UiJ3R4A7xc0lo9JrH3vVfopUm4YPP7w4zt9CEc FwL+3+0qhjBpT5r/Z/e6f9enxAmZS5dV0X2RHUMzZ03fMqyhHnSidp0+eUfHlVpYvTZU53hXH NQefZOdSkTSbQ5pgzp85196rHKRKiNKs5n5lnRk61k3wWohr7ehkM/sWcj942YSmN7SJaxbs/ CnCwXaAHkLhBWOD2G81wuXE5NwmJDx/RMTmNPFHxF0TqkyEG5c= Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org >> @@ -5529,8 +5528,7 @@ static int usb_reset_and_verify_device(struct usb_device *udev) >> dev_err(&udev->dev, >> "can't restore configuration #%d (error=%d)\n", >> udev->actconfig->desc.bConfigurationValue, ret); >> - mutex_unlock(hcd->bandwidth_mutex); >> - goto re_enumerate; >> + goto unlock; >> } >> mutex_unlock(hcd->bandwidth_mutex); >> usb_set_device_state(udev, USB_STATE_CONFIGURED); >> @@ -5583,6 +5581,8 @@ static int usb_reset_and_verify_device(struct usb_device *udev) >> udev->bos = bos; >> return 0; >> >> +unlock: >> + mutex_unlock(hcd->bandwidth_mutex); > > This makes it harder for the reader, I am curious if the view on the preferred code readability can be clarified further. > as the mutex_unlock() is now far below the block > of code that's protected by the lock. I got an other software development opinion for this aspect. Can the label be clear enough about the shown purpose already? Regards, Markus