From: Arend Van Spriel <arend.vanspriel@broadcom.com>
To: "Kuan-Wei Chiu" <visitorckw@gmail.com>
Cc: Johannes Berg <johannes@sipsolutions.net>, <tglx@linutronix.de>,
<mingo@redhat.com>, <bp@alien8.de>,
<dave.hansen@linux.intel.com>, <x86@kernel.org>, <jk@ozlabs.org>,
<joel@jms.id.au>, <eajames@linux.ibm.com>,
<andrzej.hajda@intel.com>, <neil.armstrong@linaro.org>,
<rfoss@kernel.org>, <maarten.lankhorst@linux.intel.com>,
<mripard@kernel.org>, <tzimmermann@suse.de>, <airlied@gmail.com>,
<simona@ffwll.ch>, <dmitry.torokhov@gmail.com>,
<mchehab@kernel.org>, <awalls@md.metrocast.net>,
<hverkuil@xs4all.nl>, <miquel.raynal@bootlin.com>,
<richard@nod.at>, <vigneshr@ti.com>, <louis.peens@corigine.com>,
<andrew+netdev@lunn.ch>, <davem@davemloft.net>,
<edumazet@google.com>, <pabeni@redhat.com>,
<parthiban.veerasooran@microchip.com>,
<gregkh@linuxfoundation.org>, <jirislaby@kernel.org>,
<yury.norov@gmail.com>, <akpm@linux-foundation.org>,
<jdelvare@suse.com>, <linux@roeck-us.net>,
<alexandre.belloni@bootlin.com>, <pgaj@cadence.com>,
<hpa@zytor.com>, <alistair@popple.id.au>,
<linux@rasmusvillemoes.dk>, <Laurent.pinchart@ideasonboard.com>,
<jonas@kwiboo.se>, <jernej.skrabec@gmail.com>, <kuba@kernel.org>,
<linux-kernel@vger.kernel.org>, <linux-fsi@lists.ozlabs.org>,
<dri-devel@lists.freedesktop.org>, <linux-input@vger.kernel.org>,
<linux-media@vger.kernel.org>, <linux-mtd@lists.infradead.org>,
<oss-drivers@corigine.com>, <netdev@vger.kernel.org>,
<linux-wireless@vger.kernel.org>, <brcm80211@lists.linux.dev>,
<brcm80211-dev-list.pdl@broadcom.com>,
<linux-serial@vger.kernel.org>, <bpf@vger.kernel.org>,
<jserv@ccns.ncku.edu.tw>, <Frank.Li@nxp.com>,
<linux-hwmon@vger.kernel.org>, <linux-i3c@lists.infradead.org>,
<david.laight.linux@gmail.com>, <andrew.cooper3@citrix.com>,
Yu-Chun Lin <eleanor15x@gmail.com>
Subject: Re: [PATCH v4 03/13] media: pci: cx18-av-vbi: Replace open-coded parity calculation with parity_odd()
Date: Fri, 11 Apr 2025 19:04:43 +0200 [thread overview]
Message-ID: <19625cf93f8.279b.9b12b7fc0a3841636cfb5e919b41b954@broadcom.com> (raw)
In-Reply-To: <Z/lFQ85vhSQiFDBm@visitorckw-System-Product-Name>
On April 11, 2025 6:37:35 PM Kuan-Wei Chiu <visitorckw@gmail.com> wrote:
> On Thu, Apr 10, 2025 at 07:08:58AM +0200, Arend Van Spriel wrote:
>> On April 10, 2025 12:06:52 AM Johannes Berg <johannes@sipsolutions.net> wrote:
>>
>>> On Wed, 2025-04-09 at 20:43 +0200, Arend van Spriel wrote:
>>>>
>>>> This is orthogonal to the change to parity_odd() though. More specific
>>>> to the new parity_odd() you can now do following as parity_odd()
>>>> argument is u64:
>>>>
>>>> err = !parity_odd(*(u16 *)p);
>>>
>>> Can it though? Need to be careful with alignment with that, I'd think.
>>
>> My bad. You are absolutely right.
> Then maybe we can still go with:
>
> err = !parity_odd(p[0] ^ p[1]);
>
> I believe this should still be a fairly safe approach?
Yes. Or whatever the name will be ;-)
Regards,
Arend
next prev parent reply other threads:[~2025-04-11 17:05 UTC|newest]
Thread overview: 43+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-04-09 15:43 [PATCH v4 00/13] Introduce parity_odd() and refactor redundant parity code Kuan-Wei Chiu
2025-04-09 15:43 ` [PATCH v4 01/13] bitops: Change parity8() to parity_odd() with u64 input and bool return type Kuan-Wei Chiu
2025-04-09 16:59 ` Yury Norov
2025-04-09 18:25 ` Kuan-Wei Chiu
2025-04-09 18:39 ` Guenter Roeck
2025-04-09 19:21 ` Kuan-Wei Chiu
2025-04-09 15:43 ` [PATCH v4 02/13] media: media/test_drivers: Replace open-coded parity calculation with parity_odd() Kuan-Wei Chiu
2025-04-09 17:03 ` Yury Norov
2025-04-09 18:23 ` Kuan-Wei Chiu
2025-04-09 18:41 ` Yury Norov
2025-04-09 18:56 ` Kuan-Wei Chiu
2025-04-10 15:07 ` Yury Norov
2025-04-25 8:33 ` Hans Verkuil
2025-04-09 15:43 ` [PATCH v4 03/13] media: pci: cx18-av-vbi: " Kuan-Wei Chiu
2025-04-09 18:43 ` Arend van Spriel
2025-04-09 18:59 ` Kuan-Wei Chiu
2025-04-25 8:51 ` Hans Verkuil
2025-04-09 22:06 ` Johannes Berg
2025-04-10 5:08 ` Arend Van Spriel
2025-04-11 16:37 ` Kuan-Wei Chiu
2025-04-11 17:04 ` Arend Van Spriel [this message]
2025-04-09 15:43 ` [PATCH v4 04/13] media: saa7115: " Kuan-Wei Chiu
2025-04-25 8:51 ` Hans Verkuil
2025-04-09 15:43 ` [PATCH v4 05/13] serial: max3100: " Kuan-Wei Chiu
2025-04-09 17:24 ` Yury Norov
2025-04-09 18:30 ` Kuan-Wei Chiu
2025-04-09 15:43 ` [PATCH v4 06/13] lib/bch: " Kuan-Wei Chiu
2025-04-09 15:43 ` [PATCH v4 07/13] Input: joystick - " Kuan-Wei Chiu
2025-04-09 19:23 ` Dmitry Torokhov
2025-04-09 15:43 ` [PATCH v4 08/13] net: ethernet: oa_tc6: " Kuan-Wei Chiu
2025-04-09 15:43 ` [PATCH v4 09/13] wifi: brcm80211: " Kuan-Wei Chiu
2025-04-15 16:13 ` Simon Horman
2025-04-09 15:43 ` [PATCH v4 10/13] drm/bridge: dw-hdmi: " Kuan-Wei Chiu
2025-04-09 15:43 ` [PATCH v4 11/13] mtd: ssfdc: " Kuan-Wei Chiu
2025-04-09 15:43 ` [PATCH v4 12/13] fsi: i2cr: " Kuan-Wei Chiu
2025-04-09 15:43 ` [PATCH v4 13/13] nfp: bpf: " Kuan-Wei Chiu
2025-04-09 16:54 ` [PATCH v4 00/13] Introduce parity_odd() and refactor redundant parity code Yury Norov
2025-04-09 18:15 ` Kuan-Wei Chiu
2025-04-09 18:33 ` Yury Norov
2025-04-10 2:09 ` H. Peter Anvin
2025-04-11 16:34 ` Kuan-Wei Chiu
2025-04-25 19:33 ` H. Peter Anvin
2025-04-26 9:14 ` Kuan-Wei Chiu
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=19625cf93f8.279b.9b12b7fc0a3841636cfb5e919b41b954@broadcom.com \
--to=arend.vanspriel@broadcom.com \
--cc=Frank.Li@nxp.com \
--cc=Laurent.pinchart@ideasonboard.com \
--cc=airlied@gmail.com \
--cc=akpm@linux-foundation.org \
--cc=alexandre.belloni@bootlin.com \
--cc=alistair@popple.id.au \
--cc=andrew+netdev@lunn.ch \
--cc=andrew.cooper3@citrix.com \
--cc=andrzej.hajda@intel.com \
--cc=awalls@md.metrocast.net \
--cc=bp@alien8.de \
--cc=bpf@vger.kernel.org \
--cc=brcm80211-dev-list.pdl@broadcom.com \
--cc=brcm80211@lists.linux.dev \
--cc=dave.hansen@linux.intel.com \
--cc=davem@davemloft.net \
--cc=david.laight.linux@gmail.com \
--cc=dmitry.torokhov@gmail.com \
--cc=dri-devel@lists.freedesktop.org \
--cc=eajames@linux.ibm.com \
--cc=edumazet@google.com \
--cc=eleanor15x@gmail.com \
--cc=gregkh@linuxfoundation.org \
--cc=hpa@zytor.com \
--cc=hverkuil@xs4all.nl \
--cc=jdelvare@suse.com \
--cc=jernej.skrabec@gmail.com \
--cc=jirislaby@kernel.org \
--cc=jk@ozlabs.org \
--cc=joel@jms.id.au \
--cc=johannes@sipsolutions.net \
--cc=jonas@kwiboo.se \
--cc=jserv@ccns.ncku.edu.tw \
--cc=kuba@kernel.org \
--cc=linux-fsi@lists.ozlabs.org \
--cc=linux-hwmon@vger.kernel.org \
--cc=linux-i3c@lists.infradead.org \
--cc=linux-input@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-media@vger.kernel.org \
--cc=linux-mtd@lists.infradead.org \
--cc=linux-serial@vger.kernel.org \
--cc=linux-wireless@vger.kernel.org \
--cc=linux@rasmusvillemoes.dk \
--cc=linux@roeck-us.net \
--cc=louis.peens@corigine.com \
--cc=maarten.lankhorst@linux.intel.com \
--cc=mchehab@kernel.org \
--cc=mingo@redhat.com \
--cc=miquel.raynal@bootlin.com \
--cc=mripard@kernel.org \
--cc=neil.armstrong@linaro.org \
--cc=netdev@vger.kernel.org \
--cc=oss-drivers@corigine.com \
--cc=pabeni@redhat.com \
--cc=parthiban.veerasooran@microchip.com \
--cc=pgaj@cadence.com \
--cc=rfoss@kernel.org \
--cc=richard@nod.at \
--cc=simona@ffwll.ch \
--cc=tglx@linutronix.de \
--cc=tzimmermann@suse.de \
--cc=vigneshr@ti.com \
--cc=visitorckw@gmail.com \
--cc=x86@kernel.org \
--cc=yury.norov@gmail.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®