From: Konrad Dybcio <konrad.dybcio@somainline.org>
To: Vincent Guittot <vincent.guittot@linaro.org>,
lkp@intel.com, sudeep.holla@arm.com, rafael@kernel.org,
mingo@redhat.com, peterz@infradead.org, lukasz.luba@arm.com,
gregkh@linuxfoundation.org, linux-kernel@vger.kernel.org,
qyousef@layalina.io
Subject: Re: [PATCH] arch/topology: Fix variable naming
Date: Tue, 30 Apr 2024 14:19:02 +0200 [thread overview]
Message-ID: <19ccb549-5113-4a58-ac08-4e2e6fea3e20@somainline.org> (raw)
In-Reply-To: <20240425073709.379016-1-vincent.guittot@linaro.org>
On 25.04.2024 9:37 AM, Vincent Guittot wrote:
> Using hw_pressure for local variable is confusing in regard to the
> per_cpu hw_pressure variable. Rename it to avoid confusion.
To avoid confusing the compiler :P
>
> Reported-by: kernel test robot <lkp@intel.com>
> Closes: https://lore.kernel.org/oe-kbuild-all/202404250740.VhQQoD7N-lkp@intel.com/
> Signed-off-by: Vincent Guittot <vincent.guittot@linaro.org>
> ---
Fixes: d4dbc991714e ("sched/cpufreq: Rename arch_update_thermal_pressure() => arch_update_hw_pressure()")
Tested-by: Konrad Dybcio <konrad.dybcio@linaro.org> # QC SM8550 QRD
Reviewed-by: Konrad Dybcio <konrad.dybcio@linaro.org>
Konrad
next prev parent reply other threads:[~2024-04-30 12:19 UTC|newest]
Thread overview: 5+ messages / expand[flat|nested] mbox.gz Atom feed top
2024-04-25 7:37 Vincent Guittot
2024-04-25 8:11 ` Lukasz Luba
2024-04-25 8:46 ` Sudeep Holla
2024-04-30 12:19 ` Konrad Dybcio [this message]
2024-05-15 8:27 ` [tip: sched/urgent] arch/topology: Fix variable naming to avoid shadowing tip-bot2 for Vincent Guittot
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=19ccb549-5113-4a58-ac08-4e2e6fea3e20@somainline.org \
--to=konrad.dybcio@somainline.org \
--cc=gregkh@linuxfoundation.org \
--cc=linux-kernel@vger.kernel.org \
--cc=lkp@intel.com \
--cc=lukasz.luba@arm.com \
--cc=mingo@redhat.com \
--cc=peterz@infradead.org \
--cc=qyousef@layalina.io \
--cc=rafael@kernel.org \
--cc=sudeep.holla@arm.com \
--cc=vincent.guittot@linaro.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®