From: Andrzej Hajda <andrzej.hajda@intel.com>
To: Andi Shyti <andi.shyti@linux.intel.com>
Cc: Chris Wilson <chris.p.wilson@intel.com>,
netdev@vger.kernel.org, intel-gfx@lists.freedesktop.org,
linux-kernel@vger.kernel.org,
Chris Wilson <chris@chris-wilson.co.uk>,
Eric Dumazet <edumazet@google.com>,
dri-devel@lists.freedesktop.org, Daniel Vetter <daniel@ffwll.ch>,
Rodrigo Vivi <rodrigo.vivi@intel.com>,
Jakub Kicinski <kuba@kernel.org>,
David Airlie <airlied@gmail.com>,
Dmitry Vyukov <dvyukov@google.com>
Subject: Re: [Intel-gfx] [PATCH v4 01/10] lib/ref_tracker: add unlocked leak print helper
Date: Mon, 20 Mar 2023 16:30:36 +0100 [thread overview]
Message-ID: <1b9729c0-8831-87bd-8cc2-2cc23e929351@intel.com> (raw)
In-Reply-To: <ZBeT5cWWqY4hkqu6@ashyti-mobl2.lan>
On 19.03.2023 23:59, Andi Shyti wrote:
> Hi Andrzej,
>
> [...]
>
>> diff --git a/lib/ref_tracker.c b/lib/ref_tracker.c
>> index dc7b14aa3431e2..5e9f90bbf771b0 100644
>> --- a/lib/ref_tracker.c
>> +++ b/lib/ref_tracker.c
>> @@ -14,6 +14,38 @@ struct ref_tracker {
>> depot_stack_handle_t free_stack_handle;
>> };
>>
>> +void __ref_tracker_dir_print(struct ref_tracker_dir *dir,
>> + unsigned int display_limit)
>
> can we call this ref_tracker_dir_print_locked() instead of using
> the '__'?
>
OK, 'locked' convention looks better.
Regards
Andrzej
>> +{
>> + struct ref_tracker *tracker;
>> + unsigned int i = 0;
>> +
>> + lockdep_assert_held(&dir->lock);
>> +
>> + list_for_each_entry(tracker, &dir->list, head) {
>> + if (i < display_limit) {
>> + pr_err("leaked reference.\n");
>> + if (tracker->alloc_stack_handle)
>> + stack_depot_print(tracker->alloc_stack_handle);
>> + i++;
>> + } else {
>> + break;
>> + }
>> + }
>> +}
>> +EXPORT_SYMBOL(__ref_tracker_dir_print);
>> +
>> +void ref_tracker_dir_print(struct ref_tracker_dir *dir,
>> + unsigned int display_limit)
>> +{
>> + unsigned long flags;
>> +
>> + spin_lock_irqsave(&dir->lock, flags);
>> + __ref_tracker_dir_print(dir, display_limit);
>> + spin_unlock_irqrestore(&dir->lock, flags);
>> +}
>> +EXPORT_SYMBOL(ref_tracker_dir_print);
>> +
>> void ref_tracker_dir_exit(struct ref_tracker_dir *dir)
>> {
>> struct ref_tracker *tracker, *n;
>> @@ -27,13 +59,13 @@ void ref_tracker_dir_exit(struct ref_tracker_dir *dir)
>> kfree(tracker);
>> dir->quarantine_avail++;
>> }
>> - list_for_each_entry_safe(tracker, n, &dir->list, head) {
>> - pr_err("leaked reference.\n");
>> - if (tracker->alloc_stack_handle)
>> - stack_depot_print(tracker->alloc_stack_handle);
>> + if (!list_empty(&dir->list)) {
>> + __ref_tracker_dir_print(dir, 16);
>> leak = true;
>> - list_del(&tracker->head);
>> - kfree(tracker);
>> + list_for_each_entry_safe(tracker, n, &dir->list, head) {
>> + list_del(&tracker->head);
>> + kfree(tracker);
>> + }
>
> Just thinking whether this should go on a different patch, but I
> don't have a strong opinion.
>
> Looks good!
>
> Andi
next prev parent reply other threads:[~2023-03-20 15:42 UTC|newest]
Thread overview: 22+ messages / expand[flat|nested] mbox.gz Atom feed top
2023-03-06 16:31 [PATCH v4 00/10] drm/i915: use ref_tracker library for tracking wakerefs Andrzej Hajda
2023-03-06 16:31 ` [PATCH v4 01/10] lib/ref_tracker: add unlocked leak print helper Andrzej Hajda
2023-03-19 22:59 ` [Intel-gfx] " Andi Shyti
2023-03-20 15:30 ` Andrzej Hajda [this message]
2023-03-06 16:31 ` [PATCH v4 02/10] lib/ref_tracker: __ref_tracker_dir_print improve printing Andrzej Hajda
2023-03-19 23:11 ` [Intel-gfx] " Andi Shyti
2023-03-20 15:39 ` Andrzej Hajda
2023-03-06 16:31 ` [PATCH v4 03/10] lib/ref_tracker: add printing to memory buffer Andrzej Hajda
2023-03-19 23:18 ` [Intel-gfx] " Andi Shyti
2023-03-20 18:24 ` Andrzej Hajda
2023-03-06 16:32 ` [PATCH v4 04/10] lib/ref_tracker: remove warnings in case of allocation failure Andrzej Hajda
2023-03-19 23:19 ` [Intel-gfx] " Andi Shyti
2023-03-06 16:32 ` [PATCH v4 05/10] drm/i915: Separate wakeref tracking types from rpm Andrzej Hajda
2023-03-06 16:32 ` [PATCH v4 06/10] drm/i915: Separate wakeref tracking Andrzej Hajda
2023-03-19 23:57 ` [Intel-gfx] " Andi Shyti
2023-03-20 18:39 ` Andrzej Hajda
2023-03-06 16:32 ` [PATCH v4 07/10] drm/i915: Track leaked gt->wakerefs Andrzej Hajda
2023-03-06 16:32 ` [PATCH v4 08/10] drm/i915: Correct type of wakeref variable Andrzej Hajda
2023-03-19 23:58 ` [Intel-gfx] " Andi Shyti
2023-03-06 16:32 ` [PATCH v4 09/10] drm/i915: replace Intel internal tracker with kernel core ref_tracker Andrzej Hajda
2023-03-06 16:32 ` [PATCH v4 10/10] drm/i915/gt: Hold a wakeref for the active VM Andrzej Hajda
2023-03-17 11:58 ` [Intel-gfx] [PATCH v4 00/10] drm/i915: use ref_tracker library for tracking wakerefs Andrzej Hajda
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1b9729c0-8831-87bd-8cc2-2cc23e929351@intel.com \
--to=andrzej.hajda@intel.com \
--cc=airlied@gmail.com \
--cc=andi.shyti@linux.intel.com \
--cc=chris.p.wilson@intel.com \
--cc=chris@chris-wilson.co.uk \
--cc=daniel@ffwll.ch \
--cc=dri-devel@lists.freedesktop.org \
--cc=dvyukov@google.com \
--cc=edumazet@google.com \
--cc=intel-gfx@lists.freedesktop.org \
--cc=kuba@kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=netdev@vger.kernel.org \
--cc=rodrigo.vivi@intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®