From: Joe Perches <joe@perches.com>
To: Janani Sankara Babu <jananis37@gmail.com>, gregkh@linuxfoundation.org
Cc: johannes.berg@intel.com, davem@davemloft.net,
keescook@chromium.org, Rene.Hickersberger@gmx.at,
devel@driverdev.osuosl.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH] Staging:rtl8192e Replace function names by using __func__
Date: Thu, 07 Jun 2018 11:36:59 -0700 [thread overview]
Message-ID: <1bcb1e168f863ed5946327b54ceb64f6694c6b86.camel@perches.com> (raw)
In-Reply-To: <1528428555-7884-1-git-send-email-jananis37@gmail.com>
On Thu, 2018-06-07 at 23:29 -0400, Janani Sankara Babu wrote:
> This patch is created to solve the warning shown by checkpatch script
> Prefer using '"%s...", __func__' to using ', this function's name,
> in a string
[]
> diff --git a/drivers/staging/rtl8192e/rtl819x_BAProc.c b/drivers/staging/rtl8192e/rtl819x_BAProc.c
[]
> @@ -127,7 +127,7 @@ static struct sk_buff *rtllib_ADDBA(struct rtllib_device *ieee, u8 *Dst,
> }
>
> #ifdef VERBOSE_DEBUG
> - print_hex_dump_bytes("rtllib_ADDBA(): ", DUMP_PREFIX_NONE, skb->data,
> + print_hex_dump_bytes("%s(): ", __func__, DUMP_PREFIX_NONE, skb->data,
> skb->len);
You didn't compile this with VERBOSE_DEBUG enabled.
You are adding arguments to a function that takes
a fixed number of arguments.
checkpatch is mindless.
Please don't mindlessly do what it says, just try
to improve the code readability where it's unclear
and especially try to find and fix logic defects.
prev parent reply other threads:[~2018-06-07 18:37 UTC|newest]
Thread overview: 2+ messages / expand[flat|nested] mbox.gz Atom feed top
2018-06-08 3:29 Janani Sankara Babu
2018-06-07 18:36 ` Joe Perches [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1bcb1e168f863ed5946327b54ceb64f6694c6b86.camel@perches.com \
--to=joe@perches.com \
--cc=Rene.Hickersberger@gmx.at \
--cc=davem@davemloft.net \
--cc=devel@driverdev.osuosl.org \
--cc=gregkh@linuxfoundation.org \
--cc=jananis37@gmail.com \
--cc=johannes.berg@intel.com \
--cc=keescook@chromium.org \
--cc=linux-kernel@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®