From: "Ilpo Järvinen" <ilpo.jarvinen@linux.intel.com>
To: Tero Kristo <tero.kristo@linux.intel.com>
Cc: Hans de Goede <hdegoede@redhat.com>,
srinivas.pandruvada@linux.intel.com,
LKML <linux-kernel@vger.kernel.org>,
platform-driver-x86@vger.kernel.org
Subject: Re: [PATCH 0/7] platform/x86/inte-uncore-freq: Cleanups
Date: Tue, 18 Jun 2024 13:00:26 +0300 (EEST) [thread overview]
Message-ID: <1c180de1-0cad-82c4-b7e9-d951331725d6@linux.intel.com> (raw)
In-Reply-To: <20240617060708.892981-1-tero.kristo@linux.intel.com>
On Mon, 17 Jun 2024, Tero Kristo wrote:
> Hi,
>
> This series introduces some cleanups for the code and driver level APIs.
> The purpose is to improve the maintainability of the code and make it
> easier to add new features in future.
>
> No functional changes expected from any of the patches in this series.
Nice cleanups, thank you.
I've applied these into review-ilpo branch with the following
modifications:
- I fixed my name on Reviewed-by line. Please don't corrupt my name if
handwriting a tag instead of copying it. While I don't care that much
if my name is not always written 100% correctly, an incorrect rev-by
line causes my tools to add the correct form one so the rev-by line
gets duplicated (luckily I was paying attention to the non-critical
part of the output of my tool this time around so I caught it).
- I renamed _min, _max, and _value variables to min, max, and v,
respectively, because the reason for using underscores got removed by
the change.
--
i.
prev parent reply other threads:[~2024-06-18 10:00 UTC|newest]
Thread overview: 10+ messages / expand[flat|nested] mbox.gz Atom feed top
2024-06-17 6:04 Tero Kristo
2024-06-17 6:04 ` [PATCH 1/7] platform/x86/intel-uncore-freq: Re-arrange bit masks Tero Kristo
2024-06-17 6:04 ` [PATCH 2/7] platform/x86/intel-uncore-freq: Get rid of magic values Tero Kristo
2024-06-17 6:04 ` [PATCH 3/7] platform/x86/intel-uncore-freq: Get rid of magic min_max argument Tero Kristo
2024-06-17 6:04 ` [PATCH 4/7] platform/x86/intel-uncore-freq: Use uncore_index with read_control_freq Tero Kristo
2024-06-17 6:04 ` [PATCH 5/7] platform/x86/intel-uncore-freq: Get rid of uncore_read_freq driver API Tero Kristo
2024-06-17 6:04 ` [PATCH 6/7] platform/x86/intel-uncore-freq: Rename the sysfs helper macro names Tero Kristo
2024-06-17 6:04 ` [PATCH 7/7] platform/x86/intel-uncore-freq: Use generic helpers for current frequency Tero Kristo
2024-06-17 9:06 ` [PATCH 0/7] platform/x86/inte-uncore-freq: Cleanups srinivas pandruvada
2024-06-18 10:00 ` Ilpo Järvinen [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1c180de1-0cad-82c4-b7e9-d951331725d6@linux.intel.com \
--to=ilpo.jarvinen@linux.intel.com \
--cc=hdegoede@redhat.com \
--cc=linux-kernel@vger.kernel.org \
--cc=platform-driver-x86@vger.kernel.org \
--cc=srinivas.pandruvada@linux.intel.com \
--cc=tero.kristo@linux.intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®