From: Bart Van Assche <bvanassche@acm.org>
To: Bean Huo <huobean@gmail.com>,
alim.akhtar@samsung.com, avri.altman@wdc.com,
asutoshd@codeaurora.org, jejb@linux.ibm.com,
martin.petersen@oracle.com, stanley.chu@mediatek.com,
beanhuo@micron.com, tomas.winkler@intel.com, cang@codeaurora.org
Cc: linux-scsi@vger.kernel.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH v1 2/3] scsi: ufs: Let command trace only for the cmd != null case
Date: Sun, 23 May 2021 18:32:08 -0700 [thread overview]
Message-ID: <1d06cc01-a642-e8e0-a251-1b392e4935c7@acm.org> (raw)
In-Reply-To: <20210523211409.210304-3-huobean@gmail.com>
On 5/23/21 2:14 PM, Bean Huo wrote:
> + opcode = cmd->cmnd[0];
> + if ((opcode == READ_10) || (opcode == WRITE_10)) {
> + /*
> + * Currently we only fully trace read(10) and write(10)
> + * commands
> + */
> + if (cmd->request && cmd->request->bio)
> + lba = cmd->request->bio->bi_iter.bi_sector;
Why does the lba assignment occur inside the if-statement for the
READ_10 and WRITE_10 cases? Has it been considered to move that
assignment before this if-statement?
Does 'lba' represent an offset in units of 512 bytes (sector_t) or an
LBA (logical block address)? In the former case, please rename the
variable 'lba' into 'sector' or 'start_sector'. In the latter case,
please use sectors_to_logical().
Why are READ_16 and WRITE_16 ignored?
Please remove the 'if (cmd->request)' checks since these are not necessary.
> + } else if (opcode == UNMAP) {
> + if (cmd->request) {
> + lba = scsi_get_lba(cmd);
> + transfer_len = blk_rq_bytes(cmd->request);
> }
> }
The name of the variable 'transfer_len' is wrong since blk_rq_bytes()
returns the number of bytes affected on the storage medium instead of
the number of bytes transferred from the host to the storage controller.
> /**
> - * Describes the ufs rpmb wlun.
> - * Used only to send uac.
> + * Describes the ufs rpmb wlun. Used only to send uac.
> */
Is this change related to the rest of this patch?
Thanks,
Bart.
next prev parent reply other threads:[~2021-05-24 1:32 UTC|newest]
Thread overview: 12+ messages / expand[flat|nested] mbox.gz Atom feed top
2021-05-23 21:14 [PATCH v1 0/3] Three minor changes for UFS Bean Huo
2021-05-23 21:14 ` [PATCH v1 1/3] scsi: ufs: Let UPIU completion trace print RSP UPIU Bean Huo
2021-05-24 1:24 ` Bart Van Assche
2021-05-25 19:28 ` Bean Huo
2021-05-25 20:15 ` Bart Van Assche
2021-05-23 21:14 ` [PATCH v1 2/3] scsi: ufs: Let command trace only for the cmd != null case Bean Huo
2021-05-24 1:32 ` Bart Van Assche [this message]
2021-05-24 6:50 ` Avri Altman
2021-05-25 20:02 ` Bean Huo
2021-05-23 21:14 ` [PATCH v1 3/3] scsi: ufs: Use UPIU query trace in devman_upiu_cmd Bean Huo
2021-05-24 1:32 ` Bart Van Assche
2021-05-25 20:04 ` Bean Huo
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1d06cc01-a642-e8e0-a251-1b392e4935c7@acm.org \
--to=bvanassche@acm.org \
--cc=alim.akhtar@samsung.com \
--cc=asutoshd@codeaurora.org \
--cc=avri.altman@wdc.com \
--cc=beanhuo@micron.com \
--cc=cang@codeaurora.org \
--cc=huobean@gmail.com \
--cc=jejb@linux.ibm.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-scsi@vger.kernel.org \
--cc=martin.petersen@oracle.com \
--cc=stanley.chu@mediatek.com \
--cc=tomas.winkler@intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®