From: "Arınç ÜNAL" <arinc.unal@arinc9.com>
To: Colin Foster <colin.foster@in-advantage.com>,
linux-renesas-soc@vger.kernel.org,
linux-mediatek@lists.infradead.org,
linux-arm-kernel@lists.infradead.org,
linux-kernel@vger.kernel.org, devicetree@vger.kernel.org,
netdev@vger.kernel.org
Cc: "John Crispin" <john@phrozen.org>,
"Alexandre Belloni" <alexandre.belloni@bootlin.com>,
"Claudiu Manoil" <claudiu.manoil@nxp.com>,
"Marek Vasut" <marex@denx.de>,
"Sean Wang" <sean.wang@mediatek.com>,
"DENG Qingfang" <dqfext@gmail.com>,
"Landen Chao" <Landen.Chao@mediatek.com>,
"Vivien Didelot" <vivien.didelot@gmail.com>,
"Clément Léger" <clement.leger@bootlin.com>,
"Alvin Šipraga" <alsi@bang-olufsen.dk>,
"Linus Walleij" <linus.walleij@linaro.org>,
UNGLinuxDriver@microchip.com,
"Woojung Huh" <woojung.huh@microchip.com>,
"Matthias Brugger" <matthias.bgg@gmail.com>,
"Kurt Kanzenbach" <kurt@linutronix.de>,
"Krzysztof Kozlowski" <krzysztof.kozlowski+dt@linaro.org>,
"Rob Herring" <robh+dt@kernel.org>,
"Paolo Abeni" <pabeni@redhat.com>,
"Jakub Kicinski" <kuba@kernel.org>,
"Eric Dumazet" <edumazet@google.com>,
"David S. Miller" <davem@davemloft.net>,
"Vladimir Oltean" <olteanv@gmail.com>,
"Florian Fainelli" <f.fainelli@gmail.com>,
"Andrew Lunn" <andrew@lunn.ch>,
"George McCollister" <george.mccollister@gmail.com>,
"Rob Herring" <robh@kernel.org>
Subject: Re: [PATCH v5 net-next 04/10] dt-bindings: net: dsa: utilize base definitions for standard dsa switches
Date: Sat, 10 Dec 2022 19:24:42 +0300 [thread overview]
Message-ID: <1df417b5-a924-33d4-a302-eb526f7124b4@arinc9.com> (raw)
In-Reply-To: <20221210033033.662553-5-colin.foster@in-advantage.com>
On 10.12.2022 06:30, Colin Foster wrote:
> DSA switches can fall into one of two categories: switches where all ports
> follow standard '(ethernet-)?port' properties, and switches that have
> additional properties for the ports.
>
> The scenario where DSA ports are all standardized can be handled by
> switches with a reference to the new 'dsa.yaml#/$defs/ethernet-ports'.
>
> The scenario where DSA ports require additional properties can reference
> '$dsa.yaml#' directly. This will allow switches to reference these standard
> definitions of the DSA switch, but add additional properties under the port
> nodes.
>
> Suggested-by: Rob Herring <robh@kernel.org>
> Signed-off-by: Colin Foster <colin.foster@in-advantage.com>
> Reviewed-by: Linus Walleij <linus.walleij@linaro.org>
> Reviewed-by: Florian Fainelli <f.fainelli@gmail.com>
> Reviewed-by: Rob Herring <robh@kernel.org>
> Acked-by: Alvin Šipraga <alsi@bang-olufsen.dk> # realtek
> Acked-by: Arınç ÜNAL <arinc.unal@arinc9.com>
> ---
>
> v4 -> v5
> * Add Rob Reviewed, Arınç Acked
> * Defer the removal of "^(ethernet-)?switch(@.*)?$" in dsa.yaml until a
> later patch
> * Undo the move of ethernet switch ports description in mediatek,mt7530.yaml
> * Fix typos in commit message
>
> v3 -> v4
> * Rename "$defs/base" to "$defs/ethernet-ports" to avoid implication of a
> "base class" and fix commit message accordingly
> * Add the following to the common etherent-ports node:
> "additionalProperties: false"
> "#address-cells" property
> "#size-cells" property
> * Fix "etherenet-ports@[0-9]+" to correctly be "ethernet-port@[0-9]+"
> * Remove unnecessary newline
> * Apply changes to mediatek,mt7530.yaml that were previously in a separate patch
> * Add Reviewed and Acked tags
>
> v3
> * New patch
>
> ---
> .../bindings/net/dsa/arrow,xrs700x.yaml | 2 +-
> .../devicetree/bindings/net/dsa/brcm,b53.yaml | 2 +-
> .../devicetree/bindings/net/dsa/dsa.yaml | 22 +++++++++++++++++++
> .../net/dsa/hirschmann,hellcreek.yaml | 2 +-
> .../bindings/net/dsa/mediatek,mt7530.yaml | 5 +----
> .../bindings/net/dsa/microchip,ksz.yaml | 2 +-
> .../bindings/net/dsa/microchip,lan937x.yaml | 2 +-
> .../bindings/net/dsa/mscc,ocelot.yaml | 2 +-
> .../bindings/net/dsa/nxp,sja1105.yaml | 2 +-
> .../devicetree/bindings/net/dsa/realtek.yaml | 2 +-
> .../bindings/net/dsa/renesas,rzn1-a5psw.yaml | 2 +-
> 11 files changed, 32 insertions(+), 13 deletions(-)
>
> diff --git a/Documentation/devicetree/bindings/net/dsa/arrow,xrs700x.yaml b/Documentation/devicetree/bindings/net/dsa/arrow,xrs700x.yaml
> index 259a0c6547f3..5888e3a0169a 100644
> --- a/Documentation/devicetree/bindings/net/dsa/arrow,xrs700x.yaml
> +++ b/Documentation/devicetree/bindings/net/dsa/arrow,xrs700x.yaml
> @@ -7,7 +7,7 @@ $schema: http://devicetree.org/meta-schemas/core.yaml#
> title: Arrow SpeedChips XRS7000 Series Switch Device Tree Bindings
>
> allOf:
> - - $ref: dsa.yaml#
> + - $ref: dsa.yaml#/$defs/ethernet-ports
>
> maintainers:
> - George McCollister <george.mccollister@gmail.com>
> diff --git a/Documentation/devicetree/bindings/net/dsa/brcm,b53.yaml b/Documentation/devicetree/bindings/net/dsa/brcm,b53.yaml
> index 1219b830b1a4..5bef4128d175 100644
> --- a/Documentation/devicetree/bindings/net/dsa/brcm,b53.yaml
> +++ b/Documentation/devicetree/bindings/net/dsa/brcm,b53.yaml
> @@ -66,7 +66,7 @@ required:
> - reg
>
> allOf:
> - - $ref: dsa.yaml#
> + - $ref: dsa.yaml#/$defs/ethernet-ports
> - if:
> properties:
> compatible:
> diff --git a/Documentation/devicetree/bindings/net/dsa/dsa.yaml b/Documentation/devicetree/bindings/net/dsa/dsa.yaml
> index 5efc0ee8edcb..9375cdcfbf96 100644
> --- a/Documentation/devicetree/bindings/net/dsa/dsa.yaml
> +++ b/Documentation/devicetree/bindings/net/dsa/dsa.yaml
> @@ -58,4 +58,26 @@ oneOf:
>
> additionalProperties: true
>
> +$defs:
> + ethernet-ports:
> + description: A DSA switch without any extra port properties
> + $ref: '#/'
> +
> + patternProperties:
> + "^(ethernet-)?ports$":
> + type: object
> + additionalProperties: false
> +
> + properties:
> + '#address-cells':
> + const: 1
> + '#size-cells':
> + const: 0
> +
> + patternProperties:
> + "^(ethernet-)?port@[0-9]+$":
> + description: Ethernet switch ports
> + $ref: dsa-port.yaml#
> + unevaluatedProperties: false
I've got moderate experience in json-schema but shouldn't you put 'type:
object' here like you did for "^(ethernet-)?ports$"?
> +
> ...
> diff --git a/Documentation/devicetree/bindings/net/dsa/hirschmann,hellcreek.yaml b/Documentation/devicetree/bindings/net/dsa/hirschmann,hellcreek.yaml
> index 73b774eadd0b..748ef9983ce2 100644
> --- a/Documentation/devicetree/bindings/net/dsa/hirschmann,hellcreek.yaml
> +++ b/Documentation/devicetree/bindings/net/dsa/hirschmann,hellcreek.yaml
> @@ -7,7 +7,7 @@ $schema: http://devicetree.org/meta-schemas/core.yaml#
> title: Hirschmann Hellcreek TSN Switch Device Tree Bindings
>
> allOf:
> - - $ref: dsa.yaml#
> + - $ref: dsa.yaml#/$defs/ethernet-ports
>
> maintainers:
> - Andrew Lunn <andrew@lunn.ch>
> diff --git a/Documentation/devicetree/bindings/net/dsa/mediatek,mt7530.yaml b/Documentation/devicetree/bindings/net/dsa/mediatek,mt7530.yaml
> index f2e9ff3f580b..20312f5d1944 100644
> --- a/Documentation/devicetree/bindings/net/dsa/mediatek,mt7530.yaml
> +++ b/Documentation/devicetree/bindings/net/dsa/mediatek,mt7530.yaml
> @@ -157,9 +157,6 @@ patternProperties:
> patternProperties:
> "^(ethernet-)?port@[0-9]+$":
> type: object
This line was being removed on the previous version. Must be related to
above.
> - description: Ethernet switch ports
> -
> - unevaluatedProperties: false
>
> properties:
> reg:
Arınç
next prev parent reply other threads:[~2022-12-10 16:26 UTC|newest]
Thread overview: 33+ messages / expand[flat|nested] mbox.gz Atom feed top
2022-12-10 3:30 [PATCH v5 net-next 00/10] dt-binding preparation for ocelot switches Colin Foster
2022-12-10 3:30 ` [PATCH v5 net-next 01/10] dt-bindings: dsa: sync with maintainers Colin Foster
2022-12-10 10:18 ` Kurt Kanzenbach
2022-12-11 22:58 ` Vladimir Oltean
2022-12-12 7:51 ` Kurt Kanzenbach
2022-12-12 10:55 ` Vladimir Oltean
2022-12-12 17:13 ` Rob Herring
2022-12-10 3:30 ` [PATCH v5 net-next 02/10] dt-bindings: net: dsa: sf2: fix brcm,use-bcm-hdr documentation Colin Foster
2022-12-12 18:46 ` Vladimir Oltean
2022-12-10 3:30 ` [PATCH v5 net-next 03/10] dt-bindings: net: dsa: qca8k: remove address-cells and size-cells from switch node Colin Foster
2022-12-12 18:46 ` Vladimir Oltean
2022-12-10 3:30 ` [PATCH v5 net-next 04/10] dt-bindings: net: dsa: utilize base definitions for standard dsa switches Colin Foster
2022-12-10 16:24 ` Arınç ÜNAL [this message]
2022-12-10 18:02 ` Colin Foster
2022-12-12 9:28 ` Arınç ÜNAL
2022-12-12 16:51 ` Rob Herring
2022-12-12 18:55 ` Colin Foster
2022-12-22 20:08 ` Colin Foster
2022-12-23 1:55 ` Jakub Kicinski
2022-12-12 18:48 ` Vladimir Oltean
2022-12-10 3:30 ` [PATCH v5 net-next 05/10] dt-bindings: net: dsa: allow additional ethernet-port properties Colin Foster
2022-12-12 18:51 ` Vladimir Oltean
2022-12-10 3:30 ` [PATCH v5 net-next 06/10] dt-bindings: net: dsa: qca8k: utilize shared dsa.yaml Colin Foster
2022-12-12 18:52 ` Vladimir Oltean
2022-12-10 3:30 ` [PATCH v5 net-next 07/10] dt-bindings: net: dsa: mediatek,mt7530: remove unnecessary dsa-port reference Colin Foster
2022-12-12 18:53 ` Vladimir Oltean
2022-12-10 3:30 ` [PATCH v5 net-next 08/10] dt-bindings: net: add generic ethernet-switch Colin Foster
2022-12-12 18:54 ` Vladimir Oltean
2022-12-10 3:30 ` [PATCH v5 net-next 09/10] dt-bindings: net: add generic ethernet-switch-port binding Colin Foster
2022-12-10 3:30 ` [PATCH v5 net-next 10/10] dt-bindings: net: mscc,vsc7514-switch: utilize generic ethernet-switch.yaml Colin Foster
2022-12-12 18:29 ` [PATCH v5 net-next 00/10] dt-binding preparation for ocelot switches Jakub Kicinski
2022-12-12 19:03 ` Colin Foster
2022-12-13 3:34 ` Jakub Kicinski
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1df417b5-a924-33d4-a302-eb526f7124b4@arinc9.com \
--to=arinc.unal@arinc9.com \
--cc=Landen.Chao@mediatek.com \
--cc=UNGLinuxDriver@microchip.com \
--cc=alexandre.belloni@bootlin.com \
--cc=alsi@bang-olufsen.dk \
--cc=andrew@lunn.ch \
--cc=claudiu.manoil@nxp.com \
--cc=clement.leger@bootlin.com \
--cc=colin.foster@in-advantage.com \
--cc=davem@davemloft.net \
--cc=devicetree@vger.kernel.org \
--cc=dqfext@gmail.com \
--cc=edumazet@google.com \
--cc=f.fainelli@gmail.com \
--cc=george.mccollister@gmail.com \
--cc=john@phrozen.org \
--cc=krzysztof.kozlowski+dt@linaro.org \
--cc=kuba@kernel.org \
--cc=kurt@linutronix.de \
--cc=linus.walleij@linaro.org \
--cc=linux-arm-kernel@lists.infradead.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-mediatek@lists.infradead.org \
--cc=linux-renesas-soc@vger.kernel.org \
--cc=marex@denx.de \
--cc=matthias.bgg@gmail.com \
--cc=netdev@vger.kernel.org \
--cc=olteanv@gmail.com \
--cc=pabeni@redhat.com \
--cc=robh+dt@kernel.org \
--cc=robh@kernel.org \
--cc=sean.wang@mediatek.com \
--cc=vivien.didelot@gmail.com \
--cc=woojung.huh@microchip.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®