From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: X-Spam-Checker-Version: SpamAssassin 3.4.0 (2014-02-07) on aws-us-west-2-korg-lkml-1.web.codeaurora.org X-Spam-Level: X-Spam-Status: No, score=-3.8 required=3.0 tests=BAYES_00, HEADER_FROM_DIFFERENT_DOMAINS,MAILING_LIST_MULTI,SPF_HELO_NONE,SPF_PASS autolearn=no autolearn_force=no version=3.4.0 Received: from mail.kernel.org (mail.kernel.org [198.145.29.99]) by smtp.lore.kernel.org (Postfix) with ESMTP id EB753C83019 for ; Sat, 28 Nov 2020 22:15:26 +0000 (UTC) Received: from vger.kernel.org (vger.kernel.org [23.128.96.18]) by mail.kernel.org (Postfix) with ESMTP id C618A221FD for ; Sat, 28 Nov 2020 22:15:26 +0000 (UTC) Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1730833AbgK1Vtx (ORCPT ); Sat, 28 Nov 2020 16:49:53 -0500 Received: from smtprelay0083.hostedemail.com ([216.40.44.83]:51332 "EHLO smtprelay.hostedemail.com" rhost-flags-OK-OK-OK-FAIL) by vger.kernel.org with ESMTP id S1733277AbgK1SBf (ORCPT ); Sat, 28 Nov 2020 13:01:35 -0500 Received: from smtprelay.hostedemail.com (10.5.19.251.rfc1918.com [10.5.19.251]) by smtpgrave06.hostedemail.com (Postfix) with ESMTP id 10E81800CE04 for ; Sat, 28 Nov 2020 16:44:35 +0000 (UTC) Received: from filter.hostedemail.com (clb03-v110.bra.tucows.net [216.40.38.60]) by smtprelay04.hostedemail.com (Postfix) with ESMTP id 42A46180A7FDA; Sat, 28 Nov 2020 16:44:34 +0000 (UTC) X-Session-Marker: 6A6F6540706572636865732E636F6D X-HE-Tag: spot52_1600c7927392 X-Filterd-Recvd-Size: 2452 Received: from XPS-9350.home (unknown [47.151.128.180]) (Authenticated sender: joe@perches.com) by omf18.hostedemail.com (Postfix) with ESMTPA; Sat, 28 Nov 2020 16:44:33 +0000 (UTC) Message-ID: <1e0ffe90dc73d45e3e2c3bdd8686aa8e9afa8b23.camel@perches.com> Subject: Re: [PATCH] MAINTAINERS add D: tag for subsystem commit prefix From: Joe Perches To: Tom Rix , apw@canonical.com, nickhu@andestech.com, green.hu@gmail.com, deanbo422@gmail.com Cc: linux-kernel@vger.kernel.org Date: Sat, 28 Nov 2020 08:44:31 -0800 In-Reply-To: <8a48dbc8-59cc-5fff-e9ea-e68ffb9e698a@redhat.com> References: <20201127214316.3045640-1-trix@redhat.com> <6e9917257cfd6774066446014051d39b784ba497.camel@perches.com> <8a48dbc8-59cc-5fff-e9ea-e68ffb9e698a@redhat.com> Content-Type: text/plain; charset="ISO-8859-1" User-Agent: Evolution 3.38.1-1 MIME-Version: 1.0 Content-Transfer-Encoding: 7bit Precedence: bulk List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Sat, 2020-11-28 at 08:30 -0800, Tom Rix wrote: > On 11/28/20 8:00 AM, Joe Perches wrote: > > On Sat, 2020-11-28 at 07:36 -0800, Tom Rix wrote: > > > On 11/27/20 2:10 PM, Joe Perches wrote: > > [] > > > > I think an exception mechanism would be better than a specific > > > > mechanism added to various entries. > > > Can you give an example of what you mean ? > > Inherit the parent prefix then add the basename(dirname) as a default. > > > > For instance, changes to any subsystem of drivers/staging starts as > > "staging: " and with "$basename(path): " appended. > > Ah, this is quite a bit different. > > As far as I can tell there is no default. The idea is to avoid adding a D: entry to each subsystem section. > MAINTAINERS would only have the exceptions, obviously needing drivers/foo to be 'foo:' > > Without the full prefix, the user would be need to use get_maintainer.pl to figure it out. True. Or some other script. > Are the ""'s in the D value necessary ? Maybe not. I did that for clarity with the space after colon. My recollection is some systems used "[subsystem]" separators and other use / without space and not colons, but I'm for whatever approriate changes that support standarization I think most developer/maintainers don't care one way or another about patch commit prefixes, but those that do care seem to care a lot.