From: Shuah Khan <skhan@linuxfoundation.org>
To: Brendan Higgins <brendanhiggins@google.com>,
shuah@kernel.org, davidgow@google.com, dlatypov@google.com,
martin.fernandez@eclypsium.com, daniel.gutson@eclypsium.com
Cc: linux-kselftest@vger.kernel.org, kunit-dev@googlegroups.com,
linux-kernel@vger.kernel.org, keescook@chromium.org,
jk@codeconstruct.com.au, Shuah Khan <skhan@linuxfoundation.org>
Subject: Re: [PATCH v1] kunit: add support for kunit_suites that reference init code
Date: Mon, 4 Apr 2022 16:37:15 -0600 [thread overview]
Message-ID: <1e1472e8-1813-3903-f934-cb0ae7f09864@linuxfoundation.org> (raw)
In-Reply-To: <20220311072859.2174624-1-brendanhiggins@google.com>
Hi Brendan,
On 3/11/22 12:28 AM, Brendan Higgins wrote:
> Add support for a new kind of kunit_suite registration macro called
> kunit_test_init_suite(); this new registration macro allows the
> registration of kunit_suites that reference functions marked __init and
> data marked __initdata.
>
> Signed-off-by: Brendan Higgins <brendanhiggins@google.com>
> Tested-by: Martin Fernandez <martin.fernandez@eclypsium.com>
> Reviewed-by: Kees Cook <keescook@chromium.org>
> Reviewed-by: David Gow <davidgow@google.com>
> ---
>
I almost applied it ...
> This is a follow-up to the RFC here[1].
>
> This patch is in response to a KUnit user issue[2] in which the user was
> attempting to test some init functions; although this is a functional
> solution as long as KUnit tests only run during the init phase, we will
> need to do more work if we ever allow tests to run after the init phase
> is over; it is for this reason that this patch adds a new registration
> macro rather than simply modifying the existing macros.
>
> Changes since last version:
> - I added more to the kunit_test_init_suites() kernel-doc comment
> detailing "how" the modpost warnings are suppressed in addition to
> the existing information regarding "why" it is OK for the modpost
> warnings to be suppressed.
>
> [1] https://lore.kernel.org/linux-kselftest/20220310210210.2124637-1-brendanhiggins@google.com/
> [2] https://groups.google.com/g/kunit-dev/c/XDjieRHEneg/m/D0rFCwVABgAJ
>
> ---
> include/kunit/test.h | 26 ++++++++++++++++++++++++++
> 1 file changed, 26 insertions(+)
>
> diff --git a/include/kunit/test.h b/include/kunit/test.h
> index b26400731c02..7f303a06bc97 100644
> --- a/include/kunit/test.h
> +++ b/include/kunit/test.h
> @@ -379,6 +379,32 @@ static inline int kunit_run_all_tests(void)
>
> #define kunit_test_suite(suite) kunit_test_suites(&suite)
>
> +/**
> + * kunit_test_init_suites() - used to register one or more &struct kunit_suite
> + * containing init functions or init data.
> + *
> + * @__suites: a statically allocated list of &struct kunit_suite.
> + *
> + * This functions identically as &kunit_test_suites() except that it suppresses
> + * modpost warnings for referencing functions marked __init or data marked
> + * __initdata; this is OK because currently KUnit only runs tests upon boot
> + * during the init phase or upon loading a module during the init phase.
> + *
> + * NOTE TO KUNIT DEVS: If we ever allow KUnit tests to be run after boot, these
> + * tests must be excluded.
> + *
> + * The only thing this macro does that's different from kunit_test_suites is
> + * that it suffixes the array and suite declarations it makes with _probe;
> + * modpost suppresses warnings about referencing init data for symbols named in
> + * this manner.
> + */
> +#define kunit_test_init_suites(__suites...) \
> + __kunit_test_suites(CONCATENATE(__UNIQUE_ID(array), _probe), \
> + CONCATENATE(__UNIQUE_ID(suites), _probe), \
> + ##__suites)
> +
> +#define kunit_test_init_suite(suite) kunit_test_init_suites(&suite)
> +
> #define kunit_suite_for_each_test_case(suite, test_case) \
> for (test_case = suite->test_cases; test_case->run_case; test_case++)
>
>
The naming of the function and macro are rather confusing and can become
error prone. Let's find better naming scheme.
> base-commit: 330f4c53d3c2d8b11d86ec03a964b86dc81452f5
>
thanks,
-- Shuah
next prev parent reply other threads:[~2022-04-04 23:06 UTC|newest]
Thread overview: 6+ messages / expand[flat|nested] mbox.gz Atom feed top
2022-03-11 7:28 Brendan Higgins
2022-04-04 22:37 ` Shuah Khan [this message]
2022-04-04 22:48 ` Brendan Higgins
2022-04-07 21:34 ` Martin Fernandez
2022-04-08 17:34 ` Brendan Higgins
2022-04-08 18:50 ` Shuah Khan
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1e1472e8-1813-3903-f934-cb0ae7f09864@linuxfoundation.org \
--to=skhan@linuxfoundation.org \
--cc=brendanhiggins@google.com \
--cc=daniel.gutson@eclypsium.com \
--cc=davidgow@google.com \
--cc=dlatypov@google.com \
--cc=jk@codeconstruct.com.au \
--cc=keescook@chromium.org \
--cc=kunit-dev@googlegroups.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-kselftest@vger.kernel.org \
--cc=martin.fernandez@eclypsium.com \
--cc=shuah@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®