From: "Huang, Kai" <kai.huang@intel.com>
To: "Hansen, Dave" <dave.hansen@intel.com>,
"seanjc@google.com" <seanjc@google.com>,
"bp@alien8.de" <bp@alien8.de>,
"peterz@infradead.org" <peterz@infradead.org>,
"hpa@zytor.com" <hpa@zytor.com>,
"mingo@redhat.com" <mingo@redhat.com>,
"kirill.shutemov@linux.intel.com"
<kirill.shutemov@linux.intel.com>,
"tglx@linutronix.de" <tglx@linutronix.de>,
"pbonzini@redhat.com" <pbonzini@redhat.com>,
"Williams, Dan J" <dan.j.williams@intel.com>,
"nik.borisov@suse.com" <nik.borisov@suse.com>
Cc: "kvm@vger.kernel.org" <kvm@vger.kernel.org>,
"Hunter, Adrian" <adrian.hunter@intel.com>,
"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>,
"Edgecombe, Rick P" <rick.p.edgecombe@intel.com>,
"x86@kernel.org" <x86@kernel.org>,
"Yamahata, Isaku" <isaku.yamahata@intel.com>
Subject: Re: [PATCH v4 3/8] x86/virt/tdx: Prepare to support reading other global metadata fields
Date: Thu, 26 Sep 2024 12:13:33 +0000 [thread overview]
Message-ID: <1e9270cabe2217e4299ea52adf2a87874459490e.camel@intel.com> (raw)
In-Reply-To: <fce898e6-0296-4c5e-9e6a-6b5e3fc87b95@suse.com>
>
> > +#define build_sysmd_read(_size) \
> > +static int __read_sys_metadata_field##_size(u64 field_id, u##_size *val) \
> > +{ \
> > + u64 tmp; \
> > + int ret; \
> > + \
> > + ret = tdh_sys_rd(field_id, &tmp); \
> > + if (ret) \
> > + return ret; \
> > + \
> > + *val = tmp; \
> > + \
> > + return 0; \
> > }
> >
> > -#define read_sys_metadata_field16(_field_id, _val) \
> > +build_sysmd_read(16)
>
> nit: Generally the unwritten convention for this kind of macro
> definition is to capitalize them and be of the from:
>
> DEFINE_xxxxx - similar to how event classes are defined.
>
> perhaps naming this macro:
>
> DEFINE_TDX_METADATA_READER() ought to be more descriptive, also the
> "md" contraction of metadata also seems a bit quirky (at least to me).
>
> It's not a deal breaker but if there is going to be another posting this
> might be something to consider.
>
Thanks for the comments.
I don't have opinion on this. Dan said we can do something like
build_mmio_read() macro and this is where build_sysmd_read() came from. Dan
used build_tdg_sys_rd() in his patch too:
https://lore.kernel.org/all/172618717675.516322.6087817418162288917.stgit@dwillia2-xfh.jf.intel.com/
Btw I actually agree that your DEFINE_xx() is more formal thus is better when
the macro is used by multiple C files. But here only tdx.c uses it, and IMHO
it's also fine to have a informal but shorter name here.
Anyway let's see whether other people have anything to say.
next prev parent reply other threads:[~2024-09-26 12:13 UTC|newest]
Thread overview: 24+ messages / expand[flat|nested] mbox.gz Atom feed top
2024-09-24 11:28 [PATCH v4 0/8] TDX host: metadata reading tweaks, bug fix and info dump Kai Huang
2024-09-24 11:28 ` [PATCH v4 1/8] x86/virt/tdx: Rename 'struct tdx_tdmr_sysinfo' to reflect the spec better Kai Huang
2024-09-24 11:28 ` [PATCH v4 2/8] x86/virt/tdx: Rework TD_SYSINFO_MAP to support build-time verification Kai Huang
2024-09-24 11:28 ` [PATCH v4 3/8] x86/virt/tdx: Prepare to support reading other global metadata fields Kai Huang
2024-09-26 6:27 ` Nikolay Borisov
2024-09-26 12:13 ` Huang, Kai [this message]
2024-09-26 15:47 ` Dave Hansen
2024-09-26 22:22 ` Huang, Kai
2024-09-26 22:26 ` Dave Hansen
2024-09-26 23:05 ` Huang, Kai
2024-10-01 7:56 ` Dan Williams
2024-10-01 10:44 ` Huang, Kai
2024-10-01 15:19 ` Dave Hansen
2024-10-01 21:40 ` Huang, Kai
2024-10-07 3:07 ` Huang, Kai
2024-10-07 3:44 ` Dave Hansen
2024-10-07 6:53 ` Huang, Kai
2024-10-09 11:10 ` Huang, Kai
2024-09-24 11:28 ` [PATCH v4 4/8] x86/virt/tdx: Refine a comment to reflect the latest TDX spec Kai Huang
2024-09-24 11:28 ` [PATCH v4 5/8] x86/virt/tdx: Start to track all global metadata in one structure Kai Huang
2024-09-26 6:21 ` Nikolay Borisov
2024-09-24 11:28 ` [PATCH v4 6/8] x86/virt/tdx: Print TDX module version Kai Huang
2024-09-24 11:28 ` [PATCH v4 7/8] x86/virt/tdx: Require the module to assert it has the NO_RBP_MOD mitigation Kai Huang
2024-09-24 11:28 ` [PATCH v4 8/8] x86/virt/tdx: Reduce TDMR's reserved areas by using CMRs to find memory holes Kai Huang
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1e9270cabe2217e4299ea52adf2a87874459490e.camel@intel.com \
--to=kai.huang@intel.com \
--cc=adrian.hunter@intel.com \
--cc=bp@alien8.de \
--cc=dan.j.williams@intel.com \
--cc=dave.hansen@intel.com \
--cc=hpa@zytor.com \
--cc=isaku.yamahata@intel.com \
--cc=kirill.shutemov@linux.intel.com \
--cc=kvm@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=mingo@redhat.com \
--cc=nik.borisov@suse.com \
--cc=pbonzini@redhat.com \
--cc=peterz@infradead.org \
--cc=rick.p.edgecombe@intel.com \
--cc=seanjc@google.com \
--cc=tglx@linutronix.de \
--cc=x86@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®