From: Alex Hung <alex.hung@amd.com>
To: "Ethan Carter Edwards" <ethan@ethancedwards.com>,
"Harry Wentland" <harry.wentland@amd.com>,
"Leo Li" <sunpeng.li@amd.com>,
"Rodrigo Siqueira" <siqueira@igalia.com>,
"Alex Deucher" <alexander.deucher@amd.com>,
"Christian König" <christian.koenig@amd.com>,
"David Airlie" <airlied@gmail.com>,
"Simona Vetter" <simona@ffwll.ch>
Cc: amd-gfx@lists.freedesktop.org, dri-devel@lists.freedesktop.org,
linux-kernel@vger.kernel.org, linux-hardening@vger.kernel.org
Subject: Re: [PATCH 0/4] drm/amd/display: move from kzalloc(size * nr, ...) to kcalloc(nr, size, ...)
Date: Thu, 6 Mar 2025 14:24:55 -0700 [thread overview]
Message-ID: <1e9cdcd7-b0a6-4c87-a5bb-b8e637ad8d49@amd.com> (raw)
In-Reply-To: <20250227-amd-display-v1-0-52a060a78d08@ethancedwards.com>
This series LGTM too.
Reviewed-by: Alex Hung <alex.hung@amd.com>
On 2/27/25 16:16, Ethan Carter Edwards wrote:
> We are trying to get rid of all multiplications from allocation
> functions to prevent integer overflows. Here the multiplications are
> probably safe, but using kcalloc() is more appropriate and improves
> readability. It is also safer. This series contains a few patches
> with these fixes.
>
> Part of the Kernel Self Protection Project efforts. Links below have
> more details.
>
> Link: https://github.com/KSPP/linux/issues/162
> Link: https://www.kernel.org/doc/html/next/process/deprecated.html#open-coded-arithmetic-in-allocator-arguments
>
> Signed-off-by: Ethan Carter Edwards <ethan@ethancedwards.com>
> ---
> Ethan Carter Edwards (4):
> drm/amd/display: change kzalloc to kcalloc in dcn30_validate_bandwidth()
> drm/amd/display: change kzalloc to kcalloc in dcn31_validate_bandwidth()
> drm/amd/display: change kzalloc to kcalloc in dcn314_validate_bandwidth()
> drm/amd/display: change kzalloc to kcalloc in dml1_validate()
>
> drivers/gpu/drm/amd/display/dc/resource/dcn30/dcn30_resource.c | 3 ++-
> drivers/gpu/drm/amd/display/dc/resource/dcn31/dcn31_resource.c | 3 ++-
> drivers/gpu/drm/amd/display/dc/resource/dcn314/dcn314_resource.c | 3 ++-
> drivers/gpu/drm/amd/display/dc/resource/dcn32/dcn32_resource.c | 3 ++-
> 4 files changed, 8 insertions(+), 4 deletions(-)
> ---
> base-commit: be5c7bbb3a64baf884481a1ba0c2f8fb2f93f7c3
> change-id: 20250227-amd-display-a8342c55a9a0
>
> Best regards,
prev parent reply other threads:[~2025-03-06 21:25 UTC|newest]
Thread overview: 7+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-02-27 23:16 Ethan Carter Edwards
2025-02-27 23:16 ` [PATCH 1/4] drm/amd/display: change kzalloc to kcalloc in dcn30_validate_bandwidth() Ethan Carter Edwards
2025-02-27 23:16 ` [PATCH 2/4] drm/amd/display: change kzalloc to kcalloc in dcn31_validate_bandwidth() Ethan Carter Edwards
2025-02-27 23:16 ` [PATCH 3/4] drm/amd/display: change kzalloc to kcalloc in dcn314_validate_bandwidth() Ethan Carter Edwards
2025-02-27 23:16 ` [PATCH 4/4] drm/amd/display: change kzalloc to kcalloc in dml1_validate() Ethan Carter Edwards
2025-03-04 18:12 ` [PATCH 0/4] drm/amd/display: move from kzalloc(size * nr, ...) to kcalloc(nr, size, ...) Rodrigo Siqueira
2025-03-06 21:24 ` Alex Hung [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1e9cdcd7-b0a6-4c87-a5bb-b8e637ad8d49@amd.com \
--to=alex.hung@amd.com \
--cc=airlied@gmail.com \
--cc=alexander.deucher@amd.com \
--cc=amd-gfx@lists.freedesktop.org \
--cc=christian.koenig@amd.com \
--cc=dri-devel@lists.freedesktop.org \
--cc=ethan@ethancedwards.com \
--cc=harry.wentland@amd.com \
--cc=linux-hardening@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=simona@ffwll.ch \
--cc=siqueira@igalia.com \
--cc=sunpeng.li@amd.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®