From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: X-Spam-Checker-Version: SpamAssassin 3.4.0 (2014-02-07) on aws-us-west-2-korg-lkml-1.web.codeaurora.org X-Spam-Level: X-Spam-Status: No, score=-5.3 required=3.0 tests=BAYES_00, HEADER_FROM_DIFFERENT_DOMAINS,MAILING_LIST_MULTI,NICE_REPLY_A,SPF_HELO_NONE, SPF_PASS,USER_AGENT_SANE_1 autolearn=no autolearn_force=no version=3.4.0 Received: from mail.kernel.org (mail.kernel.org [198.145.29.99]) by smtp.lore.kernel.org (Postfix) with ESMTP id 8F445C388F7 for ; Thu, 5 Nov 2020 11:39:39 +0000 (UTC) Received: from vger.kernel.org (vger.kernel.org [23.128.96.18]) by mail.kernel.org (Postfix) with ESMTP id 46AA4206FB for ; Thu, 5 Nov 2020 11:39:39 +0000 (UTC) Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1730258AbgKELjg (ORCPT ); Thu, 5 Nov 2020 06:39:36 -0500 Received: from foss.arm.com ([217.140.110.172]:58352 "EHLO foss.arm.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1730068AbgKELjZ (ORCPT ); Thu, 5 Nov 2020 06:39:25 -0500 Received: from usa-sjc-imap-foss1.foss.arm.com (unknown [10.121.207.14]) by usa-sjc-mx-foss1.foss.arm.com (Postfix) with ESMTP id BAEBB142F; Thu, 5 Nov 2020 03:39:24 -0800 (PST) Received: from [10.37.12.41] (unknown [10.37.12.41]) by usa-sjc-imap-foss1.foss.arm.com (Postfix) with ESMTPSA id 5AD083F719; Thu, 5 Nov 2020 03:39:22 -0800 (PST) Subject: Re: [PATCH v8 30/43] arm64: kasan: Allow enabling in-kernel MTE To: Andrey Konovalov Cc: Catalin Marinas , Will Deacon , Dmitry Vyukov , Andrey Ryabinin , Alexander Potapenko , Marco Elver , Evgenii Stepanov , Branislav Rankov , Kevin Brodsky , Andrew Morton , kasan-dev , Linux ARM , Linux Memory Management List , LKML References: <5e3c76cac4b161fe39e3fc8ace614400bc2fb5b1.1604531793.git.andreyknvl@google.com> <58aae616-f1be-d626-de16-af48cc2512b0@arm.com> From: Vincenzo Frascino Message-ID: <1ef3f645-8b91-cfcf-811e-85123fea90fa@arm.com> Date: Thu, 5 Nov 2020 11:42:23 +0000 User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:68.0) Gecko/20100101 Thunderbird/68.10.0 MIME-Version: 1.0 In-Reply-To: Content-Type: text/plain; charset=utf-8 Content-Language: en-US Content-Transfer-Encoding: 7bit Precedence: bulk List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On 11/5/20 11:35 AM, Andrey Konovalov wrote: > This will work. Any preference on the name of this function? > I called it in my current iteration mte_enable(), and calling it from cpu_enable_mte(). > Alternatively we can rename mte_init_tags() to something else and let > it handle both RRND and sync/async. This is an option but then you need to change the name of kasan_init_tags and the init_tags indirection name as well. I would go for the simpler and just splitting the function as per above. What do you think? -- Regards, Vincenzo