From: Hans de Goede <hdegoede@redhat.com>
To: Benjamin Tissoires <benjamin.tissoires@redhat.com>, robh@kernel.org
Cc: "Dmitry Torokhov" <dmitry.torokhov@gmail.com>,
廖崇榮 <kt.liao@emc.com.tw>,
"open list:HID CORE LAYER" <linux-input@vger.kernel.org>,
lkml <linux-kernel@vger.kernel.org>,
devicetree@vger.kernel.org
Subject: Re: [PATCH 3/5] dt-bindings: add more optional properties for elan_i2c touchpads
Date: Thu, 18 Oct 2018 10:39:39 +0200 [thread overview]
Message-ID: <1fb98946-a518-d7d7-3bec-8944be95b91c@redhat.com> (raw)
In-Reply-To: <CAO-hwJ+z6YdnLdbzeh-7f99cBBjHfbLKLzKo-fQQaC_W8bt_Uw@mail.gmail.com>
Hi,
On 18-10-18 10:10, Benjamin Tissoires wrote:
> On Wed, Oct 17, 2018 at 10:15 PM Rob Herring <robh@kernel.org> wrote:
>>
>> On Fri, Oct 12, 2018 at 04:24:11PM +0200, Benjamin Tissoires wrote:
>>> Some new touchpads IC are connected through PS/2 and I2C. On some of these
>>> new IC, the I2C part doesn't have all of the information available.
>>> We need to be able to forward the touchpad parameters from PS/2 and
>>> thus, we need those new optional properties.
>>>
>>> Link: https://bugzilla.redhat.com/show_bug.cgi?id=1628715
>>> Signed-off-by: Benjamin Tissoires <benjamin.tissoires@redhat.com>
>>> ---
>>> Documentation/devicetree/bindings/input/elan_i2c.txt | 8 ++++++++
>>> 1 file changed, 8 insertions(+)
>>>
>>> diff --git a/Documentation/devicetree/bindings/input/elan_i2c.txt b/Documentation/devicetree/bindings/input/elan_i2c.txt
>>> index 797607460735..ace6bcb0b4eb 100644
>>> --- a/Documentation/devicetree/bindings/input/elan_i2c.txt
>>> +++ b/Documentation/devicetree/bindings/input/elan_i2c.txt
>>> @@ -13,6 +13,14 @@ Optional properties:
>>> pinctrl binding [1]).
>>> - vcc-supply: a phandle for the regulator supplying 3.3V power.
>>> - elan,trackpoint: touchpad can support a trackpoint (boolean)
>>> +- elan,clickpad: touchpad is a clickpad (the entire surface is a button)
>>
>>> +- elan,max_x: the maximum reported value on the X axis
>>> +- elan,max_y: the maximum reported value on the Y axis
>>> +- elan,min_x: the minimum reported value on the X axis
>>> +- elan,min_y: the minimum reported value on the Y axis
>>> +- elan,x_res: the resolution of the X axis (in units per mm)
>>> +- elan,y_res: the resolution of the Y axis (in units per mm)
>>> +- elan,width: max reported width of a blob
>>
>> Can't we use standard touchscreen properties here? (Yes, I get this is a
>> touchpad, not touchscreen).
>
> Hey Rob,
>
> Well, there is that (it's a touchpad driver) and we can't also really
> use the of_touchscreen.c implementation.
> If both concerns are not an issue, we can then move the [min/max/res]
> properties to the touchscreen ones.
>
> Regarding 'elan,width', this is something missing from the standard ts
> properties, and AFAICT, this controls the maximum reported
> width/height of a touch.
> I should probably rename them to max_width, max_height.
>
> Hans, do you think we should add such properties to of_touchscreen.c
> too? (the width/height ones)
Are there touchscreens which report finger/touch width / height ? if so
then it probably does make sense. Note that for historical reasons
Documentation/devicetree/bindings/input/touchscreen/touchscreen.txt
Also the touchscreen bindings have: touchscreen-x-mm and touchscreen-y-mm
rather then res, which can then be used to calculate the resolution.
Regards,
Hans
next prev parent reply other threads:[~2018-10-18 8:39 UTC|newest]
Thread overview: 14+ messages / expand[flat|nested] mbox.gz Atom feed top
2018-10-12 14:24 [PATCH 0/5] Fix Elan I2C touchpads in latest generation from Lenovo Benjamin Tissoires
2018-10-12 14:24 ` [PATCH 1/5] Input: elantech - query the min/max information beforehand too Benjamin Tissoires
2018-10-12 14:24 ` [PATCH 2/5] Input: elantech - add helper function elantech_is_buttonpad() Benjamin Tissoires
2018-10-12 14:24 ` [PATCH 3/5] dt-bindings: add more optional properties for elan_i2c touchpads Benjamin Tissoires
2018-10-17 20:15 ` Rob Herring
2018-10-18 8:10 ` Benjamin Tissoires
2018-10-18 8:39 ` Hans de Goede [this message]
2018-10-18 8:44 ` Benjamin Tissoires
2018-10-18 8:51 ` Hans de Goede
2018-10-18 13:04 ` Rob Herring
2018-10-12 14:24 ` [PATCH 4/5] Input: elan_i2c - do not query the info if they are provided Benjamin Tissoires
2018-10-12 14:24 ` [PATCH 5/5] Input: elantech/SMBus - export all capabilities from the PS/2 node Benjamin Tissoires
2018-10-12 18:53 ` [PATCH 0/5] Fix Elan I2C touchpads in latest generation from Lenovo Dmitry Torokhov
2018-10-12 19:07 ` Benjamin Tissoires
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1fb98946-a518-d7d7-3bec-8944be95b91c@redhat.com \
--to=hdegoede@redhat.com \
--cc=benjamin.tissoires@redhat.com \
--cc=devicetree@vger.kernel.org \
--cc=dmitry.torokhov@gmail.com \
--cc=kt.liao@emc.com.tw \
--cc=linux-input@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=robh@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®