On Wed, Aug 15 2001, David S. Miller wrote: > From: Jens Axboe > Date: Wed, 15 Aug 2001 09:50:18 +0200 > > Dave, comments on that? > > I think the new-style sg_list is slightly overkill, too much > stuff. You need much less, in fact, especially on x86. > > Take include/linux/skbuff.h:skb_frag_struct, rename it to > sg_list and add a dma_addr_t. You should need nothing else. > The bounce page, for example, is superfluous. Ok, here's an updated version. Maybe modulo the struct scatterlist changes, I'd like to see this included in 2.4.x soonish. Or at least the interface we agree on -- it'll make my life easier at least. And finally provide driver authors with something not quite as stupid as struct scatterlist. -- Jens Axboe