From: Christoph Hellwig <hch@infradead.org>
To: Patricia Gaughen <gone@us.ibm.com>
Cc: marcelo@conectiva.com.br, linux-kernel@vger.kernel.org
Subject: Re: [PATCH] discontigmem support for ia32 NUMA box against 2.4.19pre8
Date: Thu, 9 May 2002 20:32:02 +0100 [thread overview]
Message-ID: <20020509203202.A27148@infradead.org> (raw)
In-Reply-To: <hch@infradead.org> <200205091840.g49Ie3C02733@w-gaughen.des.beaverton.ibm.com>
On Thu, May 09, 2002 at 11:40:03AM -0700, Patricia Gaughen wrote:
> > Urgg, sourceforge seems to have turned these nice links into some download
> > selector crap. I think it's really time to stop using it as it gets worse
> > all time..
> > Any chance you could post links directly to one of the mirrors next time?
>
> Do you want something like this:
>
> http://prdownloads.sourceforge.net/lse/x86_discontigmem-2.4.19pre8.patch?use_mi
> rror=unc
Seems to have the same problems. The following seems to work nicely for me:
http://belnet.dl.sourceforge.net/sourceforge/lse/x86_discontigmem-2.4.19pre8.patch
>
> oh man, and I just added that in to core_ibmnumaq.c :-)
>
> you're right, the naming was based on alpha's naming scheme, will change it.
Btw, please also do a s/ibmnumaq/numaq/. Everyone actually reading
the code should know it's from IBM and given that the design actually
originated at Sequent..
> > Okay, this comes to the next issue, you seem to use CONFIG_DISCONTIGMEM
> > and CONFIG_X86_DISCONTIGMEM interchangable in arch/i386/* and numa.c in
> > fact has a big #ifdef CONFIG_X86_DISCONTIGMEM around all of the code.
> > AFAICS CONFIG_X86_DISCONTIGMEM is really the selector for the bootmem
> > workarounds and I think it shouldn't be used anywhere else, or even better
> > replaced by and HAVE_ARCH_BOOTMEM_NODE #define in asm/pgtable.h.
>
> yes, I agree and that was my intention with CONFIG_X86_DISCONTIGMEM. I'll fix
> them.
>
> Let me make sure I understand what you mean, you're thing that
> HAVE_ARCH_BOOTMEM_NODE should be turned on in asm/pgtable.h when
> CONFIG_DISCONTIGMEM is defined? If that's so, I'll make the change.
For i386, yes. It looks to me (please correct me that I'm wrong), that
the ifdefs in bootmem.h are to allow architecture-specific versions
of the *_node functions. This could also be needed by other architectures
and really isn't a config options. I think because of this such a
feature-define looks more apropinquate to me then a CONFIG_ option.
next prev parent reply other threads:[~2002-05-09 19:32 UTC|newest]
Thread overview: 9+ messages / expand[flat|nested] mbox.gz Atom feed top
2002-05-09 0:19 Patricia Gaughen
2002-05-09 9:28 ` Christoph Hellwig
2002-05-09 18:40 ` Patricia Gaughen
2002-05-09 19:32 ` Christoph Hellwig [this message]
2002-05-10 1:30 ` Patricia Gaughen
2002-05-10 8:24 ` Christoph Hellwig
2002-05-10 15:11 ` Martin J. Bligh
2002-05-15 10:14 ` Pavel Machek
2002-05-15 12:47 ` Rik van Riel
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20020509203202.A27148@infradead.org \
--to=hch@infradead.org \
--cc=gone@us.ibm.com \
--cc=linux-kernel@vger.kernel.org \
--cc=marcelo@conectiva.com.br \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®