mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: "David S. Miller" <davem@redhat.com>
To: kaos@ocs.com.au
Cc: linux-kernel@vger.kernel.org
Subject: Re: Unix-domain sockets - abstract addresses
Date: Sun, 11 Aug 2002 19:59:06 -0700 (PDT)	[thread overview]
Message-ID: <20020811.195906.107999483.davem@redhat.com> (raw)
In-Reply-To: <649.1029121193@kao2.melbourne.sgi.com>

   From: Keith Owens <kaos@ocs.com.au>
   Date: Mon, 12 Aug 2002 12:59:53 +1000

   On Sun, 11 Aug 2002 21:35:05 -0500 (CDT), 
   Oliver Xymoron <oxymoron@waste.org> wrote:
   >Might it be simpler to change the overall module name? unix.o is an
   >especially poor choice of names, compiler defines aside.
   
   I prefer that option, expect that it changes the name of a module.  Not
   that we haven't done that before ...
   
   A module name of af_unix would be much better, like af_packet.  It
   would require changing the name of af_unix.c (source and conglomerate
   objects cannot have the same basename) and a change to modutils to map
   net-pf-1 to af_unix.

I don't like this solution, please fix this right and get rid of the
limitations at their source.

If I name a module "foo" and this causes "fo" to become a defined
CPP symbol in when compiling the sources for that module, that is
completely broken!

net/unix is just a trite example.  How about a driver for device "foo"
that has a member "foo" in one of it's structures?  They have to get
this undef thing too or rename their module, that's rediculious.

  reply	other threads:[~2002-08-12  3:08 UTC|newest]

Thread overview: 21+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2002-08-08 16:15 Michael Procter
2002-08-08 18:36 ` kuznet
2002-08-09  0:29   ` Thunder from the hill
2002-08-09 13:52   ` Michael Procter
2002-08-09 16:15     ` kuznet
2002-08-09 22:33     ` Thunder from the hill
2002-08-10  1:05       ` David S. Miller
2002-08-10  1:35         ` Keith Owens
2002-08-10  1:41           ` David S. Miller
2002-08-10  2:19             ` Keith Owens
2002-08-10  2:15               ` David S. Miller
2002-08-10 10:59               ` Roman Zippel
2002-08-12  2:35               ` Oliver Xymoron
2002-08-12  2:59                 ` Keith Owens
2002-08-12  2:59                   ` David S. Miller [this message]
2002-08-12  3:20                     ` Keith Owens
2002-08-12  3:13                       ` David S. Miller
2002-08-12  3:57                         ` Keith Owens
2002-08-12  7:13                           ` Eric W. Biederman
2002-08-12 14:28                           ` David Woodhouse
2002-08-10  6:29         ` Thunder from the hill

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20020811.195906.107999483.davem@redhat.com \
    --to=davem@redhat.com \
    --cc=kaos@ocs.com.au \
    --cc=linux-kernel@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®