mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Ivan Kokshaysky <ink@jurassic.park.msu.ru>
To: Linus Torvalds <torvalds@transmeta.com>
Cc: Manfred Spraul <manfred@colorfullife.com>, linux-kernel@vger.kernel.org
Subject: Re: [patch 2.5.31] transparent PCI-to-PCI bridges
Date: Wed, 28 Aug 2002 04:58:02 +0400	[thread overview]
Message-ID: <20020828045802.A31036@jurassic.park.msu.ru> (raw)
In-Reply-To: <Pine.LNX.4.33.0208261038440.15474-100000@penguin.transmeta.com>; from torvalds@transmeta.com on Mon, Aug 26, 2002 at 10:42:34AM -0700

On Mon, Aug 26, 2002 at 10:42:34AM -0700, Linus Torvalds wrote:
> Please don't do it like this: I hate code that changes standard PCI data 
> structure meaning (in this case the "class" thing) behind peoples back.. 

Fairly speaking, I wasn't happy about that either - that's why
I tried to change only a single bit in the first patch.
Note that this stuff was intended for 2.4 in the first place :-)

> So instead, I would suggest that you add a single-bit "transparent" field
> to the PCI structure, and initialize it to "(class & 0xff) == 1" when
> initializing the device data. Then, any fixup can just set the transparent
> bit to 1.
> 
> That would make the code more robust, and more readable in my opionion.
> 
> Ok?

Agreed.
I would even go further and add a "quirks" field to the struct
pci_dev (probably 16 bits would be enough). Thus we can define
specific bits for common PCI bugs - not only QUIRK_TRANSPARENT_BRIDGE
but also things like QUIRK_BROKEN_MWI or even
QUIRK_SOME_COMMON_PCI_IDE_BUG and so on. This would allow generic code
to check a single bit instead of looking through several
vendor/device ID lists.

Thoughts?

Ivan.

  reply	other threads:[~2002-08-28  0:53 UTC|newest]

Thread overview: 26+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2002-08-25 16:55 Manfred Spraul
2002-08-26 13:57 ` Ivan Kokshaysky
2002-08-26 17:42   ` Linus Torvalds
2002-08-28  0:58     ` Ivan Kokshaysky [this message]
2002-08-28  1:29       ` Linus Torvalds
2002-08-30 21:38         ` [patch 2.5.32] " Ivan Kokshaysky
2002-08-26 20:12   ` [patch 2.5.31] " Benjamin Herrenschmidt
2002-08-28  1:40     ` Ivan Kokshaysky
2002-08-28 10:03       ` Benjamin Herrenschmidt
2002-08-28 17:35         ` Linus Torvalds
2002-08-28 18:35           ` Benjamin Herrenschmidt
2002-08-29 23:53           ` Ivan Kokshaysky
2002-08-30  9:28             ` Benjamin Herrenschmidt
2002-08-30 21:57               ` Ivan Kokshaysky
2002-08-30 20:19                 ` Benjamin Herrenschmidt
2002-08-31 10:42                   ` Ivan Kokshaysky
2002-08-31 15:06                     ` Alan Cox
2002-08-31 16:49                       ` Linus Torvalds
2002-08-31 22:40                         ` Ivan Kokshaysky
2002-08-31  8:09                 ` Benjamin Herrenschmidt
2002-08-30 17:12             ` Linus Torvalds
2002-08-30 22:23               ` Ivan Kokshaysky
2002-08-31  8:09                 ` Benjamin Herrenschmidt
2002-08-31 13:12                   ` Ivan Kokshaysky
2002-08-31 16:29                 ` Linus Torvalds
  -- strict thread matches above, loose matches on Subject: below --
2002-08-24 20:17 Ivan Kokshaysky

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20020828045802.A31036@jurassic.park.msu.ru \
    --to=ink@jurassic.park.msu.ru \
    --cc=linux-kernel@vger.kernel.org \
    --cc=manfred@colorfullife.com \
    --cc=torvalds@transmeta.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®