From: Brice Goglin <bgoglin@ens-lyon.fr>
To: linux-kernel@vger.kernel.org
Subject: Duplicated code in grab_cache_page, __grab_cache_page, ...
Date: Wed, 13 Nov 2002 12:06:01 +0100 [thread overview]
Message-ID: <20021113110601.GE11564@ens-lyon.fr> (raw)
Hi,
I noticed a large part of code which looks duplicated
in __grab_cache_page, grab_cache_page (and some parts of
do_generic_file_read (in the "no_cached_page:" section))
in mm/filemap.c.
I do not see the real difference between grab_cache_page
and __grab_cache_page (except the additional
"struct page *cached_page" argument).
The fact that the first one is exported while the second
one is static looks strange to me.
Why not exporting both of them if the are really different ?
Or why not merging them into a general purpose grab_cache_page ?
I've seen some small changes during 2.5 developpement
(grab_cache_page moved to pagemap.h, __grab_cache_page
got a new argument).
I'd like to know whether you planned to clean this point
in future 2.5 revisions ?
Regards
--
Brice Goglin,
Laboratoire de l'Informatique du Parallelisme
ENS Lyon - 46 allée d'Italie
69007 LYON - France
reply other threads:[~2002-11-13 10:59 UTC|newest]
Thread overview: [no followups] expand[flat|nested] mbox.gz Atom feed
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20021113110601.GE11564@ens-lyon.fr \
--to=bgoglin@ens-lyon.fr \
--cc=linux-kernel@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®