mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Russell King <rmk@arm.linux.org.uk>
To: Dave Airlie <airlied@linux.ie>
Cc: linux-kernel@vger.kernel.org
Subject: Re: IRQ_NONE definition in NCR5380 driver...
Date: Fri, 30 May 2003 09:16:06 +0100	[thread overview]
Message-ID: <20030530091606.A7813@flint.arm.linux.org.uk> (raw)
In-Reply-To: <Pine.LNX.4.53.0305300024550.14345@skynet>; from airlied@linux.ie on Fri, May 30, 2003 at 12:27:25AM +0100

On Fri, May 30, 2003 at 12:27:25AM +0100, Dave Airlie wrote:
> Currently the NCR5380.h defines IRQ_NONE to be 255, is there any special
> reason for this? why not use UINT32_MAX-1?..
> 
> The VAX actually has got more than 255 interrupt handlers which we've
> mapped to IRQs, and it happens the external SCSI interface is at 255, so
> this makes it a bit sick...
> 
> I've redefined it in our tree to 65535 but I see no reason not to go to
> the above... any objections?

Only that ARM already has a NO_IRQ macro fairly well established for this
thing, which should probably be propagated to the other architectures.
Could we call it NO_IRQ instead?

I seem to remember that in the dim and distant past, several drivers
used to store IRQ numbers in byte-sized objects, so this would need to
be fixed before making NO_IRQ > 255.

-- 
Russell King (rmk@arm.linux.org.uk)                The developer of ARM Linux
             http://www.arm.linux.org.uk/personal/aboutme.html


  reply	other threads:[~2003-05-30  8:02 UTC|newest]

Thread overview: 3+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2003-05-29 23:27 Dave Airlie
2003-05-30  8:16 ` Russell King [this message]
2003-05-30  9:39 ` Alan Cox

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20030530091606.A7813@flint.arm.linux.org.uk \
    --to=rmk@arm.linux.org.uk \
    --cc=airlied@linux.ie \
    --cc=linux-kernel@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®