From: Pavel Machek <pavel@ucw.cz>
To: Dave Jones <davej@redhat.com>,
Mitchell Blank Jr <mitch@sfgoth.com>,
Andrew Morton <akpm@osdl.org>,
linux-kernel@vger.kernel.org
Subject: Re: [PATCH] oops_in_progress is unlikely()
Date: Wed, 10 Sep 2003 17:29:02 +0200 [thread overview]
Message-ID: <20030910152902.GA2764@elf.ucw.cz> (raw)
In-Reply-To: <20030910142308.GL932@redhat.com>
Hi!
> > > none of this patch seems to touch particularly performance critical code.
> > > Is it really worth adding these macros to every if statement in the kernel?
> > > There comes a point where readability is lost, for no measurable gain.
> >
> > Perhaps we should have macros ifu() and ifl(), that would be used as a
> > plain if, just with likelyness-indication? That way we could have it
> > in *every* statement and readability would not suffer that much...
>
> You've got to be kidding.
I'm pretty serious.
ifu (a==b) {
something();
}
looks better than
if (unlikely(a==b)) {
something();
}
sched.c alone probably would get more readable as a result of such
conversion...
[Okay, having it at every statement is prbably bad idea.]
Pavel
--
When do you have a heart between your knees?
[Johanka's followup: and *two* hearts?]
next prev parent reply other threads:[~2003-09-10 15:29 UTC|newest]
Thread overview: 15+ messages / expand[flat|nested] mbox.gz Atom feed top
2003-09-07 6:42 Mitchell Blank Jr
2003-09-07 22:13 ` Dave Jones
2003-09-10 14:20 ` Pavel Machek
2003-09-10 14:23 ` Dave Jones
2003-09-10 15:29 ` Pavel Machek [this message]
2003-09-10 16:07 ` Richard B. Johnson
2003-09-10 18:31 ` Jamie Lokier
2003-09-10 18:58 ` Richard B. Johnson
2003-09-10 19:02 ` Pavel Machek
2003-09-10 20:12 ` Jamie Lokier
2003-09-10 20:32 ` Richard B. Johnson
2003-09-10 21:27 ` Pavel Machek
2003-09-10 21:52 ` Jamie Lokier
2003-09-10 21:46 ` Jamie Lokier
2003-09-12 5:12 ` Mitchell Blank Jr
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20030910152902.GA2764@elf.ucw.cz \
--to=pavel@ucw.cz \
--cc=akpm@osdl.org \
--cc=davej@redhat.com \
--cc=linux-kernel@vger.kernel.org \
--cc=mitch@sfgoth.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome