On Thu, Oct 09, 2003 at 12:42:18PM +0200, Andi Kleen wrote: > I added a new argument force==2 to get_user_pages that means to ignore > SIGBUS or unaccessible pages errors. MAY_* is still checked for like > with the old force ==1, it just doesn't error out now for SIGBUS > errors on handle_mm_fault. How about making it an enum or define for code readability? I'd much rather see an IGNORE_BAD_PAGES or some such than a cryptic '2' in the code. I can send a patch to that effect if you'd like? Cheers, Muli -- Muli Ben-Yehuda http://www.mulix.org